Which cable do you need for Spectrum?

I’d like to be able to connect my Eve V to my Spectrum with one USB C cable for charging, data, and video. It won’t work with just any USB C cable, so are there any that can do 4K 144hz and charge my computer?

Will this one work? :

Anything that says it does 40Gbps with 100W charging should be good.

That Anker cable looks like it’ll do the job. I bought a 50cm Ugreen cable (Amazon UK) and it’s working nicely (albeit using 4K@60Hz because MacBook and Big Sur).

1 Like

I just got the Anker USB-C to USB-C Thunderbolt 4.0 100W cable and can confirm that when connected to the Eve V, it can charge, sync, and display video perfectly through one cable!

Also just connected my Razer mouse and keyboard to the USB A ports so now I can transform my tablet pc into a desktop pc with one cable! super simple and quick setup.


I’m going to try this wire I’ve tried the Plugable Thunderbolt 3 Cable 40Gbps Supports 100W which works on my lg 4k monitor but not on the Eve Spectrum for display at least.

Unless there is a setting on the monitor that I’m messing up on I can’t get any display with the usb c port even with the anker cable. I’m using the bottom port too. Am I really the only one with this issue on a windows laptop?

Just to check, but is the usb-c port on your computer Thunderbolt 3 compatible? I tested it with the V, and it only works when I used a Thunderbolt 3 USB C port on both the computer and the monitor.

Yes I’m using a Razor blade 15 with an i7- 9750H and 2060 and both my thunderbot 3 cables give me a display on my LG monitor

This may sound dumb, but I have another troubleshooting idea, is the input set to UBC-C? It could be possible it’s looking for a signal from a different port. If Both of the ports are TB 3 and the input’s set to USB-C and it still doesn’t work, maybe do a power cycle. After that, I’m out of ideas.

1 Like

I’m also assuming that Spectrum is fully plugged into both a good outlet (sometimes it’s that) and the AC adapter, and the monitor is powered on (the button under the joystick). If it’s still not working maybe it’s faulty.

1 Like

I’ve tried both usb settings, unplugged other cables even tried the other usb c port on the off chance it was installed incorrectly. I’ll try plugging it directly into the wall and check, until checking with my other monitor I thought it was the cable or something I did wrong since no one seems to be having an issue on windows but me.