Waking From Sleep Spectrum Monitor

Hello.

I just started using the Spectrum monitor and have been having issues regarding the monitor.

  1. When the PC is locked, after about 60 seconds the monitor should go into sleep mode. In Spectrums case, the monitor backlight stays on but just shows a black screen. The other monitors (Acer 1080p monitors) turn themselves off completely as they should. See below image.
    PXL_20220325_045152925 - Copy

  2. When waking from sleep. The Spectrum monitor seems to disconnect and then reconnect as I can here the Windows notification sounds when a device connects and reconnects. Once the monitor turns back on and I sign into Windows. I can see that all my open windows are pushed into the top left corner like the display reset itself to 1080 resolution and then back to 4K resolution.

What is going on here?

2 Likes

Hi @ThePie,

I am going to link to relevant topics similar to your case here:

It is a well-documented issue, and we are trying to find the root cause of it and working on a possible firmware update to fix it.

For some, enabling the VRR function seems to mitigate the issue, but your results may vary.

Thanks @Cas. Replied to the first thread with my version number and GPU I am using. Can provide more information if required.

2 Likes

Hey, Zak (@ThePie ), and welcome to the Eve community!

Among the different hats I wear here, one of them is firmware liaison, in that I kinda keep information and ideas flowing between the firmware developer team (fw dev team) and the community members. I also checked out your reply to the ‘Backlight stays on’ topic.

This is one of those “WTF?” issues that makes 0 sense. Let me give you a little background on my end.

I started with the Spectrum Test unit back in May of last year - right before the Windows 11 beta was opened to the public. At that time I had an eVGA GTX 970 SSC, although the rest of my rig was much more modern - Ryzen 9 3950x, 128 GB DDR4 @ 3600 MHz, 3x Sabrent NVMe Rocket 4.0 1 TB drives…and I had 0 issues on Windows 10. I upgrade to Windows 11 beta, 0 issues, I then clean installed Windows 11 on Beta 2 and still had no issues. In October, when it was released to manufacturing and then to the public, I clean installed again, still no issues.

I did another clean install in February after I got a sweet deal on a trio of Samsung 980 Pro NVMe drives - these were 2 TB capacity. And still no issues.

However - when I got another sweet (bundle) deal on an eVGA RTX 3080 Ti XC3, quite literally, all hell broke loose.

All of a sudden, things are less stable. The biggest issue I noticed overnight after installing the card, and cleanly installing the 511.79 drivers again was the lack of sleep. The second biggest I noticed was weird flickering, The third was that, on power up, sometimes it takes me 3-4 forced reboots (via the reset button) for the Spectrum to get an image on the screen from my booting computer. Some of this sound familiar?

The thing is - for all intents and purposes, only one thing changed, and it almost has to be the direct cause of the issues. It’s still the same monitor, the same system, the same OS - literally the only thing that changed was my GPU. But it is a critical difference, and I’ll show you why.

Our Spectrums are not G-Sync certified, but rather, G-Sync compatible. This means they do not have the dedicated G-Sync module from nVidia in the hardware, but otherwise meet all of the necessary specs in order to support G-Sync. But, in order to use G-Sync with a G-Sync compatible monitor, you must be using a 10 series card or newer - the 9 series and older, even if they support G-Sync, only do so on certified devices, not compatible devices. As to why that matters, read on.

Now, a lot of people have reported similar behavior, or other issues, upon upgrading their GPU, or connecting to a modern console with modern GPUs integrated, but, curiously, I was never able to reproduce a single one of them with my 970. It was only after upgrading that I all of a sudden found myself in a world of pain (the first night I didn’t realize the issue, and it wasn’t until I woke up the next morning that I saw that that backlight was on - and was presumably on all night. The monitor was downright hot, and the power brick was too hot to touch).

Currently, I’ve tried everything I know of, and even disabling G-Sync hasn’t helped (although it’s not surprising, there is more than one report out there that nVidia drivers seemingly re-enable G-Sync even after you manually disable it for your system - automatically, and behind the scenes, without even a notification that it is being done). This could be part of the reason why disabling G-Sync hasn’t worked for me regarding this lack of standby mode issue. Or it could be something else. Or even a combination of things.

I’m currently collating the data for the first 2 issues that we’ve made polls for, blanking and flickering, which directly affect daily use. I think it might be worthwhile to take this issue on next in a similar fashion, along with the flip side of it - when it is in standby mode, sometimes a signal from the GPU will not wake it up like it is supposed to. I really do think that this will have to be the next focus, they are pretty critical in my book as well.

If you want, try disabling G-Sync on your end and see if it works - I’ll give it some more testing this weekend (Only had the card for 3 weeks, so not a lot I’ve been able to test reliably).

HTH

3 Likes

This afternoon after letting the monitor sit idle for a few hours (which it actually went to sleep this time) I came back and tried to wake it up (move the mouse / press a few keys on the keyboard) but only the two 1080p side monitors I have woke up. The Spectrum did not wake, even after trying for a 3 whole minutes. Eventually I just had to unplug the thing and then it was working again.

Figured I would add to the ongoing issue for records sake.

Hi @ThePie,

Thank you for taking the time sharing your experience. Any data point that we can get is greatly appreciated!

Have you tried disabling the VRR function on the monitor and see if it acts differently?

Seems as though the monitor will not allow me to turn off VRR.

Hi @ThePie,

I’m assuming you are using Windows? If that is the case please disable G-SYNC or FreeSync on your Windows system first. This should give you the option to disable VRR on your Spectrum.