Waking From Sleep Spectrum Monitor

Hello.

I just started using the Spectrum monitor and have been having issues regarding the monitor.

  1. When the PC is locked, after about 60 seconds the monitor should go into sleep mode. In Spectrums case, the monitor backlight stays on but just shows a black screen. The other monitors (Acer 1080p monitors) turn themselves off completely as they should. See below image.
    PXL_20220325_045152925 - Copy

  2. When waking from sleep. The Spectrum monitor seems to disconnect and then reconnect as I can here the Windows notification sounds when a device connects and reconnects. Once the monitor turns back on and I sign into Windows. I can see that all my open windows are pushed into the top left corner like the display reset itself to 1080 resolution and then back to 4K resolution.

What is going on here?

3 Likes

Hi @ThePie,

I am going to link to relevant topics similar to your case here:

It is a well-documented issue, and we are trying to find the root cause of it and working on a possible firmware update to fix it.

For some, enabling the VRR function seems to mitigate the issue, but your results may vary.

Thanks @Cas. Replied to the first thread with my version number and GPU I am using. Can provide more information if required.

2 Likes

Hey, Zak (@ThePie ), and welcome to the Eve community!

Among the different hats I wear here, one of them is firmware liaison, in that I kinda keep information and ideas flowing between the firmware developer team (fw dev team) and the community members. I also checked out your reply to the ‘Backlight stays on’ topic.

This is one of those “WTF?” issues that makes 0 sense. Let me give you a little background on my end.

I started with the Spectrum Test unit back in May of last year - right before the Windows 11 beta was opened to the public. At that time I had an eVGA GTX 970 SSC, although the rest of my rig was much more modern - Ryzen 9 3950x, 128 GB DDR4 @ 3600 MHz, 3x Sabrent NVMe Rocket 4.0 1 TB drives…and I had 0 issues on Windows 10. I upgrade to Windows 11 beta, 0 issues, I then clean installed Windows 11 on Beta 2 and still had no issues. In October, when it was released to manufacturing and then to the public, I clean installed again, still no issues.

I did another clean install in February after I got a sweet deal on a trio of Samsung 980 Pro NVMe drives - these were 2 TB capacity. And still no issues.

However - when I got another sweet (bundle) deal on an eVGA RTX 3080 Ti XC3, quite literally, all hell broke loose.

All of a sudden, things are less stable. The biggest issue I noticed overnight after installing the card, and cleanly installing the 511.79 drivers again was the lack of sleep. The second biggest I noticed was weird flickering, The third was that, on power up, sometimes it takes me 3-4 forced reboots (via the reset button) for the Spectrum to get an image on the screen from my booting computer. Some of this sound familiar?

The thing is - for all intents and purposes, only one thing changed, and it almost has to be the direct cause of the issues. It’s still the same monitor, the same system, the same OS - literally the only thing that changed was my GPU. But it is a critical difference, and I’ll show you why.

Our Spectrums are not G-Sync certified, but rather, G-Sync compatible. This means they do not have the dedicated G-Sync module from nVidia in the hardware, but otherwise meet all of the necessary specs in order to support G-Sync. But, in order to use G-Sync with a G-Sync compatible monitor, you must be using a 10 series card or newer - the 9 series and older, even if they support G-Sync, only do so on certified devices, not compatible devices. As to why that matters, read on.

Now, a lot of people have reported similar behavior, or other issues, upon upgrading their GPU, or connecting to a modern console with modern GPUs integrated, but, curiously, I was never able to reproduce a single one of them with my 970. It was only after upgrading that I all of a sudden found myself in a world of pain (the first night I didn’t realize the issue, and it wasn’t until I woke up the next morning that I saw that that backlight was on - and was presumably on all night. The monitor was downright hot, and the power brick was too hot to touch).

Currently, I’ve tried everything I know of, and even disabling G-Sync hasn’t helped (although it’s not surprising, there is more than one report out there that nVidia drivers seemingly re-enable G-Sync even after you manually disable it for your system - automatically, and behind the scenes, without even a notification that it is being done). This could be part of the reason why disabling G-Sync hasn’t worked for me regarding this lack of standby mode issue. Or it could be something else. Or even a combination of things.

I’m currently collating the data for the first 2 issues that we’ve made polls for, blanking and flickering, which directly affect daily use. I think it might be worthwhile to take this issue on next in a similar fashion, along with the flip side of it - when it is in standby mode, sometimes a signal from the GPU will not wake it up like it is supposed to. I really do think that this will have to be the next focus, they are pretty critical in my book as well.

If you want, try disabling G-Sync on your end and see if it works - I’ll give it some more testing this weekend (Only had the card for 3 weeks, so not a lot I’ve been able to test reliably).

HTH

3 Likes

This afternoon after letting the monitor sit idle for a few hours (which it actually went to sleep this time) I came back and tried to wake it up (move the mouse / press a few keys on the keyboard) but only the two 1080p side monitors I have woke up. The Spectrum did not wake, even after trying for a 3 whole minutes. Eventually I just had to unplug the thing and then it was working again.

Figured I would add to the ongoing issue for records sake.

Hi @ThePie,

Thank you for taking the time sharing your experience. Any data point that we can get is greatly appreciated!

Have you tried disabling the VRR function on the monitor and see if it acts differently?

Seems as though the monitor will not allow me to turn off VRR.

Hi @ThePie,

I’m assuming you are using Windows? If that is the case please disable G-SYNC or FreeSync on your Windows system first. This should give you the option to disable VRR on your Spectrum.

Wanted to revisit this issue. Disabling G-Sync would affect game performance and should remain enabled. Other ways to solve the monitor always staying on even though windows turned off the display at the lock screen?

I’m assuming this is due to the setting to keep the USB hub on when the monitor is asleep.

If the monitor ACTUALLY sleeps, the hub disables itself every time.

Shocked no-one has tested this.

Same issue for me. @ThePie

The monitor will constantly disconnect and reconnect after waking up until it’s unplugged and replugged from the GPU. This is after a fresh install of windows.

Prior to this, I’d have visual artifacts (like half the screen shifted up/down) with “static” in the “empty space” below the taskbar. Turning off and on the monitor used to resolve these issues.

Using HDMI to an RTX 3090.

I have the USB hub set to go off when the monitor sleeps.

Updating from firmware 105 to 107 fixed the issue I was having.

Nvm. The issue still remains on firmware 107.

1 Like

Having similar issues to the above and some slightly different ones:

  • Monitor will only go into FULL sleep if I press power button for sleep but not when it goes to sleep from timed inactivity.

  • Also get device disconnected / on & off sound (sometimes repeatedly) when monitor goes to sleep from above mentioned timed inactivity settings (aka it doesn’t go to FULL sleep). Sometimes I don’t get the sound at all but sometimes I get it multiple times. Both issues don’t happen if I press power button for sleep on pc.

  • Also have issue mentioned above about monitor sometimes seemingly resetting and shoving everything on screen to upper left corner

  • Also have the issue sometimes of monitor being on but only showing black screen with “no signal detected” on screen when waking from sleep, though I’ve had that issue much less frequently lately. Figure it’s still worth mentioning here

Also worth mentioning I don’t have these issues on my 1080p BenQ GW2270 that is plugged into same laptop.

I use an 8K HDMI cord from Amazon on Spectrum monitor, USB-C to HDMI adapter for BenQ monitor with an old HDMI cord from an Xbox One.

I have also looked into and tested the sleep, standby, hybrid sleep, and other options. Many different combinations of those cause the same (and sometimes worse) issues. This is how I think I’ve fixed the black screen issues mentioned above that now don’t happen frequently, but I’m still having the other mentioned issues. The issues I have now aren’t as detrimental and much more tolerable, but nevertheless annoying and would love to see them looked into!

Hi there,

First of all, welcome to the community!

Did you mean that you can still see the backlight on if its not going on “full” sleep?

Do you have any devices connected to the hub? This is a known behavious where the USB hub resets itself whenever the monitor goes in or out of sleep mode.

It might be possible that the resolution changes somehow… which might be the cause of why the items are all shoved to one side. What device do you have connected? Is it a Windows PC or Mac?

If you haven’t done so already, something that might worth trying is to update the firmware to the latest version. Just make sure that you follow the instructions carefully.

Yes, back light stays on and intermittently shows “No signal detected” on screen when computer and monitor are meant to be in sleep / standby mode (not sure exactly the name or difference between that and the FULL sleep i mentioned)

No devices connected to hub, only the power cord and HDMI cable.

Yeah I could see that being the case. I have also witnessed this happen in settings before but I’m not sure what I was doing to replicate it as I just gave up messing with it haha. That could definitely be a limitation of my laptop potentially. I’m using an HP Zbook 17 G5. I also have a BenQ GW2270 plugged in through a USB-C to HDMI adapter. So I have the integrated screen, the spectrum 4k 144hz, and the benq all on. Integrated and BenQ are 1080p, but i attempt to run the Spectrum at 4K 120HZ

and okay I will check for an update, however I believe I updated not too long ago and still had the issue but will check again

EDIT: So now I remember that actually I was unable to install any firmware updates as my spectrum can’t detect the computer that it is installed on through usb-c. It’s the same HP laptop above and the same one I had when I was having this problem. It’s possible that these updates could potentially solve some or all of the other issues mentioned but yeah until I’m able to install new firmware I don’t know what else to do