V battery suddenly not charging correctly

After unintentionally letting my V’s battery fully discharge while sleeping, I encountered some problems starting up–I got a “preparing automatic repair” that resulted in some black screen startup loops before I finally got it to restart correctly. The battery reported at 5% (via BatteryBar), but charge rate was very low (about 1500 mW), and periodically the battery stops charging and restarts. This has been going on for hours and despite being plugged in the whole time (with the V’s original charger and cable), the battery is only at 9% now. I tried another cable and switching USB-C ports with no change. When I unplug and replug, the charge rate goes up to 7 or 8000 mW, and then lowers again after the next time it cycles to battery and back to charging.

Could this problem be related to the fact that the battery ran so low? Is there anything I can do to fix this?


I haven’t heard of that specifically. However it has been noted that when people have let their V fully discharge by accident or on purpose that they’ve had trouble bringing it back to life.
I had the issue, however it seemed like it spontaneously wouldn’t turn on, however it could have woke up in my sleeve and drained its battery.

I would suggest contactung support but also keep messing with leaving it plugged in, plugging it in and using a usbc pd charger with a ground pin if you have it.

My own issue was solved by having someone other than me try, after having it plugged in for a few days, probably because my V was upset with how I was treating her. We have been getting along better since.

I’ve accidentally discharged my V a few times and, occasionally have had similar problems getting it started again but I think that’s because I tried to restart fairly soon after I had plugged it in to charge.

I found that it would restart again without any problem once it had been charging for half an hour or so.

1 Like

Thought I’d give a quick update: looks like the charger was in the process of dying. The other day it stopped working completely (I tested with a different USB-C charger to make sure it wasn’t my V.) I’ve filed a support ticket but don’t expect to see a replacement any time soon, as I’ve been on the waiting list for a replacement keyboard for over 2 months now…