V + Aorus Gaming Box

Hey all, the last few days I’ve been trying to get my V to work with the Aorus Gaming Box 1070 and only once it did flawlessly. The other times it has been continuously connecting and disconnecting every few seconds with or without peripherals attached to it. I get power delivered constantly through the TB 3 but not much else. Had all drivers installed and updated although could never get to update the gaming box firmware. Read about similar issues needing to actually downgrade TB3 firmware to a previous version and even Windows itself. Before trying anything as drastic as that I wanted to know if anyone else in the community has tried this combo so I can determine if the fault lies in the box, or on the V itself. @Team, was this the mystery box you guys used in last years video? Any help is very much welcomed. Cheers!

So i did try downgrading the TB3 and it worked! Got it form here . I managed to update the Box firmware and plugged all my peripherals and even gamed a bit on my desktop monitor through the DP port. Unfortunately, after restarting the next day with the TB cable plugged in to the V i got the Windows blue screen twice. Haven’t managed to get it working again…
I’ve also read that on some Razer Blades you need to have at least 95% battery to prevent the disconnects. Just came back from a weekend out, and with 100% battery same thing happens.
@Wickedly I already tried using the TB cable that came with my V and doesn’t help. Regarding the processes i clearly get the TB one but not sure what else to look for. I can confirm that when it worked i set it to always connect but so did the times that it didn’t. And yes, the TB icon always shows in the taskbar. Actually it’s gotten more reliable once i downgraded TB3 firmware and updated the Box firmware. Finally, i haven’t tried taking the GPU out yet. That along with resetting Windows are last resorts. Hopefully we can figure out a solution before needing to do that. Thanks all, I’ll keep you posted.

Again haven’t used the box or the V as much as I’d like lately. However, after failing constantly to maintain a stable connection I decided to have the V powered via its own PSU connected to the upper usb C port. After that i connected the Gaming Box (without peripherals) to the TB3 port. So far it’s worked every time, even hooking up an external monitor and sdd to it afterwards. Today I was able to game as well so finally my setup has fulfilled it’s purpose. Pretty happy with it since I don’t mind having the V plugged at the same time. In case anything changes I’ll let you all know. Cheers!


I probably was the evegpu

I’ m interested if you find a solution, as I have one as well. As a 1tb backer it will still be a few days before I can test !
And if we are more than 1 working on it, we will certainly find a solution eventually .

Did you check out egpu.io ? It was very helpful helping me running the aorus on my mac book pro.

Don’t downgrade it.

There are many possibilities, first, it could simply be the cable - its happened to me before when I tried to connect a laptop to a monitor, that the cable couldn’t handle the bandwidth so in that split second the gpu would think “oh, there’s no second monitor” and try to go back to just kept repeating that over and over. Try a new cable that you’re sure is HDMI 2.1 or DP 1.4 or something first.

Check if your thunderbolt processes and services are starting up - there should be three in total, can’t remember what they’re called off hand.

That time when your setup worked, did you have to set the tb3 option to “always connect”? Does the tb3 icon show up in the taskbar?

Have you also tried connecting your V to the box along but not using the GPU? Just making the connection to update the firmware?

Glad to hear you fixed it, but i tried that same driver too - the NUC one - if you’ve updated your box’s firmware you should try updating the V’s TB3 drivers again, those NUC drivers caused a lot of problems for me when i tried them.

P.S. resetting the V isn’t actually a hassle at all because there’s so little bloatware. it actually took me like under 30 minutes each time i did it.