USB Hub stops working randomly for a few seconds

Since last week the usb hub of my Spectrum (Firmware 104) randomly stops working for a few seconds. The connection the the source (over USB C) is lost and reconnects again. It happends in both USB-C modes (3.1 and 2.0). Usually it happends during gaming, in this case Minecraft in both windowed and fullscreen mode.

It also happens both with HDR and G-Sync on and off.

My system:
GPU: RTX 2080 ti connected over DP 1.4
Driver: 497.09
CPU: Ryzen 5 5600X
MB: MSI B550 Tomahawk
OS: Win 11

I hope this is a firmware issue and can be solved in the next update.

Hi @Nic01060,

If you haven’t done so already, please contact our support team regarding this issue.

I would like to think this is a Firmware issue and can be resolved with a simple update.

  1. Have you tried using an alternative USB-C Cable?
  2. Can you make sure the USB Hub Source is Set to USB-C on the OSD Settings.
  3. Did this issue only occur once you upgraded to Firmware 104?

Please let me know.


I think I solved the problem myself. It seamed to be an overheating or interference issue of the USB controller.
I have a RGB controller adhered to the back of my monitor for ambient lighting like Philipps Ambilight and I think the positition where it was adhered before caused the problem. Since I moved it the problem seems to be gone but I will keep an eye on it for the next days.

1 Like