USB Hub not working after attempting USB Firmware Update

So I just tried updating the USB Hub on my Spectrum monitor. I followed the instructions provided but instead of saying “Upgrade successfully” like it’s supposed to, it said “Upgrade failed”, and it looked like it was still “working” but after 20 minutes of nothing happening, I closed the app, power cycled everything and tried the upgrade again.

When reopening the update app, it says “No device found!”. I tried several power cycles, changed the source from Type-B to Type-C to Select Automatically, with both a Type-B and Type-C plugged in. And yes, I made sure they are all plugged in all the way in.

My PC doesn’t see the USB Hub anymore.
I’m not sure what to do next, does anyone have any idea?

1 Like

I think that in this case, power off the monitor and leave it off for about 30 seconds, and while it is off, just before you turn it on, reboot your PC, so that you turn it on when the PC is going through the shutdown process.

If that doesn’t work, try letting it stay off for about 5 minutes. Another reboot won’t hurt after that 5 minutes, like I described above.

1 Like

That didn’t work either.

1 Like

Is this the 18.02 update or the 17.02?

The 17.02. It’s the only one showing up on the support/download page.

1 Like

Hi @fuzzyelf,

I responded to you on another topic but if you could reply here, that will be appreciated.

1 Like

I have it set to always on.

1 Like

I have same message
what could i do?


I would suspect that you still have the USB hub source as “Select Automatically”.

You can try selecting the hub source manually instead to see if the computer detects the monitor hub correctly.