USB Hub not waking after monitor sleep

Heya - I wonder if there is a known fix for this?

When I first connect my MacBook (Intel, 2018, via USB-C) to the Spectrum, the usb hub will work fine. If the computer and display then sleep, when woken up the hub does not come back on. Note, not just it is not connecting back to my Mac, but the hub isn’t delivering power to any of the connected peripherals either?

Any one else finding this/ has found a fix?

I tell lies. It -is- delivering power (my phone will charge), I was just using my caps-lock key to see if there was power to the keyboard. Moving my mouse from the keyboard hub to the monitor brings it to life.

I think there may be a weird interaction between the keyboard (Apple extended) and the monitor specifically, as it won’t work no matter how many times I plug and unplug. However it -did- work at first connect.

Hi @iwasdjb,

Hmm… just to clarify, you are having issues only between the monitor and the keyboard after sleep, yes?

If you head to the website, we have just released a new firmware for the monitor itself and the USB. I don’t know if this will fix your issue, but it is worth trying as we included numerous improvements in those firmware updates.

1 Like

Hiya - Just had a chance to update to 106 and run the USB firmware update. I tried the USB first, and it appeared to fail - subsequent runnings said “running in ROM”.

I have run the 106 update (all fine), but now there is no USB connectivity at all - not the hub, and apparently not from my Intel MacBook.

Running the USB updater again just says there is no device found - is this a brick, or recoverable?

Phew! - A bunch of power cycles and switching hub sources finally got me connected and updated. Will report back on behaviour!

1 Like

How exactly did you fix this issue? I can’t seem to get my USB hub to connect to my PC anymore. So I can’t update the monitor or use the USB ports.

Hi @fuzzyelf,

Were the USB ports working previously or did they just stop working randomly?

Have you tried connecting it to another source and seeing if it works then?

All the USBs were working fine, then I tried the USB firmware upgrade. During the process, it said that it failed, but it looked like it was still working on it, so I left it alone. 20 minutes later and no progress has been made, so I closed the app, did a power cycle on both my monitor and my PC. From that point on, the PC doesn’t read the USB Hub. I’ve tried with both cables ,Type-B and Type-C. I changed the monitor settings, tried all sources (Type-B, Type-C and Select automatically) with a power cycle in between each. I can’t seem to make it work anymore.

Hi @fuzzyelf,

It looks like the issue occurred during the USB firmware upgrade and has left the USB Hub in a state where it’s not functioning as intended.

Do you have your USB Hub set to ‘turn off with monitor’ or ‘always on?’

It is set to always on.

Hi @fuzzyelf,

I would recommend contacting support at this point. The USB Hub is clearly not interacting with your USB sources and may need technical support to fix it.

I’m assuming you’ve also tried to use ‘turn off with monitor’?