USB devices not seen by MacBook Pro

Hey everyone,

I finally opened and set up my Spectrum yesterday. So far it’s kind of a mixed bag, there’s a lot of things I like, and a lot I struggle with. This is an example of the latter.

The setup:
I am currently using a MacBook Pro (13", 2017), connected with a single USB-C cable that should be able handle this as far as I know. This is a cable that came with and I have been using with my previous monitor (LG UL850-W), providing 4k@60, PD (60W), and USB pass-through.

The problem:
I have two USB devices plugged into the Spectrum (a mic and a DAC/AMP), neither of them are visible to macOS. I am using the exact same cable mentioned above, so I am baffled why it doesn’t work when it was with the LG.

More details:

  • The monitor has FW 104, updated it yesterday.
  • To get 4K@60 I had to switch the bandwidth priority to “High refresh rate”, but even if I switch it to “High USB data speed” and get stuck at 30Hz, the devices are not visible.
  • Similarly, it doesn’t matter if I change the hub selection between automatic and Type-C, or if I set the USB hub to be “Always on” or not.
  • The USB devices do get power though, so the ports themselves seem to work.

I have a new MBP on the way, for which I also plan on getting a higher spec cable. It might solve it, or it might not. But that’s 1-2 weeks away, would prefer to fix this before then if possible. Would also love to understand at least why the current setup doesn’t work, why I only get 4K@30 with the high data speed setting (I believe that should support 60Hz), but more importantly, why my USB devices are not visible on the Mac, when this exact setup was working with the LG, only the monitor changed.

Any answer, help, and insight is appreciated! <3

1 Like

Hi @damol,

We will soon publish a USB hub firmware update to improve the built-in hub’s compatibility. Although I’m not certain if it can resolve the problem you are facing, it’ll be worth a try. In the meantime, would you please tell us more about how are your mic and AMP(DAC) connected to Spectrum? For example, via which port on the side?

To get 4K@60 on ‘High USB data speed,’ the source device needs to support DisplayPort 1.4 alternate mode via Type-C. In addition, you can follow the instruction under ‘If your display appears blurry’ section from If your external display isn’t detected or appears blurry on your Mac to see if a higher refresh rate is possible via manual selection.

Oh, that sounds exciting, I’ll be interested in that update. Sure, no problem. The mic is a Blue Yeti X connected via a Micro-USB to USB-A cable, plugged into the USB port right below the 3.5 jack on the Spectrum. The AMP is a Schiit Jotunheim 2 (with their Multibit DAC card), connected via a USB-B to USB-A cable, plugged into the USB port below the one mentioned above.

Gotcha. It might not support that, it is a relatively old MacBook after all, it only has Intel Iris 650 graphics. The new M1 Pro MacBook coming next week (hopefully) will be much beefier on that front, so that might very well solve that end of the problem. I did already use the “Option-click-on-Scaled” trick to check my options, that’s how I got to the conclusions in my original post.

I will be happy to check what refresh rate options I have once I have the new machine and cable, was just hoping there’s something I overlooked in terms of making the USB hub work in the meantime, as it was working with the LG monitor, using the same cable and same Mac. My worst fear is a hardware issue, but I would only like to get to that conclusion once I checked with a different Mac and cable, most likely happening next week or the one after.

1 Like

Alright, I can finally follow up with some more information.

Setup updates:

  • My new 14" M1 Pro MacBook Pro arrived. It has macOS Monterey 12.0.1 on it, so I am also running into the issues mentioned in other threads, can be ignored for the sake of this thread. I’d be fine with 60Hz maximum refresh rate if the whole USB setup would work.
  • I also got an Apple Thunderbolt 3 Pro cable. This is so that it is guaranteed it supports the required standards (I know you and other people also referred to this cable in other threads).
  • Finally, I decided to plug my external keyboard (Keycult No. 2/56) into the Spectrum as well. It was previously plugged into the MacBook, but my goal is to only use a single cable with this new setup, a big factor in me buying the Spectrum. Either way, this is done via the last remaining empty port on it, the USB-C one on the side.

This setup still doesn’t work as expected even though now both the Mac and the cable should be up to the task. The only real improvement is that I can at least now select 4k@60 both with the “High refresh rate” and “High USB data speed” options selected. But I still only see a single USB device in both cases when they are all plugged into the Spectrum. That one is currently the USB-C port’s, the keyboard.

More details:

  • That last bit gave me an idea to try to use the USB-C port as a hub on the Spectrum, so I tried it with two types of hardware plugged in: either an Apple USB-C Digital AV Multiport Adapter or a Twelve South StayGo USB-C Hub. Only the latter allowed me to see multiple devices plugged into it (tested with the keyboard and the mic), but this external hub also gave me audible coil whine, which it normally does not, so I decided against testing that for a longer period. So while in theory I could daisy chain things into the Spectrum’s USB-C port to make things work, that’s a no-go too for now.
  • And to add one final curiosity, while changing things around after getting the MacBook and the TB3 cable I did see the mic show up once in macOS (while plugged into the exact same port as of now), but I could never replicate that after getting everything in its place. This at least tells me this is most likely just a firmware issue.


  • Is there anything else I could try setup-wise, both in terms of hardware, or Spectrum’s OSD?
  • I have a bunch of screenshots from the System Information app that show how macOS sees the USB hardware with all these different combinations mentioned above. Would they be helpful to your team, should I post them here?
  • My best hope is still the USB hub firmware update you mentioned last week. Do you have an ETA on that, even if just a ballpark estimate (e.g. weeks, months, next year)?

Either way, thank you for your help in advance!

1 Like

Just giving a small update here in case anyone ever runs into anything similar: in the weeks and months since my last update I managed to make all three of the devices work through the monitor, and have only a single Apple TB3 cable go to the MacBook, as originally intended.

The way to get there was to try multiple different combinations of which accessory is plugged into which USB port, requiring an Apple USB-A/USB-C dongle to be able to use the C port for an A cable as well (a possible source for some coil whine, have not confirmed yet), and also getting some different cables for certain things like my mic. Now everything works, but I still have to disconnect and reconnect the AMP/DAC every time after the monitor goes to standby or is turned off, otherwise macOS doesn’t see it. As a sidenote: none of these were required with my previous monitor, so I don’t think about it as “normal” or expected. But at least it kind of works.

My last hope for any improvements on this front is really the promised USB hub firmware compatibility update. I guess it might have been included in 105, but since there’s no Mac FW updater yet AFAIK I’m still on 104, and I don’t want to go through the extra hoops I needed for that last update. Since there’s a new liaison, @nkyadav I hope you don’t mind the tag. Are there any updates on these two things?


Hey, @damol

As for the USB Hub compatibility update, see this post I made: Feature request: usb hub selection per input - #12

As for a MacOS updater, we still do not have a timeline for one, unfortunately.

Thank you so much for the updates, I really appreciate it. Looking forward to 106 then, if it comes without the Mac installer (as it likely will) I’ll just find a workaround again. :slight_smile: