USB-C USB-C stopped working MacBookPRo and Spectrum

I have spectrum monitor and MacBook PRO M1 Max (top version on the end of 2021) - on the star they both were working together with USB-C USB-C connection, but now (few month later) MacOS even can’t see this monitor but the charging is going on ok. First of all i thought that the problem is in cable so i ordered a new one with 10 Gbps ( USB C to USB C 3.1 Gen 2 Cable 6ft 90-Degree Fasgear Type C 100W Cord 4K@60Hz Video Output 5A Power Delivery Charging Wire Compatible for MacBook,iPad Pro,Pixelbook,Oculus Link,T5 LaCie SSD (Black)) but the new cable shows the same - only charging. The same problem when im trying to connect my Ipad PRO - just charging.

I tried - 2 cables (old that was working and new one)
I tried - 2 devices (Ipad Pro and Mac Book Pro)
I tried both USB-C ports

But when Im using HDMI-HDMI - no problem.

Hey @2688087 Welcome to the community!

If i am reading this correctly the problem is the monitor isnt picking up a signal from your M1?

i dont understand monitor dont oicking up signal or macbook cant see monitor to send signal - because in preferences of macbook on “monitors” there is empty

Have you made any changes that coincided with the monitor disappearing? That includes macOS updates, changing cables, upgrading the Spectrum’s firmware, etc.

It’s unlikely (but far from impossible) that the Spectrum would suddenly stop responding if nothing else has changed.

i think that may be mac os was updated, but i dont know exaxtly - the last time i used both in connection was 3 month ago.
also i moved from UAE to Spain, but I dont think it could be the reason, hahaha

i tried to upgrade the firmware of spectrum but my mac didn’t see it in the upgrade utility via parallels, so no upgrade.

1 Like

Has anyone tried running the Spectrum over a thunderbolt hub or two?

As long as the hub converts Thunderbolt to DisplayPort or HDMI, it should work ok.

The Spectrum’s USB-C port requires the use of DisplayPort alt mode, which takes over wires inside the USB cable to carry a DP signal. ThunderBolt has a very different way of carrying a video signal that’s not directly compatible.

1 Like

Well said! I appreciate the nuance of your answer

1 Like

Today tried the same operations on MacBook Air 2020 M1 - mac os Monterrey 12.1 - the same - nothing.
My MacBook Pro is with Monterrey 12.4 MacOS version

Monitor software updated. Still no result. May be it’s time to send it back for warranity repair?

My experiments shows me next:
USB-C No 7 - gives me charging of Ipad and nothing for MacBook
USB-C No 5 - gives me nothing for any device - is it DEAD?
Снимок экрана 2022-07-12 в 22.45.36

Hi there,

Port #7 has less power output, so I don’t think it is enough to power your Macbook but enough for your iPad. Looking at your test, this is intended behaviour.

Typically port #5 is the one that allows you to charge your devices and accept video input from your Macbook. If it doesn’t work or transfer power when the monitor is on, then it is a faulty port.

You did mention on the original post that charging was working fine on this port (albeit no video). Did the problem worsen?

One thing you can try is to access the OSD and set all setting to factory default. Then manually select video input instead of “select automatically”.

Hi @2688087

I did not seen you mention this, so I am asking you which input source you select when trying to connect your MBP.

For me since FW 106 I need to manually select the USB Type C Input from the menu to get an image. If I leave it on “automatically select” nothing happens at all besides charging.

And yes automatic signal input selection works with HDMI for me as well

yes. problem worsen. after upgrade firmware macbook stop charging from any of type-c ports.

yes. of course i manually selected input type-c

Support agent from my account on evedevices website where I ordered my monitor doesn’t answer me for a week about this case…
Does anybody know what to do net to apply for warranity repair?

If you could send me a message with your order ID and Ticket ID I will get this looked into!