USB-C charging works on macbook but not windows 10 laptop

I’ve noticed my Spectrum’s USB-C port charges my macbook pro M1 fine, but as soon as I plug into my work laptop it display image but doesn’t charge like the macbook?

I know this laptop port works for both display/charging as we use this at work. Is it some weird windows thing maybe?

Firmware is currently 105 (out of box as I received it)

Hi @iamts,

If I may know, what laptop are you using for this? Just wanting to check voltage requirements to make sure everything checks out!

Hey @Cas,

My work laptop is a Dell Latitude 7390 (Core i7-8650U , Windows 10 Build 19043)

Hi @iamts,

To be able to charge a device using Spectrum, the device must support USB-C Power Delivery. When I try to look up the specs, this shouldn’t be an issue with Dell 7390.

Are you using the same cable at work as the one you use for your M1 Mac? If not, it’s possible that the cable specifications are different. You might want to try changing the cable and see if it works.

Another thing to check is your BIOS setting. There might be something that you can tweak to enable USB-C charging. You might also want to try changing the OSD setting > USB-C Bandwidth Priority. Try to see if changing the priority between refresh rate or data speed helps.

No it’s not my work cable, its a cable I bought for home use (which is what I use for my M1 Mac that works with spectrum; both display and power).
This is the cable:
(1.2M USB 3.1 Type C Cable (Male to Male) - USB-C - 4Cabling)

  • Data transfer speeds of 7Gbps
  • Charging output 20V Max, 3A / 5 A
  • 100 watts, or 3 amps of power

I’ve tested both OSD bandwidth priority settings and neither charges the laptop (both display image). I’ll see if I can get into the BIOS and have a look.

I just noticed I get two different windows notifications upon plugging into my laptop.

With my logitech g pro mouse connected to laptop / USB-C to monitor
“USB device might need more power
Your PC might not provide enough power to the USB device. Please connect your device to external power, or try using a different PC”

Nothing plugged into montior or laptop / USB-C to monitor
“PC isn’t charging
Use the recommended charger and cable, and make sure it’s directly plugged in”

I suppose I can try a different cable, though it seems odd if the cable is rated for 100W power?

1 Like

Just to verify - you’re plugging the Type-C cable directly from the Spectrum to the Dell, no intervening hubs / docks, correct?

Hey @nkyadav that’s correct, directly into the Spectrum.

1 Like

And directly to the Dell - I want to verify that it is a direct connection in both directions.

Sorry, yes. Direct connection (both directions).

1 Like

Thank you. I’m not sure why this is happening for you, since the XPS 13 7930 explicitly uses PowerDelivery (USB PD) which our monitor explicitly supports. And by supporting this industry standard, that Dell laptop should not care if you’re connecting a Dell power source or not.

I suspect, though, that there may be a setting in the UEFI fw that your corporate admins might have set to only allow a certain charger, although that still makes no sense because 1) I’ve not heard of such a setting, and 2) USB PD is an industry standard. and as such, Dell should not be able to tell what device is providing the needed charge.

At your workplace, are you using some sort of docking station? If not, can you describe the setup there?

It’s a Dell Lattitude 7390 ( - page. 11/12) it says the port is “DisplayPort over USB Type-C (optional Thunderbolt 3)”

There are a small bundle of different connectors that sit on all the desks (for people to just plug in and use whatever they please, mostly everyone uses the single USB-C for screen/power delivery) I can’t actually tell where the cables go because they all go under the desk into a closed/locked cabinet draw type thing mounted, on the back of the desks. I imagine it’s some sort of dock locked underneath, I will ping someone from I.T to ask though.

1 Like

Sorry about the typo, but yeah, I was looking at the info for the 7390, and it specifically says PD, so it’s odd that it doesn’t work.

Yeah it’s really strange, just found out work use a ‘Targus’ dock that is locked under the desk, which is probably just one of their normal docks that supports usb-c power delivery.

Unsure how else I can get it working, at the moment just using the laptops normal charger but would be nice to use one cable like my macbook.

1 Like

Hi @iamts,

It is very odd. I doubt there is a setting in Windows that can affect this functionality.

My guess now is the cable. I have a feeling that the Dell may be asking for more power than what Spectrum is capable of on the initial draw, which in turn disables the PD function (and hence why you get the warning).

When looking for possible solutions, I came across this: have you ever tried plugging the cables in in a different order? (for example, connect the cable to laptop first before connecting to Spectrum and vice versa). Some even suggest using different sides of the cable from how you normally use it. It may seem trivial, but maybe it will work.

I don’t think that’s the case. The beefiest power brick sold with the Inspiron 7390 is only 65W, using the standard Dell 7.4mm power connector.

My wife’s Precision 5550 charges only over USB-C, and requires a 135W power brick. If I plug that into my Spectrum, it’ll charge but will complain that it’s “charging slowly” due to not receiving enough power.

My Alienware laptop does the same thing when plugging in an undersized power brick via the 7.4mm plug. It comes with a 240W brick, but I’ve plugged in 180W and 90W bricks in an emergency. It does the same thing - it charges, but complains that it’s not receiving the power it wants.

@iamts there is a newer firmware out for the Spectrum’s USB chipset. It might help to get the Dell to charge, but could also cause the M1 Mac to stop working.

If you want to try it, you can find more info in the v106 firmware thread. There’s also the ability to roll back to an older USB firmware if you run into problems.

The other big downside of the firmware update is that only runs on Windows and needs to run as an administrator. Even if you have admin rights on your work laptop, it’s not really something you’ll want to run on it. If you don’t have access to another Windows machine, it might be safer to stick with the current firmware.


Yeah agree, my power adapter I’m using for my dell is only 65W, which is what I’ve found odd. So I can’t imagine the ‘initial draw’ too much for the spectrum.

That’s interesting, I had no luck regardless of any combination I tried, must be the firmware.

Yeah I wouldn’t do it on my work laptop (but a good point), I do have a win desktop I can give it a go on, but I was reluctant to upgrade so fast due to people having issues with their mac connectivity, as you mentioned. Functionality of rolling back might change my mind though.

Thanks @NZgeek

1 Like

Give it a shot, and document what happens, that will give is real world data we can take back to the fw dev team.

I, for one, appreciate any efforts you put fourth up figuring this out.

I’m on 105 as well and charge my Dell Latitude 5420 with a 20Gbps 100W USB C cable plugged into the bottom USB-C port.