USB C, anything over 60Hz drops to 6 bit color

I’m trying to hook two computers to the Spectrum display. The one with DisplayPort seems to work as expected, but the laptop with the Thunderbolt 4 port behaves as described in the title. In order to keep 8 bit color resolution I have to use 60Hz refresh rate in Windows. HDR is disabled, I updated firmware to 104 and tried (I think) toggling all of the relevant settings (USB C bandwidth priority, adaptive sync). Nothing changed.

Is this normal? Am I not supposed to get 4K@120Hz with full 8 bit color resolution through USB-C?

1 Like

Could you please post a little more information on this?

  • What type of computer is having the issue? e.g. Windows PC, Linux PC, Intel-based Mac, M1-based Mac
  • What GPU is in that computer? Laptops sometimes use whatever video output is built into the CPU, but sometimes there’s a separate GPU.
  • Are you running the latest graphics drivers for the GPU?
  • Which version firmware are you running on your Spectrum?
1 Like

The laptop in question is a brand new Lenovo Slim Pro 7 14IHU5, which I bought specifically in order to be able to utilize this monitor to the fullest. I updated it immediately to Windows 11. I chose this model because I was able to find a spec sheet for it rather easily, which is not necessarily true for most other laptops on the market. The laptop has a discrete GPU (Geforce MX450) however I believe it is the job of the integrated graphics chip to produce the actual video signal, which is Intel Iris Xe in this case.

From the spec sheet I can see that they specify a maximum resolution of 5K @ 60Hz, which is about double the bandwidth of 4K @ 60Hz. Based on this I figured I would be able to get 4K signal out at a higher frame rate. Iris Xe graphics should be capable of this, and I reckon the thunderbolt 4 should be capable of this, so I’m not sure where the problem might lie.

I have not tried updating the graphics driver, but I did update the Spectrum firmware with the latest version that was available yesterday (104).

The spec sheet for this laptop you can find here

Update: I tried installing a fresh Intel Iris Xe driver (beta even). No avail still.

It’s always very hard to say what the story is with integrated graphics on a laptop.

You’re likely correct that the MX450 graphics will get piped through the iGPU. This is very common for laptops, and saves on the hardware costs of a separate muxer chip.

From what I’ve been able to find elsewhere, Iris Xe graphics can output more than 60Hz at lower resolutions. In fact, your laptop comes with 90Hz screens @ 2560x1800 resolution, so higher fps is possible.

The best thing to do is to upgrade to firmware version 105, which is available here on the forums but not for download via the website.

This fixes a whole bunch of issues. Amongst other things, people running M1 Macs have noted that they’re able to get 144Hz over USB-C when they were limited to 60Hz previously. It’s very possible that the fix for them will also help in your case.

I’m getting the same issue on my Radeon 6900 XT. It drops to 6 bits and loses HDR over USB C for anything above 60hz.

Edit… Seems to be doing it on display port now only on the 105 firmware. My 104 firmware still works with 10 bit 144hz.

Edit2: Rolled back 105 to 104 and now 10bit @144hz works again

Wait you updated to 105, then rolled back to 104 and now it works again?

This honestly feels like a bandwidth problem to me since >60 Hz refresh rates are available but only with limited color accuracy. Would be interesting to try other refresh rates too, especially 90Hz, but Windows only offers 60, 100, 120 and 144.

I guess it could be a cable issue too but the one I bought advertises 40 Gbps and 8K@60Hz support so I reckon the cable should not be the problem either.

I am going to try the 105 firmware but I think I will wait for the official release. I’m sure the firmware updater is as robust as possible but I’m still somewhat worried about bricking my new Spectrum because of a transmission error or blackout or something. Thus I don’t want to update unless there’s very good reason to do so.

Hi @Triebr,

Can you please confirm you’re running this in 4K?

@Lasse - Please let me know you’re findings, once you upgrade to 105.

We usually do recommend trying an alternative cable to eliminate the cable factor. Are using TB3 or TB4? Can you also provide a link, so I can look into this myself?

This is not a common issue, so I would need to test a few things out.

I tried another random USB-C cable with the same result. The main cable I’m using is this one Club 3D | USB4 Type-C Gen3x2 Bi-Directional Cable 40Gbps 8K60Hz 100W PowerDelivery M-M 0.8m - 2.62ft

I thought the cable was thunderbolt 4. But now that I look at it, I only see “USB4” mentioned and NOT TB4. Today I learn this might not the same thing? Don’t tell me I need a new cable :woozy_face:

USB4 should be ok. The cable says it’s rated at 40Gbps so it’s supposed to have enough bandwidth to carry a full DP video signal.

The 105 release is “official”, but just hasn’t been make available on the main website for some reason. It appears to be as stable as the 104 firmware version and fixes several bugs. The only potential new bug is the standby coil whine, which only appears to be affecting some people.

I wouldn’t worry too much about the firmware upgrade process. It’s pretty robust, and won’t use the new firmware until it’s been fully received and verified.

I had some issues upgrading to firmware 105. It was flaking out about 2/3 of the way through the upload and restarting. I killed off the firmware updater multiple times at various points during the upload. I power cycled my Spectrum a couple of times. It just kept working using the current firmware.

The only thing that would be a concern is a power cut, if it happens when the Spectrum is applying the firmware you’ve uploaded. Unless there’s warnings about power shortages where you live, just wait for a day when there’s good weather and do the update then.

1 Like

I wonder if we could approach this from a slightly different angle.

Perhaps someone could confirm that they are indeed able to get >60Hz video at full 8 bit color using similar configuration to mine? In other words a usb-c cable from the laptop’s thunderbolt 4 port to the usb-c port of the monitor. Bonus points if the laptop involved has the Iris Xe graphics chip and runs the latest version of Windows.

If I knew there was something wrong with my specific setup, and the thing I’m trying to do is generally possible, I could try to e.g. purchase yet another cable just to make extra sure its not about the cable. TB4 certified cables seem to be somewhat hard to come by and they are not exactly cheap, so it would be nice to know if I can even expect any improvement that way.

I’m not super certain about all the technicalities involved, for example if the DP “alt mode” is a factor and needs to be supported somehow. There has also been some talk about Display Stream Compression, and I’m not sure if that applies here as well? Does Eve support DSC at the moment? Can DSC be used to lower bandwidth requirements? Do I have to turn this feature on somewhere or is it used automatically?

I just tried plugging in my wife’s laptop to my Spectrum’s USB-C port. It’s got an i7-10850H CPU and Quadro T1000 graphics (effectively GTX 1650). The CPU has Intel UHD graphics rather than Iris Xe, but it’s close enough to test some things.

I was able to use the following video modes:

  1. 4K @ 30Hz 8-bit (SDR)
  2. 4K @ 60Hz 8-bit (SDR)
  3. 4K @ 60Hz 8-bit with dithering (HDR)

Mode 1 was selected by default by Windows. I had to go into the advanced display settings to choose 60Hz. The same thing happens on MacBooks, so this is likely an issue with the reported EDID information.

HDR enabled without a problem. It’s listed as “8 bit with dithering” because the Spectrum’s panel uses 8-bit+FRC, and FRC is a type of dithering to emulate 10-bit on an 8-bit panel.

I wasn’t able to go more than 60Hz, even when attempting to add a custom graphics mode in the Intel graphics settings. This makes sense because the CPU specs list the maximum DP output as 4096x2304@60Hz.

Sorry for the necropost, but I figured I might just as well report the latest findings. Installing firmware 107 solved the 6-bit color issue. The patch notes said it added support for DSC over USB-C, which probably was the key here. I wish someone could have confirmed that USB-C indeed lacked this functionality and that DSC is required for the higher bandwidth video. This would have saved me from bothering people with troubleshooting requests on Lenovo boards etc, but here we go.

1 Like

Hi @Lasse,

Thank you so much for reporting back to us. Sorry I wasn’t around yet when the topic was made so I completely missed this :stuck_out_tongue:

107 does enable DSC over Type-C which solves many bandwidth-related issues.