Upgrade to 106 (cannot use "PC Screen only" projector mode)

Hi all,

I flashed the new 106 version however it renders my configuration simply unusable :sob:

Test Environment:

  • Eve Spectrum with v106 + USB firmware 06A4 / 0A.89.18.02
  • LGgram 16Z90P i7-1165G7
  • Laptop connects to the Spectrum via USB Type C

Test settings:

  • Input source: Auto
  • USB Source: USB Type-C
  • USB Hub: Always on

Test methodology:

  1. Connect the laptop to the Spectrum using USB C cable
  2. Using Winkey + P, set output to Spectrum (only)
  3. Wait for the video output be changed and image on Spectrum (only)
  4. Using WinKey + P again, set output to laptop (only)
  5. Wait for the video output be changed and image on Spectrum (only)

Expected result:
End-User be able to choose between setting the video output to laptop only or Spectrum only

Observed result:
When switching the video output from Spectrum (only) to laptop (only) using Winkey + P, the video is indeed set to Laptop (only)… however, 2-3 secs later we hear the USB Disconnect sound (nothing happens, just the sound…) then another 2-3 secs later we hear the USB Disconnect sound again and this time the video output is set to Spectrum (only).

These behaviour with 106 makes it is impossible for the End-User to be able to set the video output to Laptop (only) when the USB Type C cable is connected to the Spectrum.

In previous versions 102, 104 and 105RC, switching between display output on the laptop, we would not hear any USB connect/disconnect sound thus we would not experience the issue.

Workaround 1:
Flash T104_rollback.bin
Flash BD_EVE_4K_Release_20211126_V105_rev957_USB update.bin

Workaround 2:
Set the input source fixed USB Type C … this creates other annoyances but not as serious as the main issue I document in this post

Annoyances:
Having to chose the input source manually is annoying because swithing inputs the Spectrum takes a long time not to mention when it does not work at all…

1 Like

Hi @ERodrigues,

I’m sorry you are having this issue.

To fix this, I recommend you flash the new USB firmware as well. Let us know if this solves the problem for you.

Edit: You might also want to perform power cycles after updating. Make sure that you remove power, not simply turning it on and off with the power button.

1 Like

This might be something specific to the laptop.

I’ve just tried my gaming laptop (an older Alienware model) and my wife’s laptop (a Dell Precision 5550) and I had no problem using any of the various modes. I switched between laptop display only, Spectrum only, extend and duplicate, and all worked as expected.

My Spectrum’s firmware is fully updated, and I’ve got both video source and USB hub set to automatic.

1 Like

Hi @NZgeek ,

Sure, indeed it can be the laptop however it can also be from the latest changes made on the firmware because as I mentioned this behaviour does not happen in any of the previous released firmware versions. I performed several downgrades/upgrades and tested multiple versions before posting my results. The laptop did not change, the Spectrum did :upside_down_face:

Given that you are not experiencing the same issue, are you able to share your test environment and test methodology?

Maybe it is worth for me to give it a go using HDMI on the LGgram instead of Type C… just to check if the behaviour is the same. Although the beauty of LGgram + Spectrum is that I only have 1 cable for everything :smiley:

I will be right back :slight_smile:

Update:

In my setup, when using HDMI only, I still get the same behaviour as with Type-C + v106… I downgraded to v105 using the Workaround 1 method and everything is back to normal :slight_smile:

Thanks,
ER

1 Like

Hi @Cas

My tests were performed already with that firmware flashed but forgot to mention :frowning: sorry for that.
I have updated the post to reflect that info.

Regarding this new USB firmware version, I have other post about that:

USB Firmware “06A4 / 0A.89.18.02” - (Power Delivery issues? Handshake?) - Products / Eve Spectrum ES07D03 | User Experiences - Eve Community

Thanks,
ER

2 Likes

I would try flashing v106 again (since you have he ability to downgrade to v104 when you want to get it working again), and after it is fully flashed, then run through the procedure listed here:

See if that gets your LGgram working with v106 or not.

Hi @nkyadav ,

I already tested again v106 but “no go” :frowning: with my laptop, either with USB or HDMI the behaviour is the same.

Thanks for the help!
ER

1 Like

My test environment:

  • Spectrum ES07D03, previously on firmware v105. It was updated to the latest firmware (scaler and USB) yesterday morning.
  • Laptop 1: Alienware 17 R3, approx 6 years old
    • Usually connected via DP cable to an external GPU
    • Very early USB-C, doesn’t like doing video and USB data at the same time
  • Laptop 2: Dell Precision 5550, less than 1 year old
    • Natively uses USB-C for charging and video output
  • Connected via a 50cm USB-C cable
    • Cable is rated for 40Gbps
    • Cable is used most days in conjunction with a MacBook Pro

Testing methodology:

  1. Connect USB-C cable to laptop and check that the display is connected.
  2. Use Win+P to select “Duplicate” mode, then press enter.
    • Verification: the same output is on both displays and that the mouse cursor is seen moving.
  3. Use Win+P to select “Extend” mode, then press enter.
    • Verification: the mouse cursor moves between displays.
  4. Use Win+P to select “Second screen only” mode, then press enter.
    • Verification: the laptop screen goes dark and the mouse moves on the Spectrum.
  5. Use Win+P to select “PC screen only” mode, then press enter.
    • Verification: the Spectrum goes dark and the mouse moved on the laptop screen.
  6. Revert to “Extend” mode before disconnecting the USB-C cable.

Both laptops were able to correctly cycle through all display modes. In particular, when switching to “PC screen only”, the display stuck to just the laptop screen and there was no attempt by the Spectrum to take over.

While this was only a relatively quick test, the fact that I couldn’t repro the issue says that it’s not something solely related to the firmware. It’s some interaction between the new Spectrum firmware and your LG laptop.

It’s strange that you’re seeing the same issue over HDMI. I can see the potential for USB-C to have problems because it carries both video and data, but HDMI doesn’t have that same issue. I can only assume that you’ve tried to reboot the laptop to make sure it’s not an OS-related issue.

1 Like

@NZgeek

I am not seeing what setting on the OS could cause such behaviour, maybe a driver could cause this? Maybe I will check this later when time permits… However, with v105 I have no issues whatsoever :slight_smile: so it is hard for me to “blame” the LGgram on this (at least for now).
I will wait for more people with 11th Gen i7 to see if they have similar/same behaviour.

When you move to “laptop only” mode, can you wait 1-2min and let me know what happens?

By the way, thumbs for for that Dell Precision 5550, I reckon a 10th Gen? Dual NVME + 4GB GPU? What a workhorse!!! :muscle:

Thanks,
ER

1 Like

I can’t think of anything obvious that would cause this off behaviour. It’s definitely not something that Windows would do.

The graphics drivers are a possibility. If they run into a situation where they somehow think that the internal display isn’t working correctly, they might decide to switch to just the external display. But I can’t think of anything that an external display could do that would cause this.

I’ll retry both of our laptops later on to see if either of them will switch to external monitor only. It seems unlikely, but we’ll see.

And yes, my wife’s laptop has an i7-10850H with a 4GB Quadro T1000. It only has a single NVMe drive, but it’s enough for her. (It’s amazing what you find for sale at CeX.)

2 Likes