Touch Screen Not working Issue

Hello, I have an early Eve V. The touch screen was working a few days ago, now nothing.
the Device Manager shows the HID Touch Screen Driver loaded, but the information says It cannot find the touch screen device.

Since Support does not respond to support questions, I put this out to all of you.

FYI the processer is not supported by Windows 11 (It would be nice if we could get one that does and replace the current one. but I am sure Hong Kong will not support that. Also there is no place I have found in the US where they support the device.) buyer beware


Device System Info

|Device name|V|

|Processor|Intel(R) Core™ i7-7Y75 CPU @ 1.30GHz 1.61 GHz|
|Installed RAM|16.0 GB|
|Device ID|B79EBD28-44E4-4103-A71E-F5461AF9DF51|
|Product ID|00325-95817-67249-AAOEM|
|System type|64-bit operating system, x64-based processor|
|Pen and touch|No pen or touch input is available for this display|

Possible things to try (that you may have already tried), in increasing order of level of hassle (and data/application loss) to determine whether it is a hardware fault or just a software problem:

  1. Completely turn off the PC by holding down the power button for more than 15 seconds, and then turn on.
  2. Go back to a system restore state that predates when the touch screen stopped working
  3. Reset Windows 10 to its default state or do a clean install
  4. If you made a backup of the SSD when you first received the machine, restore that backup to take it back to its factory default state.

Note that Windows 11 does install on the V with registry change to ignore out-of-date CPUs. I have Windows 11 running on my V and it seems to be running fine.

Hi, I went back to the reset windows 10 point. re-installed and still the touch screen does not work. Grrr. I hope the update to windows 11 with the registry override works

Hi. Yes, you can install Windows 11 with a registry fix, but I don’t think that will fix anything - it certainly didn’t fix my fingerprint problem. Do you have any items in “device manager” with an “!” indicating that there is a problem?

There are no issues in the windows device manager. I upgraded the Bios and that restored the touch component of my Touch screen. The downloads available on the Dough - Power your passion are not very clear at all, but trial and error seems to have worked. When I did upgrade to windows 11, it would not permit any updates, that is something I was not prepared for, since we know MSFT is a buggy product at best since so many moving parts. I am now back to windows 10 and building on that. When EOL comes for Windows10, I will go from there.

The BIOS upgrade seems to have fixed the touchscreen issues

2 Likes

However, now the screen no longer works. Oh and don’t ask for support. Their team are all in Ukraine. :frowning:

Hi @LeeL1,

Thanks for showing concern towards our support team, most of our colleagues are now in safe locations in Ukraine :pray:

Please contact our support team if you have any hardware issues; they will try to respond as soon as they can.

My Touchscreen still has ghost touches. The driver offered by EVE V is not a driver it is program. I need a driver that I can link to the HID touchscreen in Device Manager.

Please send a link to an actual driver

I have attached a video of how annoying the ghost touch is
explorer_LbwmEwEJ0J

Unfortunately, this was a common issue with the original Eve V.
I’m not sure whether you will be able to see this thread, but it’s documented here:
https://dough.community/t/ghost-touches-when-coming-out-of-sleep/13458

In summary, Eve never released a fix for it.

Hi Phil
I can’t access that thread, it says it private or deleted
I am pretty much going to throw it in the bin. I used to use it for drawing but I cant now
Will have to look at a surface
What amazes me is the complete lack of support , and the focus on a new product when the old one does not work.

Hi @Joel_Brasher-Jones. Well, we did get more support for the V1 than customers for the V2! As for your problem, the thread doesn’t say much. But before you throw it in the bin, I would suggest trying (after backing up all your data etc.), in the following order (if you haven’t already done so):

  • installing a different BIOS from the Dough download page
  • trying in safe mode to see if you have ghost touches there
  • trying a clean install of windows (after backing up the color calibration values)
    etc.

@phil I tried all these and still nothing, anyone want to buy a bricked EVE V?

Hi @Joel_Brasher-Jones. The only other suggestion I have is that you may be able to disable the touch driver from windows (disabling “HID-compliant touch screen” in device manager).

That will mean that touch input on the screen will not work at all, but at least you won’t have any more ghost touches and can use the tablet with a mouse/touchpad.

@Phil well now thatnhas completely disappeared and now i am bsck to the I2C hid device error (code 10). Nothin is going right

@LeeL1 quick question, which Bios update did you do?

Cheers