Spectrum Inputs Always Active

I’ve got 2 Spectrum 4K’s and use them for work, PC gaming, and console gaming and I’ve noticed that the inputs of the display all stay active even when the device is switched to another input.

For example, my PC is connected to both monitors and lets say monitor 1 is set as the primary display. Now I also have my PS5 connected to monitor 1. When I switch inputs on monitor 1 to the PS5, my gaming PC still sees monitor 1 and is outputting a signal to it.

If I power on the PS5 first and then boot the PC this results in the login screen being displayed on monitor 1 and I have to switch inputs or disconnect the DP cable.

Now I could swap displays and put the PS5 on monitor 2 to counter this, but the input is still active at this time and can have windows. You can still drag windows to this display even though you have changed the input. Keyboard shortcuts might move windows here.

I would like to see a firmware update address this input activity and make the inactive inputs actually be inactive so that windows and macOS stop registering them as being connected when the monitor is set to a different input.

1 Like

I think that might be normal, but I could be wrong.
With my Eizo, having the PC connected via HDMI and Mac via DP the PC still sees the Eizo when switching to Mac.
But since I did this the last time very long ago, I might remember it wrong

Especially what will happen if your primary monitor would be “offline” for win? Taskbar and everything would be moved to secondary monitor, including shortcuts etc. Win would need to set the primary monitor to the second one, since the first one is no more available. would be a pretty mess I guess…?

That would be ideal for me. Even if this was an option in the settings to adjust behavior. I don’t know if it’s standard in other big name displays as I haven’t had multiple displays with this kind of input capability to use them like I do with the Spectrums.

When I switch to HDMI1 I would like the DP input to go inactive and have Windows update to only see one monitor.

hmm I’m not sure how you’ll be able to fix this. this does happen with my tv and it’s an hdmi setting I had to turn off which was something like turn device on with tv or auto-switch source when device powered something along those lines…I’m not sure if such a setting is available in Spectrum. I haven’t done a single firmware update yet lol