Spectrum ES07D030 _ 6A4 / 0A.89.19.02 : What's the matter?

Date Published: September '22, the 5th.
Ok but…
when you try to click the link… Error “404 page not found”!
Plus, the link was available even some days before the 5th, but not absolute sure. it’s just a vague impression…!
Nothing found about this, on the community… that’s why I’m asking here!

Hi there,

Sorry but I am not sure exactly what you were referring to. Can you please elaborate?

ES07D03


[06A4 / 0A.89.19.02]

404 Page Not Found

2 Likes

Hi there,

Ah I see. The download page for the USB hub is not working. Let me bring this to the team.

1 Like

Hey there!

It should be fixed now.

2 Likes

Anyone else getting an issue with this firmware? I’ve tried different cables and using both USB-A&C connections but always the same error. No other results for Error! Upgrade FW failed, BinFile_ERROR

HUBIspTool_TI5aTOhZWg

2 Likes

Hey there @Benihana

Yes, you will need to uninstall, reboot and then reinstall. Make sure you are only connected to Spectrum via USB.

Screenshot_13

1 Like

Thanks, that was it :blush:

2 Likes

So I attempted this update, and was able to connect to my monitor using the setup in the PDF that came along with the update software. I connected via USB-B. The software recognized the monitor and allowed me to start the firmware update process. However, there was an error in the output window saying the update had failed, but the progress bar was about 2/3 full. I let it sit for a while, not wanting to do anything in case the program was still proceeding.

After about 10 minutes with no progress I clicked the scan device button again, and it found the device but oddly the message said “running on ROM code” under PD-Device This also cleared the previous error message on the output window, so I do not have the exact wording to provide here. Hoping this was just some error with the system, I power cycled the monitor in hopes of resetting the monitor and restarting the update process. However, I can no longer connect to the monitor as each scan shows “No device found!” The monitor is no longer responding to USB inputs (my keyboard and mouse were attached to the monitor at the time of update).

Is there a way to revert back to factory defaults, or is this a situation where the USB hub is just permanently busted? I was hoping to update this as I have been experiencing issues when connecting to my computer via USB-C, but it seems that I’ve only made things worse…

1 Like

Hey @mirman_manofthesea

It never completed flashing the USB FW. Instead of performing a power cycle you would have been able to flash the FW in its current state.

Though, if you can disconnect every peripheral connected by USB to the device used to flash that is not needed (so keep mouse and KB if present), unplug Spectrum from electricity for about 1 minute (turning off will not work), and then only connect to Spectrum from one device and by USB, and verify that the correct USB mode is selected in Spectrum OSD and see if it shows back up in Running on ROM code mode again.

After that,

  • Uninstall the USB Flash utility completely.
  • Reboot device
  • Install USB Flash utility
  • Reboot computer
  • Run USB utility and verify if it is showing that same message again.

If it does show Running on ROM Code then you can flash the FW.

Also, if applies, only try to flash one Spectrum at a time.

All of this needs to be completed and nothing can be skipped, please ensure to read the instruction.pdf that is provided when downloading the firmware thoroughly.

Also, if you ever need to revert to defaults in the future, the option to do so in your OSD > Presets
Screenshot_15

Thank you @Aethel, that fixed it! Letting people know just in case they have the same problem.

Screenshot 2022-09-09 162435