Spectrum ES07D03 | Firmware Update Version 107

running win 11 and still does not recognise as HDR compliant after updating to 107.

It only takes 2 minutes?

1 Like

I am super excited about this:

I have successfully updated to 107 and I want to create hotkeys to switch inputs on the monitor, however I am having trouble and hoping you can help clarify how to take advantage of this new capability…

On Windows, I’m trying to use the program Control My Monitor to send DDC commands. My Windows PC is connected via DisplayPort, and I have devices connected to USB-C, HDMI1 and HDMI2.

With the monitor on the DisplayPort input, the program shows VCP Code 60 with a setting of 16. However if I try to change that value (either from the UI, or using the “/SetValue” command line argument), the monitor flashes for a moment but remains on the DisplayPort input.

Also I’ve noticed that when the monitor is not set to DisplayPort input, the app is not able to read the monitor VCP values, and /SetValue 60 doesn’t even flash the monitor.

If there is a different technique or program you used to test this functionality, or any advice you can provide on how to achieve what I’m after, please let me know! Thanks!

1 Like

Same. Got a email today about the 107 but doesn’t have 107 :man_shrugging:t2:

Went to update to 107, installed it and waited for the instruction to power cycle. Unplugged the dc plug, waited 10seconds then plugged it back in. Now monitor won’t turn on. I’ve checked all connections. Any ideas?

The firmware download is a ZIP file containing 3 files:

  • A PDF with the firmware update instructions.
  • An installer for the firmware flashing tool.
  • The firmware update itself.

Simply download the firmware update and unzip it. Everything you need is there.


それらは英語であるため、日本語に変換するには Google Translate などを使用する必要があります。

You need to go to the support page on EveDevices.com. Click on the word DOWNLOADS and you’ll see a list of downloads for all of Eve’s devices. The firmware is under Spectrum ES07D03 > Scaler Firmware.

For some reason the updates are listed from oldest to newest, so you have to scroll down to find 107. It’s definitely on the list.

Have you got low-latency mode enabled? If so, you’ll need to turn that off before you can enable VRR.

Low-latency mode isn’t really required for the Spectrum. It’s more of a thing for TVs that do large amounts of picture processing before showing you the image.

Have a look at this post where I list a bunch of things you can try.

1 Like

I’m glad to see there’s some new help in the firmware department. Welcome aboard!
I was using the beta firmware that 8bit directed me to here. I was excited to get the freshest official firmware and hoping it would resolve some of the lingering issues I’ve had (although they have been slowly getting better). Unfortunately it seemed to bring back a previous problem I had with the monitor never actually going into standby mode. It blacks out the screen when windows tells it to power save, but the backlight and status led never actually enter power save mode. Little bummed to see an old problem resurface, also means my monitor stayed on all night just like the old days. I think I’ll go back to the test firmware since that problem was nonexistent then (although still had blanking out while gaming, but less then previous firmware).
win11, nv3080, DP connection


@systemofadead Does this mean you have the ability to create test bins? I would like you to edit the splitscreen EDIDs in the bin and see if that fixes the nvidia surround problem.

I have noticed something odd, now this is happing on ps5. Fw 107

VRR monitor on & off - tested
120 hz on ps5 set to on and off - tested

Game tested: spider-man remastered & spider-man miles morales

Settings in game:
Fidelity mode enabled
120hz mode set to auto on and off tested.

Now while the ps5 is set to 120hz and VRR is enabled on monitor and ps5 the cut scenes inside these games the transitions between who’s talking or camera point of view change is like a bad cut edit from TikTok there is no transition not smooth.

As soon as I turn off VRR on the monitor the ps5 is still registering it as it’s on. Same above problem

Go into settings on ps5 and turn off 120hz mode and go back into the game and the transitions are smooth and not cut edit

Enable VRR on the monitor and keeping 120hz off on the ps5 while also having ps5 VRR enabled the cut scenes are smooth still,

But soon as 120hz mode on ps5 is enabled the cut scenes are like TikTok edited cuts.

I also have video of the old problem while launching spider-man remaster happened once then went to record and the problem didn’t happen. Closed the game and re launched it again while taking another video of it and soon as the start menu pops up you click continue and then the screen goes black and will not pop anything up unless you hit the ps button on the ps5 controller and you can see the screen again but if you hit it again the screen disappears and you can still hear the game, so blindly clicking x to load your game then it will turn back on when the game loads.

Tested it the same way I did above with the bad edits

I’ve tested other compatible 120hz games on Xbox series X w/VRR and haven’t run into any issues with fw107 everything has been working great so far

That is probably because VRR changes the refresh rate constantly and if you set it to 120hz you are binding the VRR from being able to change. When I enabled VRR on my monitor and PS5, it made playing COD unplayable. At least for COD, it seems like it runs way better with 120hz on and VRR turned off.

The one thing I really wish would be on the next firmware, and something I have been saying every firmware, is that the crosshair style and color do no save with the presets and turn back to default whenever I need to change to a different preset. Also, it would be nice to have a light spectrum color field, like what Microsoft has, for being able to choose a crosshair color. There could be 5-7 main colors but the ability to choose a custom color would be nice as well as adding in a custom icon, like the symbol selection that MS Word has. This is a small thing in comparison to everything else but this would be nice, at least to save to desired crosshair type and color. Grinding through handgun camos is a bitch.

Like @wuice I am also observing a regression in 107 to do with monitor standby. I run my two Spectrums on DisplayPort, and on firmware 106 I was able to change the input from Detect Automatically to DisplayPort, and successfully sleep the monitors and have them wake themselves up without disconnecting from Windows and messing up my desktop backgrounds and window positions.

However, since upgrading to firmware 107, this no longer works. I set the monitors to DisplayPort, sleep them, and when they wake, they have disconnected and reconnected to Windows which has caused wallpapers and window positioning to get mangled.

Here’s a video of this behaviour in action: EVE Spectrum ES07D03 Sleep Issue - Firmware 107

This makes monitor standby as a function practically useless. I’m going to revert to firmware 106 and hopefully you guys can fix this regression in the next firmware version. (Edit: I can confirm that reverting to 106 resolves the problem) I’d love it if monitor sleep would work in Autodetect mode, not just DisplayPort mode, but I can settle for it working in DisplayPort mode.

Sleep has disappointingly been a long running issue with these Spectrums. Here’s some previous discussions on the forums for reference:


So far appears to be slower than fw105 when making a side-by-side comparison


Next Problem:

On my system this isn’t working. My display is connected to a Nvidia 3080 via DisplayPort (1 of 2 displays on the system). On firmware 107, changing to any framerate below 60hz using the System > Display > Advanced display control panel in Windows 11 results in an all black screen. This is also replicated using PlexHTPC app and selected “Match Framerate” option in settings.

This was working fine in 106 in my system, so for me this is a regression. I am on the latest Nvidia driver (516.40).

Also of note, the Nvidia Control Panel only lists 144, 120 and 100Hz as available refresh rates for the monitor now:


Hey @Ratfink

Thank you for describing this issue so thorough! I have sent you a DM asking for information!

1 Like

Hey there @James_M I have sent you a DM to gather further information about this issue!

Hey @Edocsil2020 I have sent you a DM regarding this issue to gather more information to send to them team!

After the update v107 :
1-sometimes I got stuck on the logo when I turn it on and it doesn’t response even if I try to turn it off.
So I have to cut the power off
2-It take more time when I turn it on to response or to get to the hdmi .
(I am using it with PS5)

I did the 107 update today and followed the procedures 100%. After the last power cycle, the monitor turned on and I went into the OSD to check information to make sure it said 107 firmware. The monitor turned itself off and now will not turn on.

I sent a message to support and they said that most of their support people are in Ukraine and we all know what is going on there.

Does anyone know how to force the firmware to reload to the base firmware?

I have to report an issue: HDR doesn’t work with Prime Video on Xbox Series X, colors are washed out and it’s literally grey everywhere.
Edit: Firmware is 107

1 Like

Sorry, but where can I turn off low latency mode, on the ps5 or spectrum? Thx