Spectrum Connecting to Macbook over USB C

I use my spectrum 4k with my macbook connected via TB4 cable to the USB C port on the bottom. I am able to get 4k 144hz of this connection and i am able to charge my macbook over 1 cable. But whenever I disconnect the plug and try to replug it back into the laptop it does not get a signal. Only when I shut down or restart my macbook am i able to reconnect to the display. I have tried different macbooks and they all have the same problem. Does anyone know a fix for this, plz let me know.

1 Like

Hi there!

First of all, welcome to the community!

That is odd, I can’t recall if this is something that has been reported before. However, can you please check for me if the Macbook still receive power, even when Spectrum receive no signal?

When there is no signal the mac will still get power, it will still be able to connect to the usb hub where I have my keyboard and mouse connected however it will say no signal unless I restart, I have tried on other macbooks aswell and they had the same problem. My firmware on the monitor is 105, not sure if that is the reason, but I have read other threads that updating the firmware could pose other worse connection problems.

If you have access to a Windows PC, you might want to try updating the USB firmware.

The latest USB firmware version (06A4 / 0A.89.19.02) has a change that looks to be directly related to your issue:

Resolves issue where the monitor does not properly resume from stand-by mode with Apple silicon-based Mac computers over USB Type-C for some users.

You can download the firmware from the Dough downloads page.

I have access to a windows PC but I have no clue how to update the usb firmware. Is it a complitcated process? I am also worried about the update causing more weird issues with my monitor.

I sometimes face a very similar problem which happens also when the Mac goes to sleep, but unplugging the cable and reconnecting the MacBook always fixes it. If you can’t get it to work without a restart I would definitely recommend updating the USB firmware. It’s pretty easy, the instructions are included with the firmware download, and if you face any issues in the process feel free to post here and we’d be glad to help you out.

Can I update the firmware of the USB with updating the firmware of the mointor to 107? If this is possible I will try to update and see what happens.

I am also having trouble find the firmware download for the USB hub.

I believe you should be able to. I’m on the latest USB firmware with 106.

You can find it on the downloads page under “Spectrum ES07D03” in the “USB Firmware” dropdown.

I have found the download and the instructions. It tells me I need the firmware update tool. I cant find it on their downloads page.

UPDATE: I downloaded the firmware for 107 and the USB hub firmware update but I am still having the same problem with my macbook. Not sure why this problem is still persisting. Thanks for the help so for much appreiciated.

Hey there,

Sorry that you are still experiencing this issue. We will have the next firmware version coming out relatively soon. It will come with several optimisations and bug fixes, so stay tuned!

1 Like