(SOLVED) Only 30hz with USB-C (TB4) Cable on Intel Macbook Pro 16" 2019

Just received my Spectrum and it is certainly fantastic.

Unfortunately I don’t get any signal when connecting to my Intel 2019, Macbook Pro through a TB3 USB-C Cable.
This TB3 Cable was provided with my LG Ultrafine 27" 5K Display and it works flawlessly on that monitor so cable shouldn’t be the issue.

Im using the bottom usb-c port and not the one on the side.

Ive also tried switching the usb-c bandwith to usb 2.0 & 4k @ 144hz but still no signal.

EDIT: Tried another TB4 Cable and it worked!

However Im still stuck at 30hz on Intel Macbook Pro 16" 2019 on Big Sur

1 Like

The Spectrum does not support Thunderbolt natively in any way. However, it should support using a Type-C cable from the TB port on the MBP to the Type-C port on the back (bottom, as you noted) on the Spectrum.

The issue here is that the UltraFine displays actually support native TB (found this out when researching a TB 3 to TB 2 adapter for use with UltraFine displays and older MBPs), so that cable works for those monitors.

Can you try a regular Type-C cable and see if that works?

1 Like

A TB3 or TB4 cable should work just fine. From what I’ve been able to tell, they’re physically identical to a standard USB-C cable but have tighter requirements due to the higher data rate.

I’m using a relatively cheap UGREEN TB3 cable from Amazon and it’s working just fine. It’s only a short cable (50cm, or around 1.7ft) but it’s doing the job.

I did do a firmware update (using a Windows laptop) straight out of the box, so never used the firmware that came on the Spectrum. I’ve used firmware 102R875 and 104 with no serious issues.


Interesting! Will try another usb-c cable then

Thank you for the confirmation regarding TB 3 / TB 4 cables.

I tested with the TB4 40gbps cable and it worked!

However still stuck with 30hz?

You should be able to get to 60Hz.

There’s something about the resolution information reported by the Spectrum that causes it to get set to 30Hz by default. But if you go into the display settings and option-click on Scaled, then click on the checkbox to enable low resolution modes, you get the ability to select a refresh rate.

It should be possible to get to 120Hz with HDR disabled, but that’s not available for some reason. It looks like it might be a MacOS bug.

We can’t currently get to 144Hz yet because the USB-C port doesn’t support DSC. This can probably be enabled in a future firmware version, but we don’t know when that might be yet.

Already tried that and it did not work unfortunately, the only resolutions that allowed 60hz was really low resolutions

Screenshot 2021-11-26 at 23.05.19

1 Like

I’m also having this issue, both on Windows and on Mac.

I have essentially followed the following setup:


The displayport side of things is 4K60Hz at the moment. However, when I use the USB-C/Thunderbolt side of things, it either

  • Displays 4K30Hz (Windows)

  • Displays nothing (Mac)

I have tried plugging the USB-C cable directly between the monitor and the macbook (i.e. avoiding the TB19 dock altogether) and even then, I only receive 4K30Hz out of this. I can reduce the resolution to get a higher refresh rate, as above. The USB-C cable I am using is this, so my (perhaps naive) expectation is that this is sufficient for a 4K60Hz signal. Am I missing something, or can someone offer any suggestions for me to try?

I have an intel based Macbook Pro (Mid/Late 2017) running latest OS, if that’s of any relevance as well.

Any thoughts on the 30hz issue?

It’s highly likely that you’ll be stuck with lower frame rates while using a dock.

There are 4 high-speed data lanes in a Thunderbolt 3/4 cable. These are always used in pairs, and each pair can carry either video (DP) or data.

Given that a TB dock has a bunch of USB ports and a network port (or 2), it’s probably using 2 lanes for data and 2 lanes for video. This automatically limits the video signal to 4K@60Hz.

If you’re plugging in 2 monitors, you’re then splitting that video signal in half, meaning that each monitor can only get 4K@30Hz.

This doesn’t explain why you’re still only getting 4K@30Hz when not using the dock. That’s certainly not expected behaviour. You should be getting at least 4K@60Hz, or 4K@120Hz without HDR.

1 Like

Thanks for your reply, informative for someone like me who doesn’t really have a clue about how these different technologies work. Indeed it was an expectation when using this dock that things wouldn’t be perfect, so I’m not too worried if things stay as they are.

Just by way of an update, updated the firmware on the dock and there was only a small update which didn’t mention anything like this. I then used a Thunderbolt > DP cable in two cases:

  • From dock into monitor > result was 4K30Hz as before
  • From macbook into monitor > result was 4K60Hz with HDR (expected due to the limitations of this Mac)

I also tried PS5 into both and achieved 4K120Hz through HDMI; I’m reasonably content the monitors are doing what they are supposed to. I think your observations are correct, but it doesn’t explain why one monitor is achieving 4K60 whilst the other is on 4K30. I don’t think I’ll lose too much sleep over this though!

I will try to see what happens when I connect both monitors to the macbook simultaneously without the dock, and post results later this evening.

I have the same setup and played around with the settings to see if I can replicate the problem. If you connect to Spectrum via TB4 cable and set the USB-C bandwidth priority to High USB data speed I get 4K at 24hz but if I change it to High refresh rate I get 4K 60hz. But you will need to unplug the TB4 cable and plug it back in after that as it will show no signal. Maybe that is the solution to only getting 30hz?


What the hell, this actually worked!

Switched to High refresh mode and reconnected my USB-C cable and got signal.

I can’t understand why none of my thunderbolt cables work. Trust that I paid plenty for them and they work for everything else. Bizarre.

Techmo is correct.

In the Spectrum’s manual, on page 30, you can see this laid out.


Note, this is maximum, not necessarily achievable based upon your system setup, so it will play a factor in what you actually get. IOW, to maximize your refresh rate, change the setting to High Refresh Rate.


It’s very unusual that you can’t get anything to work, because I’m using a relatively cheap TB3 cable and it’s working fine. (MacBook Pro 2019, 15.6", Radeon 560X)

The only things of note on my setup:

  • I flashed my firmware to 102R875 immediately after receiving the Spectrum (via a Windows laptop).
  • I’m currently running firmware 104.
  • I have my Spectrum’s USB-C bandwidth priority set to high refresh rate.

I think 102R875 contained an update for the USB hub, so it might affect things. However, it requires a Windows laptop and a working USB connection (e.g. using an old USB-B printer cable) to perform the update.

Quick explainer on the technical side of this.

As noted above, Thunderbolt 3/4 cables (and high speed USB-C cables) have 4 pairs of wires for carrying high-speed data. They also have a separate pair of wires that are dedicated to USB 2.0 data.

Putting the Spectrum in high USB data speed mode splits the 4 lanes in half: 2 are used for USB data and 2 are used for DisplayPort. This limits the bandwidth available, therefore limiting the possible resolutions and refresh rates.

Putting the Spectrum in high refresh rate mode uses all 4 of the high speed lanes for DisplayPort data. Only the USB 2.0 wiring is used for USB data, which is why the USB speed is limited to 480Mbps. This is plenty for things like keyboards and mice, but may struggle with flash drives and network adapters.


Yup this is great, the only thing missing now is 144hz through USB-C TB4 in MacOS. Right now the maximum seems to be 60hz

1 Like

So - no matter what - gots to find me a windows machine! Darn. Was hoping the built-in program would “see” a usb drive or stick. I suppose it could not execute anyway, but I have some fairly small appliances which do just that. Any advice - maybe linux?

Firmware updates are performed using the Mstar ISP protocol. BlurBusters put up a post a while back that talked about different ways of doing the firmware update, including via Linux.

I haven’t looked much into these methods to know what’s involved. However, the post does say that there’s a chance of bricking your monitor doing this.

It’d be great if Eve could build in a firmware update method that reads the update from a FAT32-formatted flash drive, and internally does the copy into flash storage. Given that the flash data is currently sent over the USB bus, this does feel like it’s possible. Sure, you’d need access to a Windows PC to move onto this firmware, but after that you’d be fine.

1 Like