Quick update about drivers & firmware

Quick update about drivers & firmware

Most driver updates have been made available through Windows Update, and you have probably installed most of them already in the past months. Though we try to provide as many updates as possible in the easiest way possible, not all component manufacturers have submitted their drivers to Microsoft. You may need to manually update the driver for your fingerprint reader if you are experiencing issues with it. You can download that and other drivers from the Support page on our website. For more information on driver updates, please refer to this FAQ article.

Firmware updates are available from the Support page on our website as well. As with any firmware updates, make sure to read the instructions beforehand. Also, ensure that the device has power, and that the update process isn’t interrupted. For more information about updating firmware, please refer to this FAQ article.

Notable updates at this time are the BIOS and Battery EC firmware. After testing, the beta BIOS version 0.41 is considered ready for release. It includes fixes for security vulnerabilities (Meltdown, Spectre, Intel ME) and improvements to power management (for example, to reduce battery drain during sleep). The Battery EC firmware is purely optional, but will increase the speed at which the V’s internal battery charges. A useful update for people who don’t have a lot of downtime to charge!


…split topic…


Bios update installed, working ok.
Non anounced small hickups:

  • Windows defender blocks installation of new bios update
  • pincode for startup gone
  • fingerprint reader does not recognize finger anymore

It may be usefull to add this info to the instruction pdf.


Never have an active défense system when upgrading à firmware of any kind. You can do that only if it has some sort of CRC checking or checksum validation.
No any hiccups for me but again, I’ve sanitized the system previous to upgrade.
Stable for the moment. No problem with the VM either. I’m going to make a thread later on.

Not able to make the fingerprint reader to work neither.
Every pilot available on the support download section only show an error code 10 (this device cannot start) in the Device Manager.

All the updates worked fine for me except thunderbolt, but thanks for the other 4! Ever since I reinstalled windows on my V I haven’t had any thunderbolt drivers. Any idea on how to fix this?


I’ve installed BIOS 0.41 BETA and Battery EC firmware and Windows doesn’t boot anymore (Linux boot fine, I have dual boot). Windows doesn’t even boot in Safe Mode, I can only see cursor with loading icon when tapping on screen for a second and then I can’t do anything.

@grimor I wouldn’t have done à dual boot on the same nvme ssd but that’s your call (for several reason,changé of firmware, change of driver, Windows update that might changé something in how ntfs is handled or gpt etc) anyway if you have a windows startup problem then you should try the diagnostic tool by launching from an usb windows installation media and see what can be salvage.

You can also analyze the partition scheme under Linux of your nvme disk and see if something have changed and also verify the correspondances with your grub configuration(if it’s still the good point to boot etc).
I don’t know how you installed your boot loader, if you did it properly manually or if you did Follow a tutorial.
So it depends of a lot of things. But it’s not because the update screwed your setup that the cause is the update. The cause could be that you didn’t think of everything while creating your bootloader partition.

So salvage what you can by using the diagnostic tool, if you had important files on it. And if not, then recreate all this from scratch and think when creating your bootloader partition first.

Installed the updates as well(not Beta BIOS tho). TB3 won’t update and Fingerprint driver doesn’t fix the sensor.

Also, my PIN code got corrupted, giving the message “Something happened and your PIN can’t be used…” when I tried to log in. Had to login with my Microsoft account PW.

Got it fixed by following this tutorial. Dunno if this was an isolated incident, but rather inconvenient.


that happened to me too with the PIN. Still can’t get the fingerprint sensor to work or the thunderbolt driver to install. When I try and update the fingerprint sensor, it tells me I have the most up to date driver which is listed on the website as the newest version. However, the driver details list the date of 10/27/17 but the one on the website says that this version was released on 6/3/19. Anyone have any ideas?

1 Like

I’m using windows boot manager to boot windows from mbr, grub is installed on linux partition and I use it occasionally by choosing BIOS boot drive choose option to boot linux. Anyway, windows was booting fine but I’ve got black screen before login screen and can see cursor when tapping on screen. I’ve done Windows reset through repair disk and It booted fine but settings app doesn’t worked and can’t lanuch any windows store apps. I’ve gone through all sfc, dism commands etc. With no results. I’m gonna reinstall Windows today because don’t have time to make it work other way. I just wanted to let Eve team that just happened after installing BIOS update.

@rsb006 the driver date release is when it has been published by eve-tech. Not by goodix. Goodix have published their driver long ago through windows update.

@LazerCut pin situation is normal. Pin can be considered as corrupted of the security key of the system have changed some ow which certainly it had because of the bios update and the presence of Tpm and all that. If you would have look for the error message on the welcome screen and if you would have done a Google search you would have seen that in général on mobile devices the update of the bios have that effect.
But if you had setup 2FA on your Microsoft account by installing the auth app on your Smartphone from Microsoft you would nt have needed to put your Microsoft password but you would have had a nice notification to validate on your Smartphone by Following the “setup of the new pin” on the welcome screen.

@grimor thanks for the heads up then. Just for your information, only one ( by concept and as a good practice) bootloader should be installed by hdd. The boot manager is also à boot loader. So in général grub for example is replaced on the boot manager from windows. But again your call.

1 Like

118 posts were merged into an existing topic: Goodix fingerprint scanner - not working


Not the same thing adt:

In computing, the System Management BIOS specification defines data structures that can be used to read management information produced by the BIOS of a computer. This eliminates the need for the operating system to probe hardware directly to discover what devices are present in the computer.

1 Like

hmmm yes it did indeed work…

Anyone willing to share their Thunderbolt driver as well as instructions on how to apply them to my V?

1 Like

Keep in mind that a Thunderbolt 3 device needs to be connected, else the firmware update can not be installed…


ok how do you find out your BIOS version?

If it was Ă  big brand you would have a UEFI tool to access to your bios settings.
Here you d
Need to restart on it to have the information. Ir’s explained in the support version to how access it.

The beta BIOS is dated 15/3/2018 or 3/15/2018 depending on your computer config. Looks like you have the old one.