PS5 VRR test firmware - non-PS5 feedback

For those that haven’t seen it yet, Eve have a test firmware available that looks like it solves VRR problems with the PS5.

There are reports that this updates also solved other VRR-related problems, such as the screen blanking that occurs on PC.

If you’ve got feedback on this firmware update, and it’s for platforms other than the PS5, please post it below rather than clogging up the PS5 VRR thread.

1 Like

A few people have noted issues with a black screen being shown when powering on via the power button, or coming back on after sleep.

I’ve detailed my findings here:

Workaround: unplug the power for a few seconds. The Spectrum will work properly on its first boot after power is plugged in.


Feedback has already been sent to the firmware devs about the issues noted above.


Two more pieces of feedback to add.

I noted that on Friday evening, the Spectrum had decided that it didn’t want to turn off. The power LED showed that it was awake, and the screen backlight was on even though the picture was black. The only thing connected was the MBP, but it had been sleeping for hours. I turned the Spectrum off via the power button on the back.

I’ve now just hooked up my gaming PC and turned it on, and had massive trouble getting the Spectrum to turn on. Disconnecting and reconnecting the power did nothing. Tapping the power button on the back did nothing. I tried disconnecting power, holding the power button for a bit, then reconnecting power. Nothing was working.

I checked that the power supply was working, and was getting a steady 20.2v output (according to my trusty old multimeter).

What eventually got it working was holding the power button on the back for about 5 seconds after power was reconnected. The Spectrum woke up, but didn’t pick up a signal thanks to the test firmware. Disconnecting and reconnecting power finally got a signal in Windows.

I’m definitely going to switch back to v106 after tonight because the test firmware is far more buggy than v106 for me.

1 Like

Still having screen flickering issues running 105 on Xbox series X

1 Like

Delete this if you don’t want it in the non PS5 thread, I posted it here as my monitor is unresponsive to any input on the FW-PS5, the PS5 isn’t the root cause.

First time on FW-PS5 all worked very well PS5 & PC, turned off, tried a few hours later no display on any input.
Went back to FW106 all worked as before.
Tried FW-PS5 again, unable to get any picture from the start, only Eve logo displays and backlight.
Yellow OSD initially. Monitor power button didn’t respond. After full power off OSD normal, still no display.
Rarely get a no signal message just no display.
Now back on FW-106
(this is a brief summary! must have performed 10-15 full power cycles overall.)


I played about 4-5 hours of Mass Effect last night. With that length of play, I would generally have at least 1 incidence of the screen going black and being dumped back to the desktop (with the game running in the background). There were no such issues this time.

I did run into 2 issues unrelated to black screens.

The first is that when booting into ME2:LE, I got no picture on screen. I’ve never had that before. I managed to fix it by alt-tabbing out of the game, then going back in.

The second was getting G-Sync to work. I regularly find that the Spectrum isn’t detected as G-Sync compatible after booting into Windows. That’s usually fixed by power cycling the screen with the power button. That obviously won’t work with the test firmware.

I tried toggling adaptive sync using the OSD. The screen turned black for a few seconds when turning the setting off, and again when turning the setting back on, but the screen was not detected as supporting G-Sync.

In the end I had to disconnect the DP cable for a couple of seconds. When things came back, the Nvidia control panel finally registered that the Spectrum was G-Sync compatible.

That’s certainly unusual. Most feedback so far, and my own personal experience, is that disconnecting and reconnecting the power gets a picture to show again. At least until the display sleeps or you use the power button, at which point it breaks again.

Just so that others know, you have to fully disconnect and reconnect power in order to get a picture signal with this firmware. Using the power button only won’t work. You have to either pull out the DC power plug under the Spectrum, or to turn off the power adapter at the wall.

1 Like

With firmware 106a I have occasionally flickering at the top of the screen.

Windows 11, GTX 1070 latest firmware, Displayport 1.4

1 Like

We have a new fw test bin that I just got and flashed.

For the record, test 2 caused me to experience blanking a lot, though I never experienced the yellow OSD. However, the fw dev team has stated that this test bin specifically addresses the yellow OSD, and may or may not affect the slow / no load with other devices.

Still, it’s progress. I’ll post the new test bin in the PS5 thread shortly. Link to the thread already provided in NZGeek’s OP above.

1 Like

There’s been some additional feedback in the main PS5 firmware thread, related to the new test build.

I won’t be able to run any tests tonight, but should be able to do productivity (MBP) testing tomorrow.

1 Like

Test3 firmware fixed the flickering :+1:


No worries, man - I, myself, have not been able to test either. And I probably will not be able to test for a few days more.

Flickering on PC? Awesome! I might need to test this sooner than I can lol.

1 Like

Yessir! Haven’t seen a single flicker in 8 hours


I’ve just flashed Test3 so that I can run it during the day with the MBP. Hopefully it’s fairly stable.

One thing I noticed is that this flash didn’t reset my v106 firmware settings. Not that I’m complaining - it’s nice that I didn’t have to go in and reset my USB bandwidth and LED settings.

Just in case it matters: I did click in on the settings stick prior to the power cycle, in the hope that I could switch the USB input back to auto. There is a slim chance that this caused the current settings to be re-saved even though the on-screen content didn’t change.

Kept my LED settings as well, nice to know if it keeps the custom temp settings, I gave up resetting them after rolling FW back and forth so much.

1 Like

I’ve been testing these for several days. I think I saw one or two fast flickers total, but not a single longer black screen (well, other than the expected ones when changing resolutions).

Test 3 also seems to come back on after sleep most of the time, although there was once where it didn’t and I had to power cycle to get it back.

Like others have said, it didn’t reset my settings on flashing, but I did a “restore factory defaults” in the presets area to be safe to make sure I didn’t have any corrupted settings.

It still doesn’t always turn off the backlight when in sleep mode, but even that seems like it may be slightly better? I’ll keep an eye on it.

1 Like

I’m just about to finish up a day of productivity use and have had no notable issues so far. Test3 appears to be stable enough for me to use as a daily driver for now.

I did find that my backlight settings weren’t great for telling if the Spectrum goes to sleep. I had it set to 128/32/32 (dark red, #802020) but it was coming out almost white. I had to bump it up to 192/32/32 (blood red, #C02020) to get the red I was expecting.

I don’t think this is due to the test firmware. I’d just forgotten exactly what settings I was using with v106, and the Spectrum’s LED colour controls have always been terrible.

1 Like

There’s a new firmware available:

I’ve just downloaded and flashed this firmware. Unlike PS5.Test3, this one will wipe your settings so be prepared to set everything up again.

The note there about DSC over Type-C is interesting. I thought that this was already present on v106. Regardless, it hasn’t allowed me to get more than 60Hz on my Intel MBP.

I’ll be able to test it for gaming over the weekend. Fingers crossed it’s stable and I don’t see flickers.


Feedback from the PS5 thread.

I can confirm no issues noticed on MBP over the last 2 hours.


Test 4 resets everything, so that is short lived lol.

I kept altering my LED indicator lights but got too lazy and left them on default for a few days after flashing test 4.

Finally got tired of the not white light and changed then again today.