Project: Spectrum | Firmware v108 (and equivalent) is out!


Hi there community!

The wait is over! We have released the new firmware for ES07D03 (v.108) and the first update for both ES07DC9 and ES07D02 (both v.101).

Please head to the download page to get the new firmware package!

General tips for installing the firmware:

  • Please read and follow the instructions
  • Only install the firmware for your specific model. Make sure to double-check your model number before downloading and installing the update!
    – Spectrum ES07D02: QHD matte
    – Spectrum ES07D03: 4K matte
    – Spectrum ES07DC9: 4K glossy
  • Make sure that you have a stable power connection during the entire process
  • Always proceed with caution! Firmware updates are not mandatory. Consider updating only when you are having issues with your current monitor or if there are certain features you would like to use from the new firmware.

Change log for the QHD model

The QHD line-up only gets DDC volume control support and some bug fixes:

  • Added support for volume control by VCP command
  • Improved compatibility for FreeSync Premium Pro on AMD graphics cards
  • Resolved an issue where an image signal at non-native resolution could be distorted when disabling split-screen mode
  • Resolved issue where incorrect gamma or color temperature settings were applied in split-screen mode
  • Resolved issue where crosshair position was not stored in presets

Change log for the 4K models

The 4K line-up gets the same improvements, plus all the features and bug fixes that we had already introduced with the release of the QHD model:

  • Added per-port settings for the USB hub to use when switching automatically
  • Added a setting to disable display stream compression (DSC) or to emulate DisplayPort 1.2 over DisplayPort and USB Type-C
  • Added eight new colors for the crosshair (dark grey, medium grey, light grey, green, blue, cyan, magenta, and yellow)
  • Added ten new colors for the frame rate counter (black, dark grey, medium grey, light grey, white, green, blue, cyan, magenta, and yellow)
  • Added the ‘bottom center’ position for the OSD menu (this is now the default)
  • Added crosshair position setting to the OSD menu for easier adjustment, and improved the precision of crosshair adjustments
  • Added support for volume control by VCP command
  • Improved compatibility for 4K resolutions at 120Hz over DisplayPort on AMD RX400 and 500 series and NVIDIA 10-series graphics cards
  • Improved compatibility with PlayStation 5
  • Resolved an issue where adaptive sync would not be enabled when turning on the monitor
  • Resolved an issue where the Windows desktop wallpaper disappeared after resuming from standby mode for some users with multiple monitors
  • Resolved an issue where the monitor would enter standby mode when only the secondary video source was active in split-screen mode
  • Resolved issue where incorrect gamma or color temperature settings were applied in split-screen mode
  • Resolved an issue that incorrectly changed USB hub host device settings when the monitor received no display signal
  • Resolved an issue where the crosshair would jump to the center of the screen when at its highest or lowest setting
  • Resolved issue where crosshair position was not stored in presets
  • Resolved an issue where user-defined color temperature or indicator light color were not reset when loading factory defaults
  • Resolved an issue where the OSD menu would sometimes time out after 3 seconds regardless of the setting

We appreciate your patience with the development of the firmware and we thank everyone with their feedback on the beta testing! You guys are awesome!

If you have any comments, please leave them below :slight_smile:

DOUGH Subscribediscordtwitterfacebookinstagramyoutube


There are new gamma settings (2.1, 2.3, 2.5). This information should be added to the changelog.

1 Like

Flashed the bin, reboot, “Processing update”… blank image… nothing happens…


OK, remove DC, insert again, “Processing update”… blank image… nothing happens…

Waited… LED turns off, Spectrum is dead.

Now nothing happens, I have waited with the DC power removed, insert, press power button, etc… It appears that my Spectrum is dead :frowning:

I will leave it off and try again later.

Pressed power + D-button and LED turned white, waited, saw the triangular logo… waited but nothing happened. Removed DC, insert, LED is white, logo appears, left it there for 2-3min, suddenly turned darker and “Processing update” appeared.

Couple of minutes later, updated completed.

Running D03.V108

Hopefully this help anyone


Installed ES07D03 1.07 → 1.08 with no issues.
Using on an Macbook Pro M1 Max over USB-C, running 4k @ 144hz.

I was previously having an issue with websites that contained a lot of “black” EG: youtube on dark mode causing the whole monitor to flicker and turn off. Could reliably reproduce. This seems to be solved. If it happens again on 1.08 I will come back and edit this post, but so far so good.

Thanks for getting this released!


I should have know better than to try and install this update quickly.
Tried to Update, everything seemed to work fine, “processing update” appeared and disappeared and then the monitor just was on and the backlight was on but nothing happend. After 15 minutes I Powerd cycled again. Same as before until there was suddenly a flash on the Backlight and my Monitor turned off and won’t turn on again.

Update: So today the monitor turned on and I had to install 108 again and it works so far.
I also had to reset to Factory Defaults so that Brightness and colors were usable again.

1 Like

Going from 107 to 108 (ES07D03). Stuck on the light blue light for verifying update. Unplugging power for 10 seconds only gets me stuck in the same spot. This has been going on for almost an hour at this point.

Edit: Left it unplugged for a few minutes and the monitor breezed right through to the to the purple light!

Are you ever going to make it possible to operate the OSD without an active input source? starting to lose hope… :confused:


Hello! Longtime user of the ES07D03, first time poster. Hope I’m not screaming into an empty cave here.
I currently have an m1 max Macbook pro. Is it possible to update the firmware on my computer? If so, any guidance would be awesome! I’m still on v102 and would love to upgrade.

I have a windows machine that I used to install the update (even though I only use the screen on my m1 max). I don’t think its possible on any platform other than windows unfortunately.

Yes, I would like to see that implemented as well.

can anyone confirm this? I have no windows machine. Am I out of luck?

Install a virtual machine on your Mac.

1 Like

I’ll get right on applying that update. Right after I get the monitor I ordered in August 2020.


Installed on my matte spectrum. Not seen any regressions. Tested with M1 Macbook Air over USB-C, Playstation 5 launch unit, and Windows 11 PC with Nvidia RTX 3060.

Improved PS5 compatibility? I’m not seeing it. My spectrum has been working reliably with PS5 for ages, except for VRR mode, which is very hit or miss. Last of Us Part 1 (the remake ps5 only version) consistently has black video dropouts when VRR is enabled in “fidelity” graphics mode with unlocked framerate set to on. It’s totally unusable in that mode. It seems like another issue where when framerates drop too low Spectrum just goes black for a while.

The new Volume control over DDC is working very well with Lunar Display app on macOS Ventura over USB-C DP Alt Mode. Great quality of life improvement! :clap:

Seems like a solid update. I’m pretty happy. I’d love to see the VRR dropouts resolved, but it wouldn’t surprise me if the only solution that would work for this panel is frame doubling and that maybe something the scaler just isn’t capable of? Would like to hear from an engineer if that is the case? If so, happy to just accept this as one of those early product in a category kinds of bugs and live with it.

1 Like

This exact scenario is happening to me. Only my monitor is not coming on. Not sure what to try, but seems like it’s bricked.

I let the monitor sit for a few min with DC power still plugged in. Pressed power button, the white light was back, had a blank screen for about 15 seconds, logo came up for what seemed like a minute, now sitting at black screen with white light on…at least power is back for now. Going to let it sit here a bit.

After letting it sit with a blank screen and white light for 10min. Nothing changed. I unplugged DC, plugged back. A blank screen with white light appeard. Then next was the logo. After a few min, my secondary display went black (this was a good sign as this normally happens when my system detects the Spectrum for the first time). Processing update appears, then after a few min was able to finish. Unplugged DC again as instructed by the message. Screen turned on with white light, no logo blank screen. No signal showed briefly on the screen after 30 seconds, back to blank screen. Secondary display remains blank and in standby mode. using the D pad showed that the Monitor was only allowing selection between USB-B, and USB-C. Disconnect monitor from system. Now have option to select HDMI and Display Port. Selected HDMI, no signal.

The fix was removing my mouse from the side USB as I temporarily connected it there so I could use a USB-C to USB-B cable to connect to the USB input on my keyboard to perform the FW update.

The FW update to 107 was all rocky, but not as bad and scary as this one…

I’ve had a weird time when an update didn’t seem to go through. I think maybe what happens is the update fails to display the thing on screen saying it’s installing. Try just leaving it plugged in for about 20 minutes and then unplug for 10 secs and see if that fixes it. Mine came good after a couple of long power cycles like that, when it had the same sort of issue a few firmware updates ago.

1 Like

After the update, everything seems like it’s working as expected. Only now, while in HDR mode, the monitor backlight is noticably dimmer?

SDR still allows for the changing of the new Gamma settings of 2.0-2.6, as well as adjusting if Brightness/Contras back to my desired levels.

What has changed with the way the monitor handles HDR mode? I attempted the Windows HDR calibration to see if that would help. But the results seem overall dimmer compared to FW107?

Installed V108 today without any issuess :partying_face:

Factory reset fixes it

1 Like

On my unit, color reproduction has always been noticeably worse in HDR mode than in SDR, but it seems to have worsened with the upgrade from 106 to 108; reds seem even brighter than before.
Has anyone else noticed the same thing? Does Dough support have suggestions?