Project: Spectrum | ES07D03 V107-T117 Firmware Beta Testers needed

image

Greetings, community!

First of all, sincere thanks to everyone for helping us improve our firmware development process by submitting detailed issue reports and discussions. It has been a little over 2 months since the initial release of ES07D03’s Firmware V107 and as we established on our original topic, our firmware development continues.

Current firmware progress

Following the release of V107, our team has been busy discussing and preparing the next firmware update. With all the feedback provided by our community members, we are fully aware that our aim for the next update will include a plethora of bug fixes to make our monitor even more awesome.

While not all issues are addressed at this moment, please bear with us as we are working hard to make sure we have a positive firmware experience for everyone. We have made progress in fixing some of the issues and we are looking for beta testers to provide us with more data points and feedback to provide to our firmware team.

What issues are being addressed?

This stage of beta testing attempts to address the issues listed below:

  1. Monitor (ES07D03) displays “no signal” when the connected Mac device turns on or wakes up.
  2. Upon restarting the computer, FreeSync Premium Pro and NVIDIA G-SYNC Compatible are displayed as “not supported” in either AMD Adrenaline or NVIDIA Control Panel.
  3. Unable to reach 4K 120Hz with a device that has AMD 400/500 series or NVIDIA GTX 10xx series GPU.

How to become a firmware beta tester?

For those who own a Spectrum ES07D03 (Spectrum 4K matte) and are willing to become our beta testers, please drop a comment below or reach out to me (@systemofadead), Theo (@Cas), or Bobby (@Aethel) in order to obtain a copy of this test firmware.

Note! This test firmware is not applicable for the ES07DC9 (Spectrum 4K glossy) model.

When reaching out, please also include the below information for our reference:

  1. What issue you are currently experiencing.
  2. Your connected device with Spectrum (model name, CPU, and GPU).
    For example: Macbook Pro 15 (2018), Intel i7 8750H, Radeon Pro 555X
  3. Current monitor scaler firmware version and USB hub firmware version.

In addition, if you are experiencing severe issues that make your Spectrum frustrating to use, please reach out as well. Make sure that you document the details of the issue, and what happens before and after the update to the test firmware.

Attention!

Please understand that with test firmware we cannot guarantee the resolution of all issues. We DO NOT recommend installing test firmware on your Spectrum ES07D03 if it is your main and only monitor. We cannot provide compensation for any financial losses as a result of productivity loss caused by malfunction due to the test firmware.

Updating to test firmware does not lock you out from the stable version. If at any stage you would like to roll back to the stable firmware, you are more than welcome to do so!

Looking forward to hearing back from you guys soon!

DOUGH Subscribe

5 Likes

I want to test new FW.

I have problem with black screen after wake up or turn on/off monitor. Works only unplug and plug in power cable.

R9 5900X, Radeon RX5500. Display Port or HDMI.

All FW is lastest from site. Scaler and Hub.

3 Likes

You should have been added to a DM, please ensure you are using the ES07D03 and are aware of the risks :slight_smile:

1 Like

I was invited to be an early tester for this firmware, and have been running it for just over a week. Here’s what I’ve encountered while running this firmware.

Dough have already received this feedback, so this is for community interest.

Firmware upgrade process

I ran into significant issues trying to install this firmware version. Every other firmware update has just worked for me but this one required 3 attempts before it was successful.

The first 2 attempts failed while the Spectrum was in the “Processing Update…” stage. The message disappeared from screen before the LED turned magenta/purple, meaning the update failed. The Spectrum would boot to the grey triangle logo but wouldn’t display a picture signal and wouldn’t respond to the stick or power button. Re-flashing the beta or v107 did nothing and I needed to flash to an older firmware (v104 is what I chose) to get things working again.

In summary, my attempts were (roughly):

  1. v107 → beta (flash failure) → beta (no “processing” stage, no improvement) → v107 (no “processing” stage, no improvement) → v104
  2. v104 → beta (flash failure) → v104
  3. v104 → beta (success)

Dough are looking at improving the firmware flashing process in the future to make it more reliable.

MacBook Pro (2019, Intel, 15") - Intel UHD Graphics 630 + Radeon Pro 560X - USB-C

I can now use 4K @ 120Hz, although only with SDR. There isn’t enough display bandwidth to do HDR without DSC or 4:2:2 chroma subsampling. My hardware doesn’t support DSC, and macOS doesn’t provide an obvious way to turn on subsampling.

If you have HDR enabled before going to 120Hz, the display settings will continue to show the HDR checkbox but you will not be able to uncheck it. The Spectrum’s OSD will confirm that the picture signal is SDR rather than HDR.

Alienware 17 R3 (i7-6820HK) - GeForce RTX 2070 in eGPU enclosure - DP + USB-B

Prior to the v107 firmware, it was common for the G-Sync not to be detected when the laptop booted. I could fix this but using the Spectrum’s power button to turn if off and on again. With firmware v107 this workaround no longer helped, and I needed to disable and re-enable adaptive sync. This took a lot longer.

v107-T1117 returns things to the previous state where a power cycle allows G-Sync to be detected correctly. I’m happy with this, and believe that my particular setup means that G-Sync may never be detected properly on first boot.

7 Likes

I would like to test the new firmware, currently I got blacking on my gaming PC and on my mac it doesnt display a signal or wakes up
I’m currently using a 2019 Macbook Pro (intel i9 9880H, Radeon 5500M)
on my gaming PC its Ryzen 5950x, RTX 2080
Currently on the latest scaler and usb hub that’s provided on the site for the ES07D03

2 Likes

Hey @Artic_yuki :tada: Welcome to the community :tada:\

Please check your DMs to proceed further with testing :slight_smile:

2 Likes

After update freesync does not reset after power off/on. But still black screen and need to power off/on via power cable. Sleep mode and cold turn on - logo, when black screen.

1 Like

Thanks for the interest in testing. Please let us know how it goes for you after update :slight_smile:

Sorry, what do you mean by FreeSync does not reset? I take it that the update does not fix anything for you.

1 Like

If I turn off/on by button or wake up pc and monitor shows black screen, I plug/unplug power cable. After that monitor detect picture and working fine. But freesync became off. In amd panel it says + not supported display. I must reenable option adaptive sync in monitor.

On previous FW it was every black screen situation. With beta FW it was not always

1 Like

Hi there,

Thank you for elaborating. I will document the feedback.

Hi there,

I know that you have tried both HDMI and DP when still on 107.

Now I would like to investigate more about FreeSync Premium Pro function turning off by itself. Did you manage to try either connection, and see if you can reproduce it consistently? We had a report that using DP connection somehow resolves the issue for our previous tester.

Please let us know if that’s the case for you as well.

My main connection is DP. HDMI on 5500 series is 2.0. I can lower monitor refresh rate and try also HDMI connection on beta FW.

FreeSync always on in AMD Settings. If I push system to sleep and then wake up I recieve black screen. I unplug power cable, plug in back. Monitor start show a picture. I open AMD settings and find what FreeSync is not supported at this monitor.
Open OSD on monitor, turn off Adaptive Sync, turn on again. After this FreeSync in AMD Settings will on automaticaly. In games all is fine, freesync working after that.

Before Beta FW it was always.
Yesterday on Beta FW once, after black scren, FreeSync does not stop working and detect. It stays on in AMD Settings.

Also will try to connect to notebook with Ryzen 5 3000 mobile series and Vega iGPU.

Also I order new cables. May be my can’t correct working in 4k 144hz. But if I Iower to 60hz, black screen problem do not gone.

2 Likes

giphy

2 Likes

Hey @8BiTw0LF

You should have been added to the DM, can you also please list the following information for our reference :slight_smile:

2 Likes

I connect my monitor to a notebook. iGPU Vega8. Via HDMI. Disconnect from PC, DisplayPort. Try some options. Then connect DP port to PC also.

So. It’s trash. No any regularity.

  1. My notebook has 1920x1080 base monitor. HDMI 2.0.
  2. I set on Eve monitor compatibility mode. Turn off all performance options. On notebook Freesync can be enable and supported. On PC - not supported.
  3. Turn on Adaptive Sync on monitor. Now Freesync available and automatic on on both - notebook and PC

Without PC. Only notebook.
1920x1080. 60 Hz. HDMI.
Couple of times I close notebook, monitor goes to sleep. I open notebook and monitor wake up and show picture. No problem. But after some success attempts, monitor start wake up with black screen. And only power off/on by plug helps. And after so power on/off monitor randomly enable crosshair, loose freesync.

If I turn off monitor by power button, it’s 100% black screen. Monitor does not display - no signal. It’s in permanent black screen. I can unplug cables, back them, try select source ports, nothing helps.

And. I took old Dell notebook with Intel HD 520.
Everything is the same.

May be it’s not a FW, cable or source (PC, Notebook)?

1 Like

May be you can rewrite microcode and firmware for monitor from a scratch?
Or do it open source.
Because most of common problem it is black screen. Monitor can properly recieve signal from a source or adopt this signal.

I would love to test this… but I currently can’t :frowning: I moved back to uni and have had to leave my spectrum in storage. So I have no access to it. I’ll be down for future firmware tests but I can’t commit to it right now.

Hi there,

Open source unfortunately is not an option at the moment…

Crosshair is also enabled after on/off?

I just want to make sure, and maybe I missed this. But what is the source setting you have? Is it set to automatic?

Crosshair on/off it is rare situation.
Source - DP, not automatic. And then HDMI - HDMI.

Automatic mode don’t change anything.

During all day use I have no any other issue like blinking screen and e.t.c.

Also in UEFI bios or Linux boot menu from USB drive, all is fine.

1 Like

I’ve tested the new firmware for a couple of days.

Pros:
No artifacts when scrolling Twitter and other sites - nice.
Goes to standby when turning off PC/PS5 - nice.
Blanking issues are rare on PC - nice.

Cons:
Random blanking issue on PC happens once every day approx.
Still long blanking issues on PS5 - like on 107. Maybe a tat quicker, but still long compared to other monitors.

1 Like