Only 60 Hz expecting 144 Hz

Hi there,

Unpacked my ES07D03 today and hooked it up to my PC.
Windows 11 (Education), displayport, AMD Radeon RX480.

I’m only getting a max 60 Hz refresh option in Windows while I expected 144Hz.

Anybody got a tip / suggestion?



In that topic, they talk about having enough performance to deliver 144 FPS in games, not about if rx 480 has ports that can deliver 4K 144 hz.

1 Like

This might help you.
Fix 144hz Monitor Only Showing 60hz - YouTube

1 Like

Only shows 60 Hz there :frowning:


Refresh rate on rx 480 - Graphics Cards - Linus Tech Tips
Another person is having the same issue. DisplayPort was supposed to help go above 60 but it did nothing. I’m not an AMD guy so sadly I won’t be of much help. Sorry

144Hz at what resolution?

The RX480 supports DisplayPort 1.4, but without DSC (display stream compression). Without DSC, the best you can get is 4K @ 120Hz without HDR, or 4K @ 98Hz with HDR.

It should be possible to get 144Hz at either 1080p or 1440p resolutions.

Only the latest RDNA-based Radeons support DSC.


On my ancient GTX 970, I get locked in at 60 Hz via DP or HDMI if HDR is enabled. If I disable HDR, on HDMI I can get 120 Hz, DP still locked at 60 Hz. The GTX 970 specs specifically state that it will support 4K @ 60 Hz, and it’s DP (1.2) connection seems to verify that - however, for whatever (odd) reason, the HDMI (2.0b) connection seems capable of supporting 120 Hz even though the card is specifically rated at 60 Hz only - but only if I set it to use YCbCr420 (8bit) colors. If I go to RGB, it also reverts to 60 Hz.

Which RX 480 do you have (as in who make the actual card, AMD, or an AIB like MSI, ASUS, etc.? The full specs of the AMD RX 480 show it supports 4k HDR over a DP 1.4 connection but as NZGeek notes, we do not support DSC currently, so the ability to get 144 Hz with your card is limited, if it is even able to. It seems that card is much newer than my GTX 970, so it might be doable - but we need more information. Technically, my GTX 970 should never be able to do above 60 Hz, but obviously it can - because it’s not from nVidia, it’s made and sold by eVGA, just using the nVidia GPU. eVGA’s website says 4K @ 60 Hz full stop - yet I’m using it right now with 120 Hz.

1 Like

I don’t know anymore what brand my 480 is. I might pop open my pc to have a look.

Been trying to buy an new GPU for a while, but waiting for a bit more normal prices.

Today a DP 1.4 capable cable will arrive. I don’t know what my current cable is verified for so that might do the trick to up the Hz rate.


Tried posting a new thread for myself, but it looks like that’s not happening. I’m having this same exact problem with my Radeon VII. I didn’t expect 4k/144hz (no DSC on Vega/Polaris), but I’m not getting anything above 60Hz over 1080p. At 1080p, I can now set refresh to 120Hz, but that’s it. I wasn’t even getting that at first, but I have no idea if the firmware upgrade was responsible for that. I’ve tried new cables, different ports, all that sort of thing. 60Hz and no better, unless I run 1080p. Changing to 8bpc doesn’t help, changing to 4:2:2 doesn’t help. I’m kinda out of ideas.




If you look up your specs for your card it states 4K/60

Not exactly. Here’s something I just pulled from Techpowerup:

"Display connectivity options include three standard DisplayPort 1.4a and one HDMI 2.0b port. This is the same output configuration as on Vega 56 and Vega 64.

The HDMI port is version 2.0, and DisplayPort uses 1.4 HBR3, MST, and HDR. This enables support for 4K @ 120 Hz, 5K @ 60 Hz, or 8K @ 60 Hz. Supported HDR configurations are 4K60, 4K120, and 5K60, just like first-generation Vega. GPU-accelerated encoding is capable of HEVC/H.264 at up to 1080p240, 1440p120, and 2160p60. Hardware-based decoding works at up to 4K60 for H.264, H.265, and VP9 (shader-assisted)."

I wasn’t expecting 4k 144hz (though it’s technically possible), but 1440p60? That’s a big pill to swallow.

The one thing I see in this info that could be a problem is the bit depth. If you’re sending a 10-bit signal to the display, but only operating in the SDR (8-bit) colour space, that means you’re sending more data than is needed and that’ll impact the max refresh rate.

Check your Radeon settings to see if there’s a way to force the bit depth down to 8-bit. That should free up enough bandwidth to allow you to get 4K @ 120Hz.

Doing that on my RX570 only reduces Bandwidth from 8.4 Gbps x4 to 5.6 Gbps with no additional options for higher refresh rates

That’s odd. The available bandwidth should be enough to push a 4K @ 120Hz signal at least.

I suspect that there’s something very odd going on between the Spectrum and Radeon cards. There’s been a few threads I’ve seen where things aren’t working as they should.

I do know that Eve are working on some various Radeon-specific fixes, and there’s talk about a firmware update coming out no later than January. Hopefully that comes out and helps.

1 Like

I’ve pushed my bit depth down to 6bpc, color down to 4:2:2. No change.

Closing. Discussion to continue here.