No signal from Mac Pro via HDMI or USB-C

Finally received my Spectrum 4K today, and I’m having a lot of issues getting it to work with my Mac Pro desktop running an AMD Radeon RX 580 (8 GB) on Mac OS Monterey 12.0.1. The monitor itself works fine when connected to an Xbox via HDMI or a Windows PC via DisplayPort, so it doesn’t seem like a hardware issue.

This appears to be an issue with Mac OS Monterey. See update below.

I previously had three Dell 4K monitors running from the Mac Pro without issue using DisplayPort to MiniDisplayPort cables. I’m replacing one of the Dell monitors with the Eve Spectrum. Since my Windows PC is using the DisplayPort, that leaves me with the two HDMI ports or the USB-C port. None of them will generate a signal from my Mac Pro.

I have tried:

• Multiple HDMI cables. I even went out and bought two different 8K HDMI cables (from two different manufacturers). Strangely, the Displays System Preference DOES show the Spectrum plugged in—it shows up in Displays as an Extended Display that I can rearrange or change the settings to—but there is no picture on the monitor itself (I get the “No Signal” message).

• Tried the USB-C port. Used a video-capable USB-C cable from the top of the Mac Pro (bypassing the Radeon card) to (both) USB-C ports on the Spectrum (I know the USB-C port on the bottom of the monitor is the one for video), but I tried both just to make sure.

• Tried restarting both the Mac and the monitor multiple times.

• Tried changing the resolution and refresh rate in Mac Display properties multiple times.

• Tried turning off HDR in Mac Display properties for the Spectrum.

• Updated the Spectrum firmware from 102 to 104.

• Tried both manually selecting HDMI inputs using the joystick and using Auto Select.

• Tried both HDMI ports on the Spectrum.

• Tried changing HDMI mode (on both ports) to “Compatibility” mode instead of HDMI 2.1.

Nothing is working. Anything else I can try?

One update: the Spectrum will display a signal from the Mac if I use a DisplayPort to DisplayPort cable, so it’s not a problem with the Mac. Still no luck using any HDMI or USB-C cable.

Update #2: I have an older MacBook Pro (2016 era, with a built-in full-size HDMI port) that was still running Big Sur. I used one of the new 8K HDMI cables and plugged that into the Spectrum. Worked like a charm.

As a test, I then upgraded that MacBook Pro to Monterey and… no HDMI signal! As soon as the upgrade finished, I restarted the Mac and Spectrum, tried unplugging/replugging the HDMI cable, and could no longer get a signal from the Mac.

As with my main Mac Pro system, the Spectrum does appear in the Display System Preference as a device that can be repositioned virtually, and the mouse cursor “disappears” when moved to where that monitor should be (as an Extended Display), but there is no picture on the monitor itself. The Mac(s) think the monitor is there, but nothing is displayed on the screen (No Signal message on screen).

To me this points pretty clearly at an issue with Mac OS Monterey and the Eve Spectrum monitor.

Hi @thinksinc,

Please check out the 2 topics below regarding the signal via USB-C after firmware 104. We’ve received similar reports from our customers, so I hope both topics help you out.

If the issue persists, please DM me your support ticket and we will get the Team to look into this for you.

Thanks @MarvyMarvz. These threads appear to be more about USB-C connections. While that connection isn’t working for me on Mac either, I’m primarily interested in the HDMI connections working, which don’t appear to be addressed in those threads but perhaps is a related issue. Since I’m trying to use HDMI cables, buying an Apple Thunderbolt 3 or USB-C to DP 1.4 cable won’t address what I’m experiencing.

I did submit a Help Desk message but have not received a Ticket # or a response yet from the team.

One more data point to add: I used the same 8K HDMI cable to connect from the Spectrum to my Windows 11 PC (w/ RTX 3090) and it worked as expected: getting 4K @ 120hz. So definitely Mac OS Monterey-related.

1 Like

Two new pieces of data:

• I just upgraded to Mac OS Monterey 12.1, which was just released. It did not address the issue. HDMI-to-HDMI cables still do not work connected to the Spectrum.

• I also just tried an 8K DisplayPort 1.4 to HDMI 2.1 cable, and it did work. I’ll have to consider this a solution for now until Eve can issue a firmware update so that regular HDMI cables will work with Monterey. Any updates on this, @MarvyMarvz?

Thanks,
Robert

2 Likes

Hi @thinksinc,

Apologies for the late response.

I have notified the firmware team of this issue and I’ll let you know of their findings, once I get a response.

Apologies once again but I’m glad to see you have it working with DP to HDMI.

Thanks, I’ll look forward to hearing what they have to say.

-Robert

Eve Support ended up shipping me a replacement monitor which I received a few days back. It exhibits the same behavior, which tells me this is either a firmware issue or a hardware defect inherent in the system. I’d have to guess it’s firmware related specifically to Mac OS Monterey. @MarvyMarvz any news from the firmware team?

1 Like

Hi @thinksinc,

The more I read into your issue the more interesting this becomes.

I believe all your Spectrum is working fine, I think the issue lies with your Macbook / the settings you are using with it.

Are you able to DM me pictures of your settings for Display and your OSD Settings on the Spectrum.

They are as interested as I am but they also think it’s a macOS issue.

Have you upgraded to v105 yet?

I’m trying not to be disrespectful here but there are tons of issues with the Spectrum and macOS. I don’t know how many support tickets and screenshots I sent. I never received any answer from support. They wanted to forward my issues and screenshots to the firmware team. Did it happen? No idea. 105 hasn’t fixed any of the macOS issues.

I’m having the feeling that the firmware team never tested the monitor with any Mac. USB-C connection with most Macs (especially the M1, M1 Pro and M1 Max versions) is not working, neither is HDMI.

The only connection that seems to work is DP to USB-C. That sucks, since it doesn’t provide power or enables clamshell mode.

1 Like

I would question this. I’m using my Spectrum with an Intel-based MBP right now, using a USB-C cable. It’s working just fine, albeit limited to 60Hz. There’s also been several reports of people working fine with USB-C to DP cables, and a handful of people getting 144Hz working with a USB-C cable on M1 Macs.

Given that some people without Macs are having connection issues, I almost have to wonder if there are bad batches of circuit boards (or components on boards) that are causing issues, but only with certain types of video feed.

1 Like