No image on new display

I got my new Spectrum 4k about three weeks ago. My PC detects it as a monitor and the backlight comes on, but there is no image on screen. The display occasionally flickers as if changing display modes, but everything is black. I can’t bring up any kind of OSD.

I have tried DisplayPort and HDMI, have tested with another PC, and have updated the firmware for both the USB hub and the scaler, power cycling many times afterward as suggested in the FAQ. None of it seems to make a difference.

Is there anything further to try here, or is my unit just bad? I filled out the contact form on the main web site the day after I set it up, but I haven’t heard back.

This is something that has been occurring since launch. I’m using mine with a PS5 but this happens no matter what you are connecting to it or what type of connection and it seems firmware 108 has only made it worse. Often I’ll start my PS5 up and turn on my monitor and the screen will stay black or sometimes show the eve symbol and then go black. I have to un-plug the power cord from the back of the monitor, wait 5-10 seconds and then plug it back in which usually fixes it. A big thing that gets to me is that you can’t just turn it off and then back on again. If you turn the monitor off, pressing the power button won’t turn the screen back on. I used to wait 5 to 10 minutes but lately I’ve been getting frustrated and have been pressing the power button like 10-20 times and then waiting and it will turn on after a couple minutes.

The only thing I can think of that might help, is to make sure you don’t have auto detect source in your saved preset.

I don’t, even though that would be nice if that worked how it was supposed to. I turn it on at the same time as my PS5 and it just stays blank and black, not even the eve logo. Then after several minutes it goes into standby mode where I have to turn it off and then back on, after waiting like 5 minutes before the monitor will accept the pressing of the power button to turn back on.

I always turn the monitor on before booting up my PC or Xbox Series X, and it works as intended 90% of the time. I use HDMI connection on both and auto detect.

I do the same. I’ve actually tried several times turning monitor on first, PS5 on first and both at the same time and I got the same results. I use HDMI and I’ve tried auto detect and just the HDMI with my PS5 connected. I’ve found better results from just using the connection port instead of auto connect. I think I found the problem; even though my user preset settings are set on using HDMI 2, the monitor settings didn’t change and remained on auto connect. I’ve set the monitor settings for HDMI 2 and it seems to be working 100% though I need to test it more. I will also see if setting both on auto connect is also working as intended.

Auto connect is surely more prone to problems.

I’ve got the exact same problem here. The backlight and indicator light turn on, but the panel never comes up. Haven’t gotten a reply to support tickets in 6 months unfortunately.
If you get anywhere with it, even if that’s getting an RMA, that would be great to know.