Nintendo Switch not working with Spectrum

I haven’t seen similar post here yet, so I am hoping to get some help.

My Spectrum arrived today, I connected it right away to my windows laptop so I could use it for work, straight from the box. No problems at all, USB-C → DP cable worked fine.

After work I decided to try other devices I have at home and the only not working so far is my Nintendo Switch (first model, HAC-001) :frowning:

List of the things I checked before creating this post:

  1. Switch works with the previous monitor I used (even though it didn’t have HDMI, I used DVI - HDMI adapter)
  2. Switch works with the other two HDMI displays I own (Phillips TV and Dell monitor)
  3. Spectrum HDMI ports 1/2 behaviour is the same, 2.0 compatibility turned on doesn’t make a difference
  4. I used the same cable - one provided with Switch - across all devices - Spectrum is the only where it doesn’t work
  5. I also used the same cable to connect other devices to Spectrum - PS4 Pro and my Windows laptop - and they worked!

It’s not like I didn’t get anything displayed on Spectrum from Switch, one time I saw the wake up menu from Switch, but once I tried to unlock it - signal was gone. After that it seems like it is in some loop, looking for signal and not being to display anything.

Any help will be appreciated, thank you!

EDIT: forgot to mention, I checked 102 and 104 firmwares


Thanks for the report. Let me do some research to see if other Spectrum owners have mentioned the Switch and ability (or lack thereof) to get a signal.



Just a heads up. I’ve recently bought a switch and have found I’m experiencing the same issue.

Looking forward to hearing what others have to say on this.


Same thing happened. Was working fine at first then after undocking and redocking switch it’s stuck on a no signal loop. Tried a solution I found online where I disconnect everything from the switch and reconnect in a certain order. It worked once but then after undocking a redocking again, hasn’t worked since.

1 Like

Everyone in this thread - what resolution does the Switch output to HDMI, is it 1080p, or something else?

According to the official technical specs, “up to 1080p”:

Up to 1080p via HDMI in TV mode

1 Like

Tom told me in discord that the menu for Switch is 720, but didn’t specify about the other part of the resolution. Which, if it is 720 * 400, then we’ve got confirmation that that resolution is still not in the EDID yet, as you pointed out.

I just got done with a long meeting with the fw team, and they are going to review the EDID and the changelog.

Right now I’m playing The Legend of Zelda: Breath of the Wild on Spectrum for the first time. Works flawlessly. I have it connected to HDMI 2.


1 Like

Hi, is there an update on this issue?

I just purchased the new Nintendo Switch OLED, and I have the same issue with it not displaying on the Eve Spectrum monitor.

Using HDMI.


1 Like

@zetronimus while OP reports that switching to compatibility mode for your HDMI connection did not work but users on reddit report positive results getting the Switch to work on HD TVs toggling HDMI mode on the TV. For some older devices (I know the Switch isn’t old) you can get the HDMI connection working by plugging the switch in, then setting the HDMI mode to compatibility, then switching back to 2.1.

If you give it a try and it still isn’t working let me know. In the mean time I’ll keep digging for a solution and I’ll ping @nkyadav to see if he has any more info.


I am also still experiencing issues with my Nintendo Switches on my Eve Spectrum. Every time I hook it up either through an hdmi splitter like I do for my PS5, Series X & Apple TV (which all work) or directly through either hdmi ports on the Spectrum it’s just a black screen. It turns on like it’s trying to display something but then says no signal. I’ve tried it with my launch Switch dock & my new Switch OLED dock & both hdmi cables. The same docks/cables work on my tv just fine so it’s definitely the Spectrum. Please help. Thank you.

Hello @TheGameV30, I moved you reply to keep this conversation together.

The best advice I can give is to try HDMI compatibility mode or to toggle HDMI compatibility mode on and then off again. Let me know if that works and if not we can try find a solution for you.

Hello! Sounds good. I was able to update the monitor to 105 and that seemed to help it. Wish there was an easier way of updating the monitor though. Otherwise, it’s all working right now! Thanks!


What exactly did help? Updating firmware to v105 (what was your previous firmware version then?) or toggling HDMI compatibility mode in the monitor menu/OSD?


I believe it was the firmware update that helped it. It was previously whatever it came with upon arrival. However, as I was having trouble updating to 105, I first updated to 104 and still had the same issues. I don’t think I did anything with the compatibility mode. Main thing I think I did in the OSD was to enable the usb hub in order to do the firmware update. But yea, I think firmware 105 seemed to help me (I tried a bunch of different things haha sorry)


Good news. I’ll try updating the firmware to 105 this weekend and will report back with results.


Hi everyone!

Took me long time, but I finally managed to get some time and gear to test properly the issue I reported in the beginning of this thread.
Turns out, there is something wrong with my Switch dock/cable combo, on the other screens I own I started to notice some artifacts, that were gone only with certain TV output settings on Switch.
To confirm that it’s the dock/cable causing problems I borrowed another set (dock and cable) from friend, almost new, and it works fine with Spectrum. I also upgraded the FW to 106 right after it was announced on the newsletter, so I thought this would be a good time to juggle with cables again.

I am they guy who preferes to find the answers in the forum threads with help, so here it is: Spectrum is fine, there might be something wrong with your dock.


Wow, thanks for the update, Marcin!

Did you have to do anything special, in terms of settings on either the Switch or else on the Spectrum, to make it work? The replacement that you borrowed, is it the same items as the one you have or a different item?

Also, which firmware are you running on Spectrum, because that could also be a factor on why other people’s Switch devices are not working - we’d like to be able to tell them to try the same firmware you’re running and see if it makes a difference before we just tell them “Your dock may be bad” lol. I think that would not go over well, in some instances.

I’m running 106 update, I switched HDMI to compatibility mode just in case but it also worked with 2.1 mode. As far as I know - both docks are identical, same model.