New Eve LB owner - can't install Windows cumulative update - stuck in failed mode

Dear Eve, almost perfect unboxing experience. However, Everytime I try to install the update called: “• 2017-12 Cumulative Update for Windows 10 Version 1709 for x64-based Systems (KB4054517)” it fails after issuing the restart. I just get back to the Windows Update view indicating it failed and to try again. Anyone else have this problem and have a fix? I’m just getting back onto Windows from OSX so I figure this is part of the experience. :wink:

A little bit of googling got me the following:
Please run Windows Update troubleshooter from Control Panel > Troubleshooting > View all.

There’s a lot of tips and possible solutions, including a case where the update is actually already succesfully installed but not recognised. Hope this helps:


Sorry to hear, that you’re having problems with Windows Update.
It probably doesn’t help, but you’re not alone with this problem.

FYI: The latest Windows version should be 1709 OS Build 16299.192 after the latest batch on the 3rd of January 2018.

Check if your Windows version 1709 OS Build is 16299.125 (the above webpage incorrectly identifies version as 16299.15 as per original Microsoft webpage - it’s changed since).

press windows key + R to open the Run command
type winver into the window
press ENTER


If you are at OS Build 16299.125, then the fault unfortunately is somewhere else. But at least this one is ticked off the list.

Microsoft is working on a resolution and will provide an update in an upcoming release.

Have you managed to get past the reoccurring Windows Update?


Just a bit further info:


The latest batch to OS version 16299.192 may not always install due to Antivirus not supporting it. Windows Defender and all other major Antivirus providers have a fix on their software to allow the update to install.


Running the troubleshooter appears to attempt to help; but then alas, does not fix it. Basically, any windows “premium” experience will always be defeated by Windows itself. So, any Early Beta recipients (EB) like me will likely stumble on this giant out of sync update issue and it’ll reflect poorly on the vendor. Yeah, I know, its Windows, and with enough hours I can get this worked out; but this is the kind of experience only one gets with Windows.

So, I’m still stuck not putting anything on my V until I can get it up to date with Windows.

1 Like

Basically, windows is telling me its database is corrupted: “Potential Windows Update Database error detected” This is my “out of the box” experience sadly. @Konstantinos has to know even though I’m smart enough to know its not Eve’s fault, its at the root of my initial experience with the V and I can’t say anything nice yet.

Fwiw I’d also submit a support ticket to Eve - even if there nothing right now they can do to fix it , they are looping back with Microsoft engineers and your diagnosis / report may help them in their troubleshooting

Sure, I get there’s nothing they can do to fix it. however, they did have months and months and months to update their images while we all waited. Basically, this is one of those “loose ends” they left that’s giving a poor out of the box experience just like the need for new drivers to catch things they have plenty of time to catch but decided to use their HEB and Early Beta recipients to catch was it seemed was obvious. Somehow the attention to detail which is so present in the packaging just didn’t apply to the software experience.


I just submitted a ticket. It’s clear that Windows is still not ready to compete with OSX no matter how pretty a machine its sitting on. Too bad as I like their new CEO and what they are doing with Azure.

Thanks for this; however, there’s nothing on my V except what came with it in the box yet. I’ve even disabled Microsoft’s own antivirus/anti-malware to try to solve this, uninstalled manually some security patches, etc, no go. This whole experience reminds me of what they did when they rolled out the anti-ransomware folder locking support this fall, and then it blocked even their own apps from running normally. At least they could have provided some rules/signatures to keep their own apps working. Really poor UX from Microsoft still. I’m trying not to hate MS; but really, their user community has been trained to have low expectations, IMHO.

First, please try to reset the Windows Updates components.

Or try the steps in this - by the way, do you get error code 0x800f081f?:

Or you could repair the Windows installation:

If repairing doesn’t help, then best way is to start with a fresh Windows install.

Please note that you need to reinstall all drivers too. Most of them come with your downloaded Windows installation package, but some you may have reinstall manually.

And don’t forget about the Calman calibration files.

Unfortunately i don’t have a first hand experience with this problem, but I hope that something from above helps you.


Thanks for this. I’ve even tried following downloading the update manually only to be told it doesn’t apply to my computer. I’ve double checked my selection and it matches the hardware I have. Perhaps the only solution left is to re image the device. A beta experience for sure.

it will be interesting to see what is the root cause of this - is it a hardware driver that’s corrupt or not playing nicely - cause the image that was loaded was a pretty clean build from microsoft - so keep us updated on what happens!

This also occurred on the prototype unit I received last month. Running “DISM.exe /Online /Cleanup-image /Restorehealth”, then “sfc /scannow” in an elevated command prompt resolved the issue, and allowed the update to install correctly.

This is the link I used: Use the System File Checker tool to repair missing or corrupted system files

1 Like

Thanks, trying this now.

@keithhubb : Thanks for those tips. However, it didn’t work. Now when I look at my update history, I see a bunch of “pending” updates all requiring a restart. However, I’m many restarts later. It would seem that windows update is in a failed state and my only option is to reset windows. As I’ve not put anything on here yet, just trying to get this thing into a known good state, this shouldn’t be a problem. I read elsewhere that the color profile settings should be in bios so I don’t need to harvest them, so here it goes.

Maintaining the same Windows installation keeps the calibration intact.

So, just reinstall the Windows again from the start and you should be golden.
Hopefully it works (it really should) :crossed_fingers:

Hmm, I wonder what happened. Definitely sounds like corruption of some type. Have you run a checkdisk just to see if the storage is okay? I have seen bad SSD’s in the past. There should an application available to check the SSD state, but you may have to download it from the manufacturer.

@jlorance There is also this link at MS about the recovery options available for Windows 10. I thought I would throw it out there in case anyone needed it. Windows 10 Recovery Options

Yup, I know about the recovery options and I’ll be executing them when I get home from work. I just think it’s ridiculous to get a brand new device and Windows get stuck in a Windows update failure mode so badly you have to do this (I’ve tried everything else). Definitely, doesn’t build confidence. I’m a very technical user (software engineering by trade), so I can’t imagine what the average person is doing messing around with Windows. I can fix it obviously, just a headache that comes free with your new Windows PC it seems.