My monitor cannot sleep in a certain circumstance

I found that as long as I turn on g-sync in nvidia control panel, my monitor won’t go to sleep when I make my pc sleep. I need to press the power button to trun off and then turn on again, then the monitor can enter sleep mode. This issue disappears when I turn off g-sync.

I’m using the 4k model and connecting with a 3090 using HDMI port. I did graphics driver clean install, tried several drivers and update the firmware, but this issue is always there. Is there any way to fix this?

Hey @garfield0018

I will let the team know of this. So once G-sync is turned off the monitor enters sleep mode with no problem? Only when G-Sync is on does the issue occur?

Right, only when g-sync is on, the monitor won’t go to sleep when I let my pc sleep.

Hi there,

Just wanted to make sure, that you said that you have the 4K model, the ES07D03 (Spectrum 4K matte), right?

Which firmware versions have you tried? and has this been a consistent experience for you since the beginning?

Hey @garfield0018

The team is going to be testing this and trying to see if the issue lies with G-Sync, this could very well be caused by a driver issue from Nvidia’s side because they do not test HDMI in their certification process.

Thank you though for finding this out and will update you when I have more information :slight_smile:

What does your Nvidia control panel settings look like?
I recommend having it set up like this (enabled for fullscreen and window mode):
image

If your settings are the same, open an administrator command prompt (type CMD in windows menu and right click, run as administrator), then type in “powercfg/energy” without the quotation marks.

After the diagnosis finishes, it will take 60secs, open a windows file browser and type in C:\WINDOWS\system32\battery-report.html to access your energy report. Read through the errors highligted in red, if you see anything like this:
image
Then it means you need to change your windows power settings.

Hope this helps

2 Likes

Thank you for your reply.
My nvidia control panel is the same as you show. And I do disable display timeout and pc auto sleep. But the thing is, When I just turn off g-sync, the monitor can sleep in seconds after the pc enters sleep mode, even though I still keep disabling display timeout and pc auto sleep. And I am using FW ver.107.