Monitor unable to wake from sleep sometimes

My monitor appears to have more than just the intermittent black screen issue, its also sometimes unable to wake from sleep…

What I do is, use windows + L to lock my screen, then have the monitor turn off by itself via auto-sleep.

However when waking, sometimes the monitor just stays on but black (can see dim backlight). Sometimes there is a No Signal message, other times there is just nothing.

There appears to be way way too many problems with the firmware… I thought the monitor would be roughly equivalent to the LG 27GP950 since it uses the same panel, but I didn’t think the firmware would be this bad.


Is the power button responsive when your Spectrum gets into this state?

I’ve noted this in another thread, but mine has done something similar when I’ve let it go to sleep overnight. When it wakes back up, the LED will come on but the screen will stay completely black. The power button is unresponsive too, and I have to disconnect power for a few seconds to get the Spectrum to come back up.

I’ve only noticed this on the 104 firmware and never had any issues on 102R875.

1 Like

I had the same problem: after I got the new Eve DP cables, I have experienced this only once. I consider the problem to be solved for me:
I am on latest nvidia driver, firmware 104 and new DP cables.

I don’t think the cable is necessarily the fix here. I’m having the issue when hooked up to a MacBook Pro with Radeon graphics, using a 40Gbps USB-C cable.

The fact that the power button stops responding and it only started after the 104 update indicates that this is a firmware issue, and it appears to be somewhat random.


This has also happened for me with the original 101 firmware (black screen after waking from sleep - i have 2 monitors and my mouse cursor appeared and moved on my 2nd monitor while the Spectrum primary monitor was still black).

I did somehow manage to get the monitor to wake up - i think by logging in to Windows, which appeared to trip something and cause the monitor to wake up.

Yeah its random for me. Sometimes the power button is unresponsive, sometimes the power button works and things fix itself after turning it off/on.

I’m having the same issue with MacOS. Latest Big Sur, latest 104 Eve firmware. Once the MacBooks goes into sleep or I lock it manually it’s 90% the monitor doesn’t wake up (MacBook still gets charged via USB-C, though) and 10% the monitor wakes up. It’s super frustrating because it seems it’s a monitor/firmware issue.

The main fix is to unplug the Eve power cord and plug it back in. That cannot be the solution.

BTW, now I’m trying to use my Xbox Series X and the monitor doesn’t get a signal even though it worked fine over the last couple of days. Not even the unplugging power and plugging it back in helps. Oh man, oh man.


Yeah the firmware seems to be the big issue, started having bsod crashes in my newly built system AFTER installing the firmware for this monitor. Every time I turn on the PC it takes ages for the screen to capture a signal, then sometimes on reboot or booting to bios I can’t even get the screen to display a signal. I’m currently running a mem test on my ram to see if my brand new ram needs replacing since installing this firmware I’m encountering bsod stop codes that seem to point out memory as being the issue.

Have you tried reverting back to the old firmware? I’m wondering if that will help the monitor pick up the signal immediately and not drop to black screen for a few seconds before displaying an image, it’s very annoying

You can’t revert back fully once you upgraded to 104. 104 is the new “baseline”, where future firmwares can always revert down to 104, but not lower.

Hello everyone.

I’m seeing a similar issue while connected to my PC wherein I Windows Key + L and allow them to sleep. But when I come back the system would be frozen. Literally a dead stick.

I haven’t tried this ‘power cycle’ (as the firmware doc calls it) but I guess I can. I thought it might be due to some recent Windows 10 updates that I had installed around the time I actually set the monitor up but alas, even after uninstalling those (with testing in between) the problem persists.

I think I had seen this pop up once before updating to 104 but it happened frequently after the firmware update. I’ve disconnected it to run a few tests to see if I can replicate the error state and I’m sad to say that I have not seen this issue since removing the Spectrum from the equation. I’ve posted additional info, firmware related, here

I will now add the updates I previously removed ( KB5006738 and KB5006365 respectively) to see if the problem returns. I suspect it will not but it should be part of the test.

My system specs:

i9-9900k (stock speed)
Gigabyte Aorus Master f11n
32GB 3400Mhz G.Skill
RTX 2080 472.39 Studio Driver

Nothing else worthy of mention.

UPDATE: It occurs to me that the DP cable I’m using is rated 4K@60Hz so I’ll replace that first. I’ve got a new certified cable arriving at some point tomorrow so I’ll provide my observations after that’s in place.

Next time this happens, try pulling the power cable out of the Spectrum for a few seconds then plug it back in.

You should be able to reach under the front of your Spectrum to find where the power cable plugs in. You should be able to pull it down just a few mm, until the Spectrum’s status LED goes out. Then count to 5 and push it back into place.

Hopefully the system will show as responsive once the display comes back on.

1 Like

Hi NZ,

Thanks for your reply here and the linked thread.

I planned on trying this today. I have some other work to do and once I have the brushed off the sheetrock dust from my person I’ll give that a go.

While I wait for my replacement DP cable (although, I think the one I have is sufficiently rated after I’ve looked at things a little more in depth), other things on the list are:

  1. Power cycle monitor while in error state
  2. REMOVE password on wake.
  3. SWAP to alternate port on GPU - Same Issue Observed.
  4. TEST USB-C to DP 1.4 from GPU (since I don’t have a long enough USB-C cable for input)

I can confirm that the system is stable after installing both MS patches so it’s definitely pointing to the monitor.

I also have a ticket open with support but I’ve not seen anything other than the automated reply.


Pulling the power on the monitor after the error state is observed is a non-starter. No success. Power cycle required

Cables received image


So far so good. The cables are actually pretty darn nice. $16 on AMZN. The certification checks out on the VESA site and links back to JCE. Noice! The system was still alive this morning so I’m happy thus far. But I’m knocking on wood at the moment just in case. Albeit the screensaver was still active. Need to investigate that a little further.

So it looks like the power management for Win10 was pushed back to the default ‘Performance’ settings thus the screens never turned off over the course of the evening so I’ve set the value back to Display Sleep so it occurs after the screensaver kicks in.

Sigh… and then in the time it took for me to take my dog for a walk, the system became unresponsive after display wake.

@Lore_Wonder I do not see any display power management settings in the OSD. Is there something I’m missing?

Meanwhile, I will revert the display sleep setting in the power management to see how it fairs for the day. This monitor is really starting to piss me off.

Anyone still experiencing this issue? Its really annoying that I have to hard reset my pc because I cant get a signal to my monitor after It goes to sleep, even after I Windows+L if I dont come back fast enough to get it out of sleep mode, I will get constant no signal on the screen until I hard restart my PC. I only use hdmi 2.1 and only have one slot so I cant switch the hdmi to another port. They need a firmware update ASAP. Ive waited over a year from pre-order and its a beautiful monitor but I cant recommend it in its current state.


The short answer is: Yes.

The longer short answer is: Yes and No.

Once I disabled the monitor sleep feature entirely, via Power Management and related screen saver panels, I was able to work around the wake faults. I simply power off the monitors at night. I am certain if I were to enable ‘Put monitors to sleep’ the issue would return.

I’m waiting on additional feedback in the thread linked above. Hopefully they’ll have something identified soon.

Same problems. Sometimes when playing 1080p games and switching back to 4k the specturm will go dark and never come back. Need to powercycle than. Also my Windows froze sometimes when trying to wake up from sleep. No Errorcodes so far. Hope this will be fixed…

I’ve recently found some success with the following changes:

  • Ensure you’re using an actual certified cable whether it be HDMI or DP.
  • Updated NVDA drivers to newest Game Ready (497.09 currently).
  • Disable G-Sync on all monitors.

Regarding that last item, I had it enabled only on the Spectrum but I disabled altogether and that seems to have resolved the issue for now.

And towards the driver version, I was previously using the Studio driver and did not see this blanking with G-Sync enabled. Maybe they will migrate whatever changes they implemented in the GR release over next month but who knows.

It’s actually keeping my charts in place from monitor sleep as well. I was experiencing the same thing you were with the freezing on monitor wake pretty consistently, even after the 104 update but I worked around it by just turning off the monitors and expecting that it wouldn’t keep my application position if anything was active on the Spectrum.

I’ve been documenting these observations in the Screen Blanking after firmware 104 thread.

I suspect if I were to actually game on the monitor I would see similar results.


I’ve encountered the same issue, I posted about it a few days ago, but it seems like an uncommon issue, and no reply from the EVE staff. I get same blank screen and unable to get it to display anything, from any input, only thing that works is a power cycle. It happens at POST, when the PC goes to sleep, or when the monitor does.

Firmware ver. 104 and latest GeForce drivers.

Also, it seems that the monitor OSD turns yellow with corrupted text whenever this issue happens.

Thanks for sharing the Windows + L trick, will give it a try.

1 Like

I have same problem.
I have 2 Spectrums. 1 works OK, the other one gets this error more or less everyday(only had them for 4 days). Both was delivered with firmware 102. The one that has this problem, didnt show any picture when connected to windows before it was updated to 104.
Windows 11
Radeon 6900XT with driver 12.1
I’m using EVE displayport cables.

Sorry to hear man.
Seems like the exact same issue I’m having … Is the issue limited to DP only, or all inputs affected?

I tried Firmware and gfx card drivers updates, which to no surprise…did nothing. Seems like an chipset issue/faulty something, since one your monitors working fine.

I’ll be sending mine soon.