Monitor seems bugged with motion blur issues

Im not sure if im still eligible for a return or not, but my monitor has started to do something strange. After playing a game at a high refresh rate (i can also get this bug if i mess with settings long enough), the monitors motion goes all buggy. So instead of 144hz motion I get something like 60-80 hz motion and the display is impossible to look at until i hard reset it or toggle different refresh rates. The frame rate is set to 144 hz when this happens and i see the FR counter at 144 hz and the display menu also says it at 144 hz, but the motion is clearly not 144 hz. I realize this may be hard to imagine, so ill probably try to get a picture of it if i can in the coming weeks. Who do i speak with to ask for a return? A warranty repair may also be in order here. Who do i contact for that?

Hi there!

Few things I like to clarify before we move forward:

  • Which firmware version do you have? Also, which device do you have? ES07D03 or ES07DC9?
  • Have you tried running a software with frame rate counter (aside from the monitor feature) and see if it actually shows a different numbers? Usually, the frame rate counter is pretty accurate, so if there is a difference between what is shown and what is actually being displayed, it might be a hardware issue (and I am sure we can both recognize 60hz vs anything higher!)
  • For the case of return or warranty, you will want to reach out directly to our support team. But let’s also try to figure it out here together! There might be something that we can do to fix it.

Maybe it’s Dynamic Refresh Rate?

Hey there,

Wow this is actually the first time I heard about this haha. Having read this, @SteveZee68, is the bug happening while you are gaming, or only after you quit?

Sorry i didnt reply sooner. Ive sent a help ticket in to support at the moment, but it probably wouldnt hurt repeating things here. Here is basically a copy of the email so i dont have to repeat it. I can only upload 2 videos at a time. The first one is 360p for some reason, google probably compressed it. Both are just video files i took with my phone. It may be hard to tell from the first one but the motion in the first one is far better than the second one. You can see how much overshoot the second one has behind the UFOs. And the image is blurrier. Hard to see with a camera, but its there.

Email:" Ok i was able to get videos of this issue. Ive uploaded 6 videos to my google drive so you should be able to see them. 1 of them may have to be downloaded as its not verifying. Let me know if there is an issue viewing them since I realize you may reside outside the US. The “normal operation” video shows a quick clean motion and the “Issue” video shows the motion problem. The others are slowed down a bit to try and contrast the differences. Im using an MSI NVIDIA 3080 GFX card. The problem happens randomly when i change refresh/resolution settings, or load/quit a game either immediately or after playing for a while. This time it happened when i disabled Gsync via the GFX driver. It also happens quite often when im running a game at a lower than native resolution and/or refresh rate. Ill quit the game and the motion will be very strange on the desktop. Its very uncomfortable to use when it happens.

Video files:

Normal Operation: NormalOperation.mp4 - Google Drive

Current Issue: Issue.mp4 - Google Drive -Motion is heavily blurred and overshoot is present behind the UFO. Motion isn’t normal.

Forgive the car sounds outside as my window is wide open. Turn your volume down or mute the sound if you need to. Both videos are 4k and were taken by my phone they will clearly show the clean motion in the first video and then youll notice the “off motion” in the second video. I have the FPS counter turned on and its in the upper right corner. Note the FPS in both videos when using “UFO ghosting” is 144 hz. The picture kind of undulates, is far more blurry and has massive trails behind it even though the monitor says its at 144 hz and its listed that way by windows and in the monitors main menu. Both say 4k @ 144 hz. In the slowed videos the UFOs vibrate back and forth and are the image is totally unstable.

If the video isn’t clear enough i can recapture it holding the camera closer.

The rest of the information you asked for:

Model: ES07D03/07DC9

Serial Number: EVE222100034

Firmware Version: 100

Issue Description: Random motion instability after changing resolution, refresh rate or enabling/disabling VRR through the driver, upon immediately loading and/or quitting a game (happens a lot in L4D2). The 144 hz motion basically stops working and the motion looks far more likes its 60 hz with massive overshoot trails and bad blurring, or it just looks wrong and unstable. It looks very bad and feels uncomfortable to use until i fix it. Resetting it via VRR toggling, gsync toggling via the driver, or simply toggling resolutions/refresh rates from the desktop seems to fix it. Sometimes a PC reboot fixes it too. Its all fine until it randomly happens again once the resolution or refresh rate changes, or I load a game.

Picture/Video: Linked above

Input source: Happens on both HDMI and DP inputs.

Device Model Name: Eve spectrum 4k ES07D03/07DC9 Glossy MODEL

PC: Custom Desktop PC. Phanteks case/MSI x570 Unify Motherboard/5800x3d CPU/1000 watt seasonic PSU/3733 Gskill DDR4 RAM/MSI 3080 suprim 12 GB model

Operating system: Windows 10 home 64 bit

Graphics card driver version: 516.94

Screen Resolution and Refresh Rate: 3840x2160 @ 144 hz

How to recreate the issue: For me its random, but im able to usually, at some point recreate the issue by changing the resolution (in a video game), refresh rate (in a video game), or toggling Gsync in the driver, or adaptive sync via the monitor."

1 Like

Im using windows 10 64 bit.

1 Like

It likely happens either when im loading in or during game play. The frame rate somehow becomes unstable and the monitors freesync functionality bugs, so when i quit the fault has all ready happened. I know several times Left 4 dead 2 causes it almost instantly when the FPS drops initially to 24 FPS (opening intro) and then goes up to 144 hz. Eventually it happens during gameplay with warzone and i usually dont notice it until after i quit, but mostly i quit because i realize something is happening that shouldnt be in game and then notice it afterwards. Not sure what hardware is faulting here, but its connected to adaptive sync i think.

The total number of videos is 6 of them, but i cannot post more than 2 per comment, so ill give you 2 more just to contrast what ive currently posted.

The first one is what normal motion looks like. Its easy to see the clear motion as i follow the UFOs across the screen. Its at 120 hz because i forgot to set it at 144 hz first, but it still shows what normal motion should look like. normal120hzslowed.mp4 - Google Drive

The second one is another glitch that occurs slightly different from the first one. The motion inconsistency is strange. This time the UFOs are twitching back and forth very quickly. The motion as i see it is not 144 hz when it happens. It looks far blurrier and the UFO is very garbled and looks a lot like crosstalk with MBR enabled when i dont actually have it enabled.

Issueclip2slowed.mp4 - Google Drive

Let me know if u cant see either. I live in the US and its possible you wont be able to view them.

1 Like

Ill prob do a better video again of the “normal operation”. 360p is terrible to look at. But you can easily see the 120 hz “clear motion” operation and compare that to both issue1 and issue2 i posted.

1 Like

Some more direct answers to your questions.

Firmware says 100 and the model i have is the ES07D03 glossy panel.

Software says 144 hz no matter what i have running. The GFX card is outputting frame properly. My FI32U does not have this problem and runs fine. Its only monitor that currently does this. I also have a 6800 xt and the fault happens on that card too.

Im pretty sure this is a monitor hardware issue (internal fault) at this point. Unless im wrong, which is why im posting here to get anyone else thoughts. I also thought maybe the cable is at fault here and will probably try to find another cable in the coming weeks. Currently i use a Club3D CAC-1372 Ultra Speed HDMI cable and while ive used many of their cables in the past, without issue, this one could be a problem.

I have an email going with Shadib and eve support agent, so im hoping something turns up there.

Ive been told that my firmware cant be updated further from 100 aswell. Not sure what i can do at this point. The monitor is pretty unusable for me now. I can try to turn off freesync, but thats a feature i need to have active else theres no point to using it.

Hi there,

I will need a bit more time to process all the posts. But just real quick…

I want to let you know that when it comes to firmware version of Spectrum 4K glossy ( otherwise known as ES07DC9), there is only version 100.

This version 100 is version 107 equivalent to the matte version. There is no way to update for the time being, as the firmware you have is the most recent (with 107 being the most recent version for ES07D03)

I’ll get back to you as soon as I get more feedback, but for now I do agree with you that it’s a hardware issue.

OK thanks. I appreciate your help.

Hi there,

Another possibility is a VRR bug.

I understand your point. But please do it anyways so we can figure it out better; whether it is hardware or software.

We do receive a lot of feedback where having VRR function makes things very unstable and disabling it fixes the issues.So I would like to know as well if that’s the case for you as well.

I will try that in the next few days and see what happens. The issue seems to persist far more on the HDMI port than the DP, but i have had it happen on both.

Well this didnt take long. I plugged it in. Set VRR to off and tried messing around with the backlight strobing feature a bit. I loaded up L4D2 and instantly noticed something was off. I quit then loaded UFO ghosting w/ the same issue (blurry ghosting with 60 hz overshoot trail behind it). The screen also looks like its flickering a bit too. All says 144hz as far as i can tell, so i went back to try to enable VRR again and the option is completely greyed out. I probably would have to reset the monitor so something is very wrong with this thing.

Here is a pic of the greyed out settings.


Also i have a few more pics to show you. It seems normal motion and abnormal motion on this monitor also show up differently on camera. I consistently took pictures with and without the motion issue and they look very different.

Normal movement:

I believe this is a normal stroboscopic effect at 144hz.

Abnormal movement:

Very different at different parts of the screen. It shouldnt look like this.

This thing is all messed up. I cannot use it w/ HDMI VRR on off.


The motion in this video is beyond wacked out.

Ok I disabled Adaptive sync in both the driver and the monitor. It seems to be working much better now. Im going to try and test it out for a day or two and see if the issue comes back. If i enable gsync via the driver, but disable VRR in the monitor the issue happens quickly. If i disable it in the driver it seems better. I tell you how the testing goes.

1 Like

NOPE its still happening with both the driver and VRR disabled. Im gonna try switching cables next.

Also my SHARPENING settings keep reverting back to a lower value whenever i mess w/ monitor settings. I constantly have to keep toggling them up and down to set them properly. Ive posted about this elsewhere aswell.

Still happening with anther HDMI cable but worked better with VRR disabled. Gonna try DP cable next. Im probably going to request an RMA for this thing in the next few days.