Monitor not getting signal when trying to update PC BIOS

I had a bit of a frustrating experience yesterday with my monitor and my desktop PC yesterday.

The monitor is connected to an eVGA RTX 3080 FTW3 gpu via HDMI (4k ultra certified from monoprice) and the motherboard is an MSI x570 MEG Ace w/ 4 x 8GB 3600MHz DDR4. Anyway, the PC booted into the BIOS fine. For the MSI boards, when you select the BIOS flashing option, it’ll reboot the computer and load up the flashing utility. I could not, for the life of me, get the display to get a signal when going that particular screen. I could see the monitor briefly show grey flashes like it was trying to load an image but it would fail.

I turned off VRR, Response Time options in the monitor, hard power cycled the monitor, changed HDMI cables, tried a DP → HDMI (8k Ultra) cable - nothing. Finally, I dragged my old LG 4k monitor into the room and it too had trouble connecting w/ the same HDMI cable. However, finally, the picture came with a random DP / DP cable I had. Full disclosure, I did not try that cable w/ the Spectrum. So I was finally able to update the BIOS and then I switch back to the Spectrum.

All said and done - the two things that are troubling me the most:

1 - the grey flashing where it seems like the monitor is trying / failing to do something.
2 - why is the monitor not ‘connecting’ with whatever source it is, and then only for that particular scenario. I see this behavior with my work laptop too (randomly).

I’m on firmware v107. If anyone has any insights on why this happened, would appreciate it.

Hi @PrazVT,

There is another topic worth checking. It may be the same thing, since it has some similarities with your case.

I wished you tried the other DP cable!

@Cas I will check it out. Also, it’s happening right now so I may need to try the DP cable.

Video of what HDMI was doing. DP isn’t working at all for Windows or BIOS. But let me check out the thread.

Hey @PrazVT

Was that link to the topic @Cas linked able to provide help to this situation? Flashing the BIOS on the GPU to support DP 1.4 natively?

Also, does this happen on previous firmware?

@Aethel, that seemed to apply to older nVidia cards. The 30 series doesn’t need those updates. So it didn’t really apply. I did try a DP cable and also tried changing the HDMI mode to compatibility. For whatever reason, the monitor would get a signal with the DP cable. Changing the HDMI mode helped me get into the BIOS once, but on trying to repeat to test, it didn’t work.

I would say I was more frequently able to get into the BIOS on older FW versions (ex. 104). The frustrating thing is it’s so random when the monitor decides it can’t get a signal (or whatever the issue is).

1 Like

Okay so in general this issue has been existent since 104, though recent firmware it has been more frequent?

Let me get the FW team to look at this and see about providing a further solution!

  • Is this windows 10 or 11?
1 Like

Yeah that sounds accurate. In general, the screen won’t display anything until the Windows login screen shows up. So I’m usually just tapping Del button hoping the BIOS will show up. I’m on Windows 11 Pro x64. Once it’s in Windows, there aren’t any issues. But in general, the inability to detect the signal at boot consistently is an issue.

Thank you!!

1 Like

Hey @PrazVT

I believe this to be the same issue as another recent topic if you could try the following from this post:

1 Like

Will check it out - thanks!

1 Like

Okay. So if I turn off HDMI VRR and Low Latency, I’m able to get into the BIOS by blindly hitting Del. But there’s no boot screen visible. If I select the BIOS flashing option, the system reboots to flashing mode and then the screen flashes like in the video above. But no image. If ctrl-alt-del to reboot, I get no image at all. No ability to get back into the main BIOS or into Windows. I have to shut the machine down with the power button, shut the monitor off and then power both back on. This time, after the manual shutdown, it came up with a memory OC error and let me into the BIOS (sometimes, the memory speed resets to non-XMP after a hard shutdown). I re-enabled XMP and after exiting the BIOS, this time it showed the MSI “MEG” logo and then the windows loading animation.

So not sure that helped completely.

Aside from the memory speed resetting to 2100MHz from 3600MHz from time to time, the system is very stable.


Hmm, well glad to hear you were able to get into the bios somewhat. Though I will pass on this information to our firmware team and see about getting more information on this for you!

1 Like

Hey @PrazVT

Can you also try making sure your input is selected as HDMI or DP (which ever one you are using) instead of select automatically? Select automatically seems to take longer in getting a signal which could be the reason you are having to blindly enter BIOS.

I typically have the inputs set manually already.