Monitor frequently disconnect (black screen) then reconnect

Ooooh I just discover that my cable is only a 1.2 DP, I will try with the USB C cable only on my macbook pro (

Ahh, yes that is probably going to be the root of your problems, make sure the cable is a certified DP8K DisplayPort cable. Let us know if the problem still persists!

Hi so I updated my monitor to firmware 1.06 today and I’m having exactly the same problems. I’m going to try versions 1.05 and 1.04. I’m really hoping for a fix here as my PS5 is only playable with PS4 settings. (No high refresh rate or HDR).

So now I’ve updated to version 1.05 and I cannot even see my PS5 screen. All cables are connected properly and when I turn my PS5 on, the monitor will light up and then go back to “no signal”. Now I am at the definition of unplayable. I cannot even see my screen, let alone use it at lower refresh rates. This is a terrible experience considering the cost of the monitor.

Hi there,

When you were on V106 or V107, have you tried running the monitor without the VRR enabled on the PS5?

Yes on both versions I tried on and off. Now I’m on 1.05 but I can no longer update the firmware as the “no signal” screen is all i see. I cannot adjust the USB Hub without signal.

I highly recommend checking if your HDMI cable is VESA certified for HDMI 2.1 if you are experiencing issues particularly in the 120hz range

I’ve never had any issues whatsoever up until I upgraded to version 1.04 several months ago. That’s when the problems started and i have not changed any cables on the monitor or the PS5. I have not changed locations either. Same outlet location, same desk, same room. The only changing variable here is the firmware updates I started doing on the monitor and that is when my problems started. 120 Hz ran silky smooth with every game that supported it up until the first firmware update I did on the monitor. My PS5 is completely up to date and functioning properly. But now I’m at the point where I can’t even use the monitor. As I’ve explained, it sits in the “no signal” screen and occasionally flickers (picking up a signal from the PS5) but stays on a black screen, then goes back to “no signal” after a few seconds. I’ve tried unplugging the monitor from the power cord and waiting on different occasions for all different amounts of time. 30 second, 2 minutes, 15 minutes, even an hour. Every time I plug it back in and try, back to the “no signal” and flickering issue. With that being said, i can’t even update it to a different firmware as I cannot adjust the USB Hub settings as you need a signal to access it. Right now I have a $900 monitor only a year old sitting on my desk, completely useless. Unless I can somehow fix this, I’m ready to move on to a different monitor.

I left the power cord unplugged all night and day throughout work as well, came home and plugged it in hoping it would work. That got the monitor to start flickering on my PS5 home page and I had enough time to change the USB Hub setting to sneak a firmware update from 1.05 to 1.04. The update went through just fine, as soon as I saw my PS5 screen pop up, I ran through the settings to turn VRR off on the PS5. So now I have a screen back. I selected a game to play from the PS5 home screen and my monitor went completely black and I had to shut down my PS5 as the monitor was unresponsive. Now I’m back to the “no signal” flickering issue where I can’t even see my PS5.

Hey @Robfitti

Since 104-107 have had no impact in solving this issue for you if you are able to do what you did before and this time just return back to v107.

When the spectrum is connected to your PC everything works as normal? This is only when the PS5 is connected to spectrum that you are getting no signal? What color is the LED at the bottom of the monitor? Also, are you able to provide links to the cables you are using for spectrum for us to look at?

Just trying to rule some things out to assist better!

Thanks for the reply I really appreciate the effort here! So it seems as though I’ve narrowed the problem down to 120Hz mode being the problem for the monitor on the PS5. I don’t have a PC or anything else that i connect the monitor to, just my PS5 is used for this monitor. While the black screen is happening the light on the bottom of the monitor is a light blue color. The problem with the black screen was non stop with occasionally being able to see my home screen through the flickering. Through that, i was able to turn off 120Hz setting on the PS5 and now the monitor worked well for about 2.5 hours and I’m back to the flickering problem as we speak. As far as the cables go, the HDMI cable I’m using came from the PS5 box. The cable itself reads: High Speed HDMI Cable E321011 AWM 20276 30V VW-1 LUXSHARE-ICT. Just to reiterate, I’m currently on version 1.04 and after a couple hours of game time I’m back to the black screen issue with “no signal” then the screen picks up a signal but I cannot see it, it just stays black then goes back to “no signal”.

Additionally, I can hear my PS5 power up through my headset. Through muscle memory, I can navigate the home screen menu and try pressing different buttons just to see if the monitor responds but it does not.

How do you go about updating your firmware? Currently our firmware can only be installed through windows.

Also, are you able to try a “Certified Ultra High speed HDMI 2.1” usually delivers up to 48Gbps.

I use a Microsoft surface pro with windows 10 to update the firmware. According to the PC and the monitor reacting, the updates go smoothly. I haven’t had an issue with installing the updates but the aftermath of the updates have been frustrating. I could try different cables I don’t have them handy, though. I would have to buy them. Did you guys notice something wrong with the cables I’m currently using?

Hard to verify as looking up that cable does not says if it is 2.1, the data transfer rate, as well as just saying High speed. If possible I would recommend it.

If the issue is narrowed down to 120hz mode, it could be the cable.

Though if the Indicator light is still light blue the update might not be completely finished.

1 Like

In the monitor settings it says that my cable is “2,1 HDMI” not sure if that’s a good verification of the cable but additionally, I’ve played games and videos at 4k resolution and also at 120Hz. I don’t believe they were simultaneous but that would make sense to me that the cable ‘should’ be okay. Also I do notice with the light blue color on the bottom of the monitor when the “blacking out” issue happens, it seems to go from light blue to a very slightly normal blue, then back to light blue. If the issue is that the firmware didn’t fully install, how would I go about fixing that?

You would need to power cycle by unplugging the monitor DC power connector, let’s just wait 5 minutes then plug in the power connector. Do not unplug the usb cable.

So connecting to you surface pro there is no issue?

I only connect with the surface pro for updates, no screen usage. All I do is plug in a USB A cable to my surface pro and connect that to the monitor with a USB C cable to perform the update. I’ve never tried “getting signal” with any other device than the PS5. I’ve also tried the power cycle dozens of times for all different time stamps even up to a full day once. For the power cycle I unplug the power cord going directly into the monitor and wait for all types of intervals of time. Should I also unplug from the outlet? Not sure if that makes a difference but I’m willing to try anything at this point!

1 Like

Alright, are you able to recreate what you did to flash 104 to go back to 107? If 104-107 are not making a difference than being on 107 will help in the long run. From there we can follow the photo I provided earlier as well as the instructions provided with the scaler firmware to ensure that it is installed successfully.

I can try to upgrade to 1.07 again. The problem is I had the screen blacking issue the last time I tried but I will try again. Once on 1.07, what should I do from there?