MBP M1 Max via TB4/USB-C No Longer Working

Continuing the discussion from Spectrum ES07D03 | FW v106 and USB Hub FW Updates:

Setup details:
MacBook Pro (2021) M1 Max connected via USB-C with Thunderbolt 4 cable.
Custom-built gaming computer connected via 8k VESA approved DisplayPort

Updated the USB hub firmware via USB-C cable (changed USB-hub setting to USB Type-C w/ High Data Speed) and updated the firmware as well.

After updating my Eve Spectrum I am no longer able to receive display via my MacBook Pro (currently running macOS Monterey 12.3). I am able to update and reflash via USB-C so it’s confirmed that the USB-C port does still work.

I’m honestly unsure where to move from this point forward. The MacBook does show signal when connected via HDMI, but is failing to pick up/send signal via a known-working TB4 cable.

This is especially concerning considering I have another Eve Spectrum 4K that has been ordered. I’d like to get this resolved asap. This is starting to feel a bit like a clunky product which is a shame because I’ve shilled this product a lot and starting to doubt the product itself.


I’m not sure I’ll be much help but two things:

I’m a Mac only user but haven’t had a chance to flash it yet but I’ll update my comment to see my experience. I’ve seen a few other Mac reports (Intel and M1) on the 105 thread that had issues with USB C as well after flashing, maybe it’s not unique to you.

MacOS 12.3 had issues with 3rd party displays documented on Apple Forums (in preparation for the Studio Display). 12.3 is definitely much worse than previous versions compatibility wise, 12.3.1 just launched and you can try updating at a chance that Apple fixed any issues. I recommend updating and hoping that alone would fix it. See this article that shows solutions for some. It might just be 12.3 that happened to not work with 106. But below does document fixes and issues

1 Like

Oh wow, thanks for sharing this.

I completely missed this. I’m on the Apple Developer Beta Program but am not seeing 12.3.1, I’m still on 12.3.

It does look like other users are having the same exact experience that I am – HDMI working and USB-C not working (see below)

However, it looks like people are solving this by dropping DisplayPort version down from 1.4 to 1.2 or 1.1. However, I’m not seeing anywhere that I can set the DisplayPort version any lower or at any version at all within the OSD.

Any pointers there?

1 Like

Sorry it’s out of my expertise on how you would adjust DP on the spectrum. Especially since I’ve always been plug and play.

The good news is, 12.3.1 specifically references this 3rd party display fix in the patch notes so it may not be needed. The update went live a few hours ago. I’m updating to it now.

Great to hear that you’ve got the update. Must be a slow rollout for the update releases. Hopefully, that resolves the issue. If you connect via USB-C can you confirm post-update that the Spectrum works for you when connected via USB-C?

The Spectrum has that feature planned, and has it working on the engineering sample I have for the 280 Hz QHD (ES07D02) that I’m testing fw for also. That is to be backported to the 4K models when the fw dev team has a chance - but if 12.3.1 fixes the issue, that will be a sigh of relief from me, because I do not know when the fw dev team will have time to backport this to the 4K.

Coincidentally, MBPs that were upgraded to Monterey from Big Sur last year also had issues with Spectrums, and 12.1 seemed to fix that. So, I’m hoping that this 12.3.1 update does so as well for you.

See my post here for a sneak peek of it in action on the QHD model. Spectrum | The Future Of Firmware - #204

1 Like

Hey just wanted to say I am having the same issue with eye MBP 2021 with M1 Pro. Downgraded to v105 and then tried v106 again after (though this time the firmware wouldn’t load). But same issue would receive power delivery to my MBP and other display ports would work but no other ports. Strangely when connected via USB C the MacBook could still access the attached devices to the USB C hub

1 Like

I’m having the same issue - USB-C input no longer works for me with my two MacBooks - an older Intel one and a newer M1 Air.

Rolling back to 104 or 105 doesn’t help - I assume USB firmware is at fault here.

While this is being investigated and fixed, can we please get a way to roll back USB firmware to known stable version?


1 Like

Had to switch to DisplayPort, which luckily still works both with my MacBooks and my Windows machine, however, using USB-C as USB hub source is also now broken - when video in is set to DP.

It’s still charging the laptop via the cable, but no devices are visible.

Please, give me at least a way to roll back this USB firmware so I can use the monitor properly again. I can live with other faults, but this is pushing me closer to asking for a refund.

1 Like

Are you running MacOS Monterey 12.3 on both of these?

If so, try going into System Preferences → Software Update and see if the 12.3.1 update is available for you. It is for me, and it’s supposed to fix issues with USB-C displays (at least on Mac Mini). This fix may also help in your situation.

1 Like

Tried on 12.3 and 12.3.1 and not working still. Also tried on v105 and v106. Def think it is the usb patch not working.

1 Like

If we can get a way to roll back the usb hub that would be ideal.

1 Like

12.3 was not an issue for me prior to USB firmware upgrade. Regardless, updating MacOS to 12.3.1 did not help.

1 Like

It seems I’ve been lucky here. Even with firmware 106 and the USB update, everything is working fine.

My MBP is from late 2019, 15" display, Intel i9, Radeon Pro 560X. I’m doing 4K HDR @ 60Hz over a 40Gbps USB 3.x/Thunderbolt 3 cable.

The 12.3.1 update doesn’t appear to have helped anything, but it hasn’t hurt anything either.


RE: roll back:

I’m trying my best tt get a roll back for the USB - but please, remember, this is not a firmware that our fw dev team put out. This is a fw update directly from the manufacturer of the chipsets controlling the USB hub and USB PD modules, and as such, is a completely closed solution - IOW, we’ve not had one before, and it may take some time before they get it back out to us (certainly not 9 months, which is how long we’ve been waiting on an update (since manufacturing), but…longer than a couple of days for sure).

If I find a work around that might be used, I’ll let you know.

1 Like

Thank you, I understand. I’m ready to wait, within reason, since I can still use the monitor - just with a lot more hassle when switching between machines.

Would it be possible, going forward, to provide rollback versions of usb firmware when releasing new ones? Being able to roll back from 105 to 104 solved an important 1440p/120Hz issue for me, for example, and knowing that I can roll back to a known stable version makes me more confident at trying out new updates.


Hi @aleksey,

Thank you for your understanding.
Of course, this will be something that we consider for future releases.


Hey, all,

After last night’s meeting with hte fw dev team, and explaining what was going on, they’ve agreed to provide us with a rollback for the USB Hub fw.

I received that USB firmware rollback earlier today and am testing it now, I plan to have it posted no later than tomorrow for folks to try. I just have to finish testing it and then I’ll post it in the original 106 topic and make it linkable for everyone to get easy access to.

USB Hub roll back section is now at the end of the first post of the fw v106 / USB fw topic.

Direct link: Spectrum ES07D03 | FW v106 and USB Hub FW Updates

(some browsers may take you to a particular post in the topic instead of the OP - if that happens to you, scroll up to the OP).

Note: Please read and follow the instructions carefully. Take your time - this is not a 40 yard dash, you don’t get points for doing it in 3 minutes versus 10.

1 Like

Duplicating in this thread as well: can confirm that rolling back to this version fixed the issue for me for both my Intel and M1 MacBooks. Cheers.