MacOS No Signal

Any chance 108 will allow me to use my monitor with my macbook again? At this point a buggy experience would be far better than this permanent “no signal”.

Hi there,

Can you please be more specific.

Are you referring to the report you made?

Nope, that is bios on my windows machine. macos doesn’t work at all ever, except sometimes for a few seconds right after boot. I saw someone else with the macos issue so I didn’t rereport.

But I have two m1 macbook pros and neither work with either of my 4k v107 spectrum monitors. They both work with other monitors. It’s finicky but i can get them both to work with the same usbc to a phone. I assumed it was just a well known thing that v107 doesn’t work with macos.

Hi there,

I dont think it is 107 specifically. While there are some reports about Mac compatibility, not everyone has it, which makes it a really odd case. Is this something that happened while where you were on 105/106?

Have you updated the USB firmware at all? There are 2 versions available on the downloads page, and the older version (0A.89.17.02) mentions compatibility fixes for Macs. The newer version (0A.89.19.02) also mentions fixes for M1 Macs waking from sleep.

I tried both usb updates, neither works with 107. 105 and 106 worked, but of course had their own issues, like randomly disconnecting. This is consistent across both monitors using these versions, tested with multiple laptops.

That’s odd. Double check your inputs on the monitor OSD. And make sure the cable is connected fully. I’ve had some instances where I’ve had to cycle the inputs a couple of times before it shows up, but then it works all the time every time.

Still seeing monitor “blanks”. Especially when using the USB-C input. Recently switched to a DP - USB-C cable and not seeing it as much now, but it still happens. Very frustrating.

I realize you’re trying to be helpful but I’ve tried the whole matrix of multiple computers, multiple eve monitors, non-eve monitors, operating systems, and cable brands. I have the right cables, they’re plugged in, and I’ve tried every osd option 20 times. 0A.89.19.02 + 107 does not work with macos on multiple devices and monitors and I can’t be the only one. I’ve been buying monitors for 20 years and I’ve never had these issues, ever. I’ve had these two eve monitors for a year now and every single firmware update has been problems on problems, for the priciest monitors I’ve ever purchased. This firmware needs to be fixed, and besides slow delivery it’s the entirety of this forum.

again, “does not work with macos” here means 90+% of the time when a macos device is plugged in the monitor says “no signal” for a few seconds then turns off

I’ve had mine for approximately the same duration and I have pretty much the same experience with regards to issues, so many issues. At this point I wouldn’t recommend anyone intending to use them with a Mac to buy one.

I know you said you had the right cables, but does that mean usb-c to usb-c ones or usb-c to displayport? I’ve had both and the former are much flakier.

At least my two monitors work well with my Mac :crossed_fingers: I suppose I’m lucky in that regard.

I’ve tried both, though the latter not since 105. Couldn’t tell a difference.

Hi I actually have a MacBook Pro 14" with an M1 Pro chip in it. I use my ES07D09 (glossy) and get a black screen / blank screen at least a few times a day. In fact it just happened while typing this comment… I use the USB-C Thunderbolt 4 cable from my Mac to the USB-C Thunderbolt 4 display port on the monitor. Then, I use the other USB-C port on the monitor for connecting a little USB hub with an Ethernet port, and a couple USB-A ports. What am I missing? I’m running Firmware 100.

It is likely, non public version with this issue solved did exist at one point, and probably will be released at some point. Some of the way older versions also work well.

Hey @matthew-levan I would like to clarify, currently v100 is the only firmware for the glossy version so you wont be able to download previous firmware versions.

Can you try turning of adaptive sync and see if that helps with the blanking?