MacOS Firmware updater

Any news on a firmware update utility for Mac? I am finding this monitor less and less usable for daily life. There are too many issues for me and I can’t even try a newer firmware build because there is no Mac update utility.
I have tried running Windows 11 on Parallels on my M1 Mac just to try and update the firmware.
In the process of doing so, since changing switching the USB Hub to On / USB Type-C hub mode in the OSD settings, i can no longer even get a video signal to the mac over USB-C and there is no sign of the USB hub device in MacOS either.
I have tried several factory resets of the display, and it works with other video inputs.

I am really close to just giving up on this monitor and getting one that isn’t a headache to use every day. :frowning:

Hey @Ben_Marshall, lets see if we can’t get this resolved for you.

If I understand your setup you have your Mac connected USB Type-C to USB Type-C or thunderbolt to the Spectrum into the downward facing usb-c port on the spectrum. Did this configuration work before you updated the firmware? When you say tried running windows 11 to update the firmware - was the firmware update successful? What firmware version are you currently running?

Do you have any other cables you can try to eliminate the cable? And you say the other inputs work - do you mean the other inputs work with your Mac or the other inputs work with other devices?

Do you still have access to the Windows 11 laptop from your work and could you use it to reattempt the firmware update or rollback?

I know it sounds silly and unnecessary but - after you change the USB Hub settings on the Spectrum does unplugging the usb-c cable and re-plugging it in again do anything? Others have reported that simply unplugging the thunderbolt cable from their Mac corrects some problems.

Finally when you do a factory settings reset do you see that the process was a success and the settings are back to the factory values?

1 Like

Hi Taalyn,

Thanks for getting back to me on this.
Yes initially i was using the M1 Mac plugged into USB-C downward facing port on the spectrum for a few months without much issue after initial setup trial and error. Before Windows 11 in Parallels even comes into the equation, i was unable to see the USB hub device in MacOS at all, and now I cant even see the display device for spectrum when connected via either USB-C port in either USB mode 2.0/3.1 with USB Hub switched off or on in OSD.

I have tried several other cables, USB-C and type B. The display will work over HDMI or DP but other devices at my workstation use these inputs so i need Mac on USB-C display input.

Windows 11 laptop from work isnt an option for firmware updater as I dont have admin rights on it.

I have tried re-connecting cables etc. Can’t get MacOS to see the display anymore at all or the USB Hub device.

And yes factory settings appears to work.

I never had the USB Hub switched to on previously and I was also using USB 2.0 /144hz bandwidth priority to get the spectrum usable with the Mac, but even those settings no longer work for some reason.

I’ll give it another go today and see what i can get to work, but i really need to get the firmware updated to something more usable as the Spectrum really really struggles frequently switching between 3 devices throughout the day. And Spectrum not being able to go into a true standby mode means i lose my window position in Windows every time i switch the input back to it, if it doesnt cause Windows to crash entirely which happens several times a day at this rate.

So I’ve connected the monitor type B port to the Mac and now i Can see ‘USB Billboard Device’ is seen, this happened briefly over uSB-C before i lost all connectvitiy on USB-C.

However i suspect that Windows doesnt recognise it in this state/incorrect driver is being used. Is there a specific driver that i can install to make this work?

What you are experiencing is definitely not ideal with multiple problems happening with multiple devices. Can I assume that the problems occur when each device is connected alone - the problem with the Mac is still present when only the Mac is connected?

It’s definitely worth opening a support ticket and If you have a ticket already send me the ticket number via DM.

There also seems to be two separate and possibly unrelated standby mode issues. One where the Spectrum won’t go into standby and one where the Spectrum won’t wake up from standby. When the Spectrum won’t enter standby for you does the backlight stay on? If you manually power off the Spectrum and then power it back on do you have the same issues with the Spectrum not entering standby mode?

And can you also check the current firmware version from the OSD as well.

Hi Taalyn,

I have Mac in USB-C, PS5 in HDMI1 & Windows Laptop in DP connected at all times.

Basically what happens is this:

  1. I am using Windows laptop for work etc. Have Spectrum and a 1080p LG display both with windows snapped into specific positions. Laptop lid always closed.
  2. At lunch I switch display input to PS5 for an hour or so.
  3. After lunch I want to switch back to Windows laptop, laptop itself has gone into sleep/standby so needs to be unlocked. (I use the second display as primary because it always wakes up when required and i can log back in unless it crashes.)
  4. When switching input back to DP on Spectrum, its as if the device disconnects and reconnects to Windows 1 or more times. At which point 1 of 3 behaviours occurs:

A. Spectrum displays DP input but window position has been reset (10% of the time at best)
B. Spectrum displays DP input ‘no signal’ (Most common, requires laptop restart to fix)
C. Spectrum displays DP input after several refreshes and then causes Windows laptop to crash.

I need to be switching between the 3 inputs regularly throughout the day so I don’t think Spectrum is really stable enough yet for my use case unfortunately. I can’t see the fixes im looking for in the lists of items in the 104 or 105 firmware updates either so I think I will be forced to replace the Spectrum for now. Such a shame as I have quite enjoyed being part of this community. If this was an open-source project i think i would be more inclined to wait for or help with fixes. But it seems relatively locked down which is a shame.

1 Like

Hi @Ben_Marshall,

You’ve probably done this already but have you tried a clean download for your macOS?

Sometimes you can lose features when you update, in your case, video signal via USB-C.

Can you get signal via USB-C Port on your work laptop?

1 Like

There is hope - one other bug dealing with displays was that the user inputs could be programmed for a specific video signal input and would report (at the top of the OSD) that the input has been changed, but the video signal would continue to pull from the previous input.

This has now been fixed in our tests builds and will be in the next release, v106 - and if the fw dev team could fix this, then I have hope that they can fix your issue (which several others have also had) about the device not recognizing signals from Macs / consoles when the devices are in standby / sleep / hibernation. powered off.

And if we’re really lucky? This issue was the root of all these ‘failed to connect’ issues…

1 Like

This issue could have been easily fixed if Eve would just do one thing already: release a firmware update tool that natively supports macOS. There’s really no excuse for something as simple as a firmware update tool being Windows exclusive.

1 Like

Hi @RyDawg,

Please see the latest update regarding the macOS Firmware updater tool.

1 Like

I am in the same boat here except the issue lies with the USB hub firmware update; after several attempts at the firmware update I’ve gone from 105 to 106 successfully, but now when trying to update the USB Hub the tool just keeps saying no device found off of the same setup used for the firmware update.
Mind you this is on a Mac so im limited to parallels to run the installer, but im confused as to why the firmware update ran fine yet the same port (USB-C) won’t register for the USB hub. SMH

Screen Shot 2022-05-04 at 9.53.46 PM
this is just an example of what I am dealing with but after switching the input from select automatically to usb c the message changes for the firmware update tool but the usb hub update tool still doesn’t change no matter what I do (plug it in and out, change settings, etc.)

1 Like