MacBook Pro 2019 on MacOS Big Sur 11.6.1 gets 4k120hz on M28U, but not Eve Spectrum with either USB-C to DP or TB4

I read through 4K 144Hz over USB-C from MacBook Pro?, but there are a ton of posts, and no clear conclusion.

My setup:

  • Eve Spectrum ES07D03 running firmware version 104
  • MacBook Pro 16-inch (2019), Intel chip, running Big Sur 11.6.1

I bought these two cables:

When I connect with the USB-C to DP cable, it defaults 4k@60hz automatically. I disabled HDR. However, even so, I have no option to switch to 120hz or 144hz (not even with a lower resolution). SwitchResX gives an option for 2560x1080p@120hz, but not at 4k. I tried to do a custom resolution, but no luck, it said 4k@119hz was invalid (though I may have done this wrong - I used the simplified option, but just selected CVT and maybe I should have selected a different option?)

When I connect with the Thunderbolt 4 certified USB-C to USB-C cable, I get no connection at all. This doesn’t seem to change regardless of what settings I tweak.

After trying all of this, I decided to try a different monitor. From the forum posts, I thought this was probably a MacOS issue. What I didn’t expect is that on a Gigabyte M28U, both cables give 4k@120hz!

When I connect to the M28U with either cable, it defaults to 4k 60hz. However, if I go to System Preferences → Displays → Option-click “scaled resolution” → check “show low resolution modes”, and open the “Hz” menu, both cables allow selecting 120Hz no problem!

Are there only certain cables compatible with the Eve Spectrum? Are Intel Macbooks incompatible with the Eve Spectrum in particular? What do I need to buy, or what can I do?

I can’t upgrade to MacOS Montery as this is a work laptop. However, as I understand it, a lot of display fixes were backported to Big Sur in one of the point releases, and I’m on the latest Big Sur release. I can’t get 144Hz on either display, so maybe DSC is still broken. Regardless, 4k 120hz works on a different monitor, but not on the Eve?


I have exactly the same issue on an M1 Mac Mini.

It’s 100% a Spectrum defect, not a MacOS or cable issue.

I currently have my Mac set to 4K/60hz, very much hoping USB-C DSC and general compatibility improvements are included in the next firmware update.

1 Like

Screenshot 2021-12-01 at 19.02.25
I’m using firmware 102 and all day the display worked with only 30hz but for some reason, after a while it started running on 60hz without changing a thing.

1 Like