How to permanently unlock Fn-Lock (F1 - F12 by default)

Hi everyone,
I hope someone can help me. I tried the support already, but without success. Not sure if I was unclear or simply not writing plain English enough.

I use 80% of the times the keys F1 - F12 and not the media keys. But by default it seems that the FN-Lock is set to the media keys. I know how to change Fn-Lock (Fn - ESC), but every time I restart my Eve V, the Fn-Lock is back to media keys.
Is there a way to switch it permanently to be on or off (which ever is F1-F12, on or off).
I know with several other laptop brands there is a setting in the Bios/UEFI which can set it to on or off. But I didn’t find anything in the UEFI for the Eve V.

Any ideas?

Working in Excel you can click F2 to get into edit mode of a cell. Working in the browser I want to refresh the page and can do that with F5. But every time I restart my V, it’s back to media buttons and the first time I use the key I either increase the screen brightness or the volume in these two examples. This is really annoying :angry:.
I work 5 days a week, 9-11 hours a day on computers where I simply use the F1-F12 keys without thinking and then maybe 5 hours a week on my V where it is all upside-down with regards to this.

Any (useful :wink:) advise would be appreciated.

I found that the Fn-lock survived restarts and even disconnecting the keyboard but would be reset when the keyboard is reconnected with its Pogo pins. I raised it with Eve in 2018 but they never fixed it:

You could try downloading the updated firmware here:
(Downloads->Firmware->Keyboard & Touchpad)

Version 1.18 is the most recent version, but that fixes something different, so it may not fix the issue you’re finding. Also, being a firmware (which I think is beta), install at your own risk. Further details here:

Hi Phil,

nope, I updated all drivers and firmware some time in spring. But just to be sure, I tried it now again with the latest one but it didn’t work. A restart and its back at the media buttons.
I set my V to go into hibernate when I close the lid (flip the keyboard up) and when I start it again it’s the same, so it acts like a restart as well. But after I tried the firmware just now, I actually restarted as I had to anyway for some small windows update.

Back in 2018, I see someone was reporting the same thing. I have had it happen a couple of times when hibernating but not plugged in - but sometimes it works fine. Could you see whether it also resets the FN-lock when hibernating when the PC has power (i.e. plugged into the mains)?
If it doesn’t reset when the PC is plugged in, then it could be:

  • a problem with the keyboard battery
  • perhaps a setting as to whether USB devices can be charged when the machine is powered oiff (and not connected to the mains). It’s just a guess, but if the PC is set to allow charging of USB devices when powered off, it may maintain power to the keyboard when powered-off and thus stop the fn-lock being reset.

Just ideas. No idea whether they make a difference.

1 Like

Hi Phil,

Sorry, couldn’t find the time to try it out.
No, it didn’t work. I tired with power cable to close the keyboard and without cable, I tried with cable to restart and without cable. It does not keep the chosen Fn+Lock setting.