Horrendous blue burn-in and flickering at 60HZ

I’m pretty sure. I believe it ended with it prompting me to power cycle with a 5 second delay (although the instructions said to power cycle with a 10 second delay and that is what I did). Because it wasn’t responsive, I did try power cycling again but it didn’t help.

All I can seem to get out of it now is when I press the menu button on the back I can select inputs, but it’s otherwise unresponsive when an input is connected.

I left it unplugged overnight and just plugged it in this morning and tried it again. My MacBook isn’t rebooting anymore, but I’m getting a black/blank screen on the display. Wait, scratch that. When I choose the input “Select Automatically” it reboots it. I was cycling through all the inputs and just realized that’s the one that triggers that behavior.

What now?

Hi there,

Uhm, help me understand your setup for a second.

So you have a PC and a Macbook. If I understand correctly, the Macbook refused to reboot until you choose the input to “Select Automatically”? How do you have your devices connected at the moment?

Do you have both devices connected to the Spectrum at a time, or just one?

Also, what colour is the LED indicator on the Spectrum? Is it light blue?

1 Like

Sure, no problem.

I only connect my PC or Macbook one at a time via USB-C. I do not try to connect them both at the same time.

I have a PC laptop - a Razer Blade 15. I used it to perform the firmware update, so it was working with the Spectrum prior to this. When I connect it to the Spectrum after the firmware update, the screen on the laptop changes as if it detects the Spectrum, but the Spectrum never comes to life. The Spectrum screen seems to be on but blank. The light on it is solid white, or I guess a solid light blueish, so it doesn’t appear to be in sleep mode. But it doesn’t actually display anything.

When I plug the Spectrum into the Macbook and the display is set to the input “Select Automatically”, a few seconds after I plug it in, the Macbook reboots. I realized this morning that if I manually change the input to any other input, it doesn’t reboot, but it behaves exactly like it did when I plugged my PC laptop into it.

Hi there,

Thanks for explaining.

The light will turn purple when the update concludes. So if its still on light blue, then the scaler is still verifying data and processing the update. From my understanding, it seems like the update is still running. Keep it connected to your PC during the update process until it completely finished just to be sure.

Spectrum is equipped with a safeguard should a firmware update fail, from which it will revert to its base version (I believe it is version 102).

Can you run the firmware updater and see if it can detect the Spectrum?

I tried running the updater app again just to see if it would connect. I had my laptop set to use the Spectrum as a primary monitor and when I plug it in, it switched to that mode so it was difficult dragging the window back to the laptop screen but I managed to do it.

It is showing “Device Disconnect”

By the way, I know what purple light you’re referring to. I got that purple light at the end of the firmware update process. This is what my setup looks like right now (and yes, I hit the refresh button several times to try and get the UI to update, it still says “Device Disconnect”)


Hi there,

Thanks for taking the time to explain the situation!

As long as it reaches purple light, then it should be fine. There are a few things that you can try based on the post made by @NZgeek here.

It all boils down to more power cycles. You may want to check the rest of the posts on the link above as a reference.


I had already tried the overnight power cycle but happened to have it unplugged after trying to get it working yesterday so I tried it again this afternoon, but it’s the same. The other methods don’t seem to change the situation either.

1 Like

Hi there,

Just as a verification, when you first power on the Spectrum, do you see the Eve Logo flash upon the screen?

Also, what happens than you pull the joystick down (which changes the input type), does it show a mini menu to allow you to change the input?

1 Like

When I power it on, I do see the eve logo and I can change the input, yes.

1 Like

Cool, thanks for getting back with us. Next question - in your screenshot you show that the monitor is not being recognized (black screen) when connected to that Windows laptop. When you press up on the joystick, you can change USB input - is it by chance set to select automatically? If so, can you press up until it shows USB Type-C and then hit refresh on that fw update tool?

1 Like

I thought of that and tried it, but it still didn’t respond after setting the input manually.

Hi there,

Have you by any chance tried to use a different connection (HDMI/DisplayPort) to see if you can get the Spectrum to display anything at all?

I’ve tried using HDMI inputs and nothing gets displayed no matter what input I choose. It’s just a black/blank screen.

I contacted support to request an RMA on August 26th, including a link to this thread to show all the steps that have already been taken.

10 days later… no response.

This is ridiculous…

Hey @cuebix

I do apologize for the delay in response as that is not the expected customer service you should receive! Can you send me your order ID so I can inform support about your inquiry?

I finally got my replacement monitor a few days ago - and still have not received reimbursement for the shipping costs I paid, btw - and just a few days and probably less than a full hour of using the monitor and I have the blue light burn in issue again.

I checked the firmware that the monitor shipped with and saw that it was 105 so I updated it to 107 and also updated the usb firmware to the latest and the problem remains.

Here’s a link to a video where I noticed the issue and unplugged the monitor and you can see the image stay on screen in a very clear, strong blue tint: IMG_2452.MOV - Google Drive

This is incredibly frustrating especially since it has taken months to get the monitor replaced, I spent about $100 to ship my monitor back and have not been reimbursed, and the replacement I was sent exhibits the same issue.

How do we proceed?

1 Like

It randomly happened to me just now. I’d like to see this being resolved and I wonder what will Eve / Dough do to resolve this. Will I need to send my monitor back for replacement? Will I have to wait for months? I’d be glad to get an answer from the official representatives.

here’s a video about my burning: Eve Spectrum blue burn-in - YouTube

For IPS panels, this is not a permanent issue and is generally due to some residual charge in certain portions of the display panel’s circuitry.

It does seem odd that this is happening to several people. I wonder if there’s usually some sort of ground connection to the panel that helps prevent this, which has either been skipped or isn’t working correctly with the Spectrum.

One thing to try is the burn-in tool I created a while back.

Click the big Start Burn-In Fix button in the lower-right panel to start. It’ll cycle through a bunch of colours, which can sometimes be enough to “reset” the circuitry those pixels that are showing ghosting.

I’m using an ES07D03 since roughly 8 weeks now and started running into this issue today as well.

I updated the screen to Firmware 107 (and the most recent USB FW) a few days after I received the screen.

Recently, I mostly used the screen via USB-C from my Macbook Pro M1; sometimes also via Displayport from my Windows Desktop.

I noticed today that suddenly the colors were off on the Spectrum. When I moved a window around, the color changed from normal to green-ish tint, depending on the position of the window. I tried resetting the settings in the OSD and unplugging the screen from power for a few seconds, which restored the colors, but led to heavy flickering of the entire screen when Adaptive Sync was on. I noticed what seems to be burn-in on the right side of the screen, that is also visible when no device is plugged in and only the Spectrum Logo is shown. I can see the outlines of a white PDF on dark background which I had open for a few Minutes on that position - certainly not long enough to cause burn-in. So I assume the video signal somehow got written into the wrong location of the screen memory / circuitry? No idea, not a screen hardware expert here.

The flicker disappears when I turn Adaptive Sync off, but comes back, when I turn it back on.

I tried the burn-in tool, that NZgeek mentioned, but that did not help.

Can this be fixed with a firmware update, or should I just return the screen? This is extremely frustrating and seems to be a very common issue.

Just to check: when you upgraded the firmware, after doing the first power cycle, did you get to the message that said that the upgrade was successful and to power cycle the screen?

If you didn’t, it’s possible that the firmware didn’t install properly. Your Spectrum might mostly work, but might also run into strange issues. The only way to fix this is to downgrade to an earlier firmware version, then upgrade again to v107.

Assuming that the firmware did upgrade correctly, which computer are you having problems with? Is it just the Mac, or just the Windows PC, or both? Also, where does the colour change happen? Is there a line down the middle of the screen where things are green-tinted on one side but not the other?

A few people have reported issues where the left and right sides of their screen have not quite been in sync. I have no idea what the underlying issue could be, but it’s not inconceivable that there are manufacturing issues that affect a small percentage of Spectrums.

If I remember correctly, both FW upgrades (107 + USB) were successful and asked me to power cycle the screen, yes. I’m pretty sure I did not see any errors in the process.

I will try the PC tomorrow and post the results here.

The color change did affect the entire screen. I could trigger it by moving a certain window to a specific location, turning a certain area of screen under that window dark/bright.

Btw, no idea if related, but I also had issues with the screen going black, maybe once every 2 or 3 days. That could be fixed by just pulling the USB-C cable and plugging it back in, or using the power button to restart the screen.