Having trouble connecting my MacBook Pro 2017 to my Spectrum via USB C

Hello everyone! Just got my spectrum hooked up but I can’t seem to get the monitor to recognize my MacBook Pro 2017 when using just a single USB C cable. I tried the one that’s included with my computer, tried another USB C cable I got from Amazon and also a really nice Belkin Thunderbolt 3 cable as well an nothing. My computer charges but when I switch to the USB C input it just says no input found. Tried both ports on the back of the monitor and tried all ports on my MacBook Pro. What am I missing? Do I need a specific cable or settings enabled/disabled? Any help would be super appreciated! I was able to get it to connect to the monitor via HDMI and a USB C hub but that’s it. Thanks!

It’s the bottom port you want to use.

In the displays OSD have you tried switching it to 60Hz mode? That may help.

Also connect it then try closing your MBP for a few seconds then opening it again.

I first used the Thunderbolt 3 cable from my LG Ultrafine display and it didn’t work. I had to buy a new Thunderbolt 4 cable.

I’m also in this scenario, I can’t get my monitor to recognize there is a Macbook plugged into the USB-C port…?

I explicitly set the USB hub source to USB Type-B, USB-C bandwidth priority to be “High USB data speed”. Then setting my “Select Input Source” to be USB-C.

I charge my work MacbookPro using that bottom USB C port since it has 100W charging, but I can’t seem to my monitor to recognize there is something plugged in?

EDIT: Macbook to Spectrum (Screen Share?) - #5
^ I’m probably not using a cable that supports video. The third party USB-C cable I’m using says power charging cable, which probably doesn’t have the video connectors.

My Spectrum is working just fine with a MBP over USB-C.

Important things to note about my setup.

  • I’ve got a Thunderbolt 3 40Gbps cable connected.
    • Many USB-C cables are designed for charging only and don’t have the high speed data lines needed to carry a video signal.
    • There are different speed Thunderbolt 3 cables. You need to have one rated for 40Gbps.
    • The maximum length for a 40Gbps cable is 80cm / 3ft. If your cable is longer than this, it probably won’t work.
  • The cable is plugged into the bottom USB-C port on the Spectrum, which is next to the power connector.
    • The USB-C port on the side is for connecting peripheral devices (e.g. keyboard, mouse) only. It doesn’t accept a video signal and is limited to something like 15W power output.
  • The USB-C cable is plugged in to the right side of my MacBook Pro.
    • I don’t think the port matters when it comes to video signal. However, the left side ports tend to have heat issues when used to charge the laptop, and I’m charging using via the Spectrum.
  • I’ve got the Spectrum’s USB bandwidth priority set to high refresh rate.
    • All USB-C cables have dedicated wiring for USB 2.0 data, so the USB hub is always going to work.
    • USB 2.0 data is perfectly fine for things like keyboards and mice.

I have no problems getting a 4K@30Hz signal. I have to use the Option-click Scaled trick to make 60Hz available (was automatic on firmware 102R875, manual on firmware 104).


I remembered one other thing that might make somewhat of a difference…

I use a MBP for work and a Windows gaming laptop for everything else. When I got my Spectrum, the very first thing I did was hook it up to the gaming laptop and flash the 102R875 firmware. It had an earlier 102 release installed initially.

It’s possible that there’s something in the newer firmware releases that can help with USB-C connections. However, that means you need access to Windows to run the firmware flashing tool.

What’s the option click scaled trick? Have a similar issue with my work laptop, tops out at 4k30Hz

This here https://media.yep.digital/encJqe