GeForce Driver 522.25 update woes

So I had a strange time last night after updating to the latest NVIDIA GeForce driver [ GeForce Game Ready Driver - WHQL Driver Version: 522.25 Released on Wed Oct, 2022 ]

Upon downloading and performing a ‘clean’ install via the GeForce Experience it prompted me to restart the computer. After restarting, the spectrum didn’t pick up any signal. I tried to troubleshoot by checking wires, input, cutting power to the spectrum for 10s etc. but to no avail. I restarted my computer and walked away as I had been offered to have a beer with a mate.

Upon coming back to the computer a minute or so later, the power LED on on the spectrum had turned light blue, which alerted me to think it was in the process of a firmware update somehow. I believe I pulled the plug on the spectrum again and after giving it power once more it stated it was processing an update with a green power LED. I let it do it’s thing while I connected up another display to see what my computer is doing (I use this display to access UEFI bios or to troubleshoot when drivers aren’t happy with the Spectrum). No signal to the second display. (Is NVIDIA pushing for me to buy the new graphics cards this bad? :joy:)

I turned off my computer, pulled the plug on the power board and gave it 10s. After turning on the PC it displays a message on the 2nd display: “bios is updating” or something along those lines. I let it do it’s thing while I pull up my work laptop to check if the spectrum is responding to other sources. Luckily it worked just fine. Phew.

Eventually the PC boots up properly and I can log in and troubleshoot that it’s just a lackluster driver so I downgrade to a later version and all is fine.

Has anyone else encountered something like this? I haven’t had such a turbulent time updating a graphics card driver in my life :sweat_smile:

PC specs:

CPU: AMD R9 3900x
GPU: EVGA 1080ti Kingpin Edition
MOBO: ASUS ROG Crosshair VIII Impact
Using DP 1.4

If the Spectrum went through the firmware update process, it sounds like you may have flashed a firmware update at some stage in the past that didn’t complete.

When doing a firmware update, you need to remove power to the Spectum for a short period. Simply turning the Spectrum off via the power button on the back isn’t enough (it might be, but might not).

You mentioned that when you were troubleshooting, you pulled power to the Spectrum for 10s. This would certainly be enough to trigger the update process if it had been waiting to happen.

If you didn’t have a firmware update that didn’t properly finish installing… who knows? Perhaps something upset the internal firmware version that the Spectrum thought it had, and it saw that there was a different version sitting in flash storage and installed that.

1 Like

Ive not had this issue. But im having other issues w/ my glossy version. There are many different BIOSES that boot up on any PC. Its hard to say which one was actually saying that. You said you got the message “bios is updating” on the second monitor aswell as the eve? It could have been the GPU i suppose if the NVIDIA driver updated something on the cards bios, which would explain why you saw the message on both cards. Not sure what the BLUE light means on the EVE however as ive never seen that on mine. Standby is not supposed to be blue, but you can change the color apparently in the menu.

1 Like

I’m 110% sure that I have completed previous firmware updates properly as I’ve been running version 106 for some time now and as you suggested I have removed power via unplugging the power cable to commence the final stage of FW update etc.

I guess I shouldn’t rule it out but I would think that if it stated v106 in the OSD (after supposedly having a successful FW installation) it was correct? Maybe I should a bit more focused when going through the steps.

I remove the power cable quite frequently for 10s since there are times the spectrum doesn’t detect my PC after spending a day working from my work laptop via HDMI and this overcomes that issue.

I like your explanation :rofl:

To clarify, the second monitor displayed “bios is updating” very similarly to the picture below. Black screen, white blocky text in the top left hand corner. Would this mean it was updating a graphics card bios or the motherboards bios?
image

The spectrum on the other hand stated it was updating its firmware with the usual different coloured power LED as opposed to my custom purple LED preset.

YOu should be able to easily see what version of the firmware you have installed now. If its 106, then it may not have been your monitor but rather your GFX card. But i can’t obviously be sure about that. Perhaps geek is correct, but i dont know. Only a support tech could confirm that.

This is what the firmware install instructions say: " This firmware involves a 3300 chip update Process… window shows up, and the indicator light starts changing gradually from green to blue and eventually purple. After instruction to power cycle the monitor shows up, unplug the monitor’s DC plug, wait at least five seconds, then plug in the monitor. After that, the monitor boots up as usual."

Nvidia doesnt have anything to do with your monitors firmware. So if the text said “nvidia” or anything GFX card related then it was probably the GFX Card, but i cant be sure as the motherboard bios is usually only relaying information that it reads from the GFX bios. Do you remember the actual text that was displayed on the second monitor? Because if you got two “updating bioses” on 2 different displays, its likely the update was the GFX card, not your monitor. That or it was your motherboard.

Is this the screen you saw?

WP_20141122_19_04_14_Pro

If thats the case, then it was from your motherboard. Why that happened on a GFX driver update, im not sure.

Do you have myasus app installed? Or some kind of auto update from asus? It could be they DLDed a bios update with your install and it concurrently ran. Double check your MB driver version too and see if its updated (if you remember what you had).

1 Like

That’s the screen!

And this is why I’m more confused than ever. Somehow after downloading and installing a graphics driver update both my motherboard and spectrum thought to update also. Truly bizarre.

I don’t have the myAsus app installed. I have armory crate but I don’t have any autoinstaller.

Thats your motherboard updating. It shouldnt be spectrum updating anything. I got this pic from a ROG Asus chat forum with someone having bios issues.

This makes it all the more strange if you say that’s what happens when a motherboard updates.

That means that after a graphics driver update it somehow triggered the motherboard to update and the spectrum monitor to update firmware.

But how do you know the monitor was updating the firmware? The screen i posted was the screen you saw above right? Did you see any other screen other than that one? That screen is what the motherboard posts when its updating the firmware. There is also different firmwares. One is BIOS and the other is LED Firmware.

I’m not sure if you read my post right, my 2nd monitor stated bios updating while my spectrum diplay displayed at the same time that it was updating its firmware (white block in the centre of display with black text stating updating firmware + peer LED change)

I’ve quoted my post below:

When the Spectrum is updating, the update message will show in the middle of the screen.

When the computer or GPU BIOS is updating, it’ll usually show regular white-on-black text at the upper-left of the screen.

1 Like