FPS Display red and stuck on 144 after latest firmware update

My fps counter was always green and actively fluctuating before updating to firmware 107. After the uodate though my coutner is now red and doesnt ever move. When I would play RDR2 at 4k medium settings i was getting around 70 to 80 frames. Now though its locked at 144… even when just browsing the internet or doing general tasks on my pc doesnt make the display move at all. Anyone else having this issue? Is it possible that the firmware 107 update also updated my PC’s hardware and turned it into a super computer??? /s

In all seriousness though would love to hear if anyone else is having this issue. Also, side note, hoping this update will fix the random screen blanking ive been experiencing again.

The colour of the FPS counter did change to red at some point. I can’t remember if it was firmware 106 or 107. That’s working as expected.

If your FPS isn’t changing, it’s likely that G-Sync / FreeSync isn’t working.

If you’ve got an Nvidia graphics card, go into your Nvidia Control Panel and check that the G-Sync section is showing in the navigation panel. If it’s not showing, you need to:

  1. Close the NV control panel.
  2. Open the Spectrum’s on-screen controls, go to the Performance section, then turn Adaptive Sync off.
  3. Wait for the Spectrum to display a picture again.
  4. Do the same thing as step 2, but turn the setting back on.
  5. Wait again.
  6. Open the NV Control Panel again and check that G-Sync is now showing.

I don’t know what the AMD settings look like, but there’s probably something similar. If FreeSync isn’t available, do the same steps above but using the AMD settings instead of the NV ones.

I almost always have this issue with my gaming laptop. The external RTX 2070 never picks up G-Sync on first boot. I used to be able to fix it by turning the Spectrum off and on via the power button, but it’s not been working as reliably since 107. Changing the Adaptive Sync setting has been working reliably to get G-Sync going again.

2 Likes

Thank you very much for the fast response! I will give this a shot once I’m home ill give it a shot.