Eve Spectrum Monitor Burn in?

I was using my monitor for work and I switched my input and BOOM this happened:

I’m not really sure what the cause is. I’ve restarted the monitor by unplugging it and plugging it back in and it still pops up like that every time now.
Is this a known issue?

I’m on the latest firmware.


Happens even when I change the input:

I would write the support and open a ticket, this could be a hardware problem.
You could test another cable and port, but this does look like its a panel thing.


Hey @hoodnerd,

Sorry to hear you are experiencing issues with your Spectrum. If you have already contacted our support team, please could you send me your support reference number, and I’ll pass this onto the team to look into this as soon as possible for you.


I had the same issue today as well. While working on some text files, the display suddenly starts to flicker ans some sections are burned in as well. Neither rebooting nor changing cables fixed the issue. I am afraid this could be a hardware thing. Support ticket opened. No idea how the replacement process with Eve is these days…


It seems like the issue slowly fades out. Flickering is mostly gone and the burned in areas have disappeared thankfully. How is that going with your display @hoodnerd?

1 Like

@Oliver_Wagner It was disappearing over night but once I tried to plug in my work M1 MacBook Air, it started happening again. So yeah I believe it could be a hardware issue as well. It’s like the monitors pixels stay active no matter what input you use, it creates a type of burn in like you said. :man_shrugging:t6:

1 Like

This doesn’t look like burn in. Burn in is related to persistent images actually wearing out pixels in a distinct pattern/shape. You see it on TV’s that stay tuned to the same news channel, or displays that put the same content in the same spot 24/7 for many days.

Considering the “burned-in” image is clear, distinct, shows dynamic content, and is exclusively blue, this looks like something between the firmware and the hardware stopped updating the blue sub-pixels, but kept updating the red and green.

Has anyone tried to “cold boot” their monitor by power cycling it to see if the blue image goes away, and functionality returns to normal? Completely unplug the monitor, wait 30 seconds to a full minute, plug everything back in and try again.

1 Like

Hi all,
Sorry for the delayed reply but I wanted to give it sometime before I reported back. It looks like it went back to normal after a few days but non the less it was scary situation for a monitor that is only a few months old.

@Brendon_Leenheer I did all of that initially and it still was happening, that’s why I thought it could be a burn in issue as it persisted on all inputs and even when monitor was dark.

Hopefully it doesn’t happen again or to anyone elses monitor.

Happy Holidays! :v:t6:

1 Like