Eve Spectrum 4K - Scalar 107 Update - Install Issues / Vertical Lines

Hi All,

My first post and just created an account to let you know the issues I faced when updating to the 107 firmware. I also seem to have resolved them now myself.

Firstly when updating to the 107 my monitor had trouble progressing going from green to blue then to purple. At first it got stuck on green and after about an hour I took the power cable out and did a power cycle. Unfortunately the monitor just got stuck on the Eve Logo. I waited until the morning to try again. Luckily the monitor seems to be able to restart itself and eventually restarting “processing update…” very quickly and went to purple. However I have a feeling it didn’t update properly…

I’ve been away for a week and just loaded up my Xbox Series X (Sniper Elite 5) and noticed I had vertical lines going down the screen where it looked like the refresh rates were out of sync.

It tried the following with no luck:

  • Resetting the monitor to factory settings
  • Turning off VRR (monitor)
  • Changing Display Rate, Resolution (Xbox)

None of these seemed to help the issue. I have just re-downloaded the scaler 107 firmware and tried to update again. It re-installed on the computer through the software but after power cycle didn’t come up with “processing update…” Maybe the power cycle fixed it or maybe the update being re-installed helped, I dont know, I just thought I would all let you know if you have the same issues.

Many Thanks,

Jacob

1 Like

Hey @JHobbs97

:tada: Welcome to the community :tada:

Thank you for posting this! I will keep note of this for a future customer if they should have the same issue. Just to be clear, the power cycle or reupdate solved your issue?

Not 100% sure, either that or pushing the update from my monitor again.

Hi @JHobbs97,

Thank you for the thorough explanation.

It would seem like the power cycle may have helped in your case. I have received a few feedbacks here on the community saying that multiple power cycles are needed to have the monitor running properly post-update.

Anyways, please let us know should you encounter more issues down the line.