Dual monitors on Mac Studio

Hello. I have two ES07D03 monitors hooked up to a Mac Studio running 12.3.1. The monitors are running firmware 106 and are both connected via USB-C. I’m wondering if anyone else with 2 monitors connected to a mac are seeing these problems.

First issue:
If I allow my monitors to sleep (computer never sleeps) or force them to sleep with a hot corner, upon waking them, the screens will display the desktop (sometimes normally, sometimes half the screen will be cut off, or the desktop will be small in one corner of one of the screen), and I can see the pointer moving, but the UI is otherwise unresponsive. For instance, the clock will not update. I have seen this happen if one of the monitors is connected via HDMI and the other via USB-C as well. I have not observed this happening with only 1 USB-C connected display.

Second issue:
MacOS does not seem to be able to uniquely identify the monitors. When I turn on the computer, which monitor is (1) and which is (2) seems to be down to whichever monitor wakes up first, and that can cause my display arrangement to be backwards. Digging into this a bit I discovered that the “DisplayAttributes” in the ioregs contain:

1:
“DisplayAttributes” = {“SupportsSuspend”=No,“MaximumRefreshRate”=144,“SupportsActiveOff”=No,“SupportsBT2020cYCC”=0,“PortID”=0,“ProductAttributes”={“ManufacturerID”=“EVE”,“YearOfManufacture”=2021,“SerialNumber”=16843009,“ProductName”=“ES07D03”,“AlphanumericSerialNumber”=“EVE212600604”…
“EDID UUID” = “16C50100-0000-0000-1A1F-0104B53C2278”

2:
“DisplayAttributes” = {“SupportsSuspend”=No,“MaximumRefreshRate”=144,“SupportsActiveOff”=No,“SupportsBT2020cYCC”=0,“PortID”=16,“ProductAttributes”={“ManufacturerID”=“EVE”,“YearOfManufacture”=2021,“SerialNumber”=16843009,“ProductName”=“ES07D03”,“AlphanumericSerialNumber”=“EVE212600476”
“EDID UUID” = “16C50100-0000-0000-1A1F-0104B53C2278”

Should the “SerialNumber” and “EDID UUID” attributes be the same for both monitors? That doesn’t seem right to me.

1 Like

I have almost the same setup as you:

  • Mac Studio running macOS 12.3.1
  • 2 x Eve ES07D03 monitors with firmware 106
  • Both monitors plugged with Cable Matters USB-C to DisplayPort cables
  • Both monitors set to 3840x2160 144Hz with HDR off

Here are the issues I face:

  1. macOS UI will sometimes become unresponsive, with only the cursor moving. Unlike OP, I have not noticed the “half the screen cut off” issue though. Disconnecting and reconnecting the displays (either the power cable or video cable) fixes the issue.
  2. One of the two monitors will often go black. The OS will still show both monitors as being connected even though one is all black. This will typically happen during usage, and I noticed it tends to happen more if there is lots of movement on-screen (e.g. full-screen video, full-screen animation like maximizing a window). Disconnecting and reconnecting the black display (either the power cable or video cable) fixes the issue.
  3. MacOS cannot uniquely identify each monitor. I believe this is a macOS bug not specific to Eve displays. I use displayplacer as a workaround.

Prior to using a Mac Studio, I was using my two Eve displays with an Intel 16" MacBook Pro. Same OS, same cables, but the displays were set to 60Hz rather than 144Hz (due to a known limitation with Intel Macs and recent macOS versions).

I had issue #3 with my MacBook Pro, but I didn’t have issue #1 and #2.

It’s unclear what’s different in my new setup that made these issues appear, but potential factors are:

  • Using a Mac Studio specifically
  • Using an ARM (Apple) chip rather than an x86 (Intel) one
  • Using 144Hz rather than 60Hz
  • Using DSC (Display Stream Compression) in order to achieve 144Hz

Issue #2 is by far the most annoying to me. In a 8-hour work day, I will typically have to unplug/replug my monitors 2-3 times. This sometimes happen in the middle of work video calls so it’s really problematic. My new setup is nearly unusable right now.

I’ll try setting my monitors to 60Hz to see if the issues are specific to 144Hz/DSC. I’ll report back.

Disconnecting both displays and then reconnecting both displays does indeed work! I mean, it’s not an acceptable solution, but it is better than needing to reboot the machine. After doing that I noticed that the displays came back as 3200x1800 at variable refresh instead of at 144Hz. That seems to happen every now and then, but even when set to variable they are running at 144, so that’s fine, I suppose.

How do you know if you are using DSC? Is that required to achieve 144Hz, and if so, at what resolutions?

I have thankfully not experienced issue #2.

The reason I suspect issue #3 might be specific to these monitors is because of that serial number issue I mentioned. And when I tried unplugging/replugging the monitors earlier and they swapped places, I checked ioregs and the port number to alphanumeric serial number mapping did (as one would expect) stay consistent, so it does seem like something the OS could handle better if apple wanted. I can understand wanting to ignore the port number for display settings generally, but if every other field for 2 different displays is identical, using the port number to maintain monitor layout makes sense. But this is also something I’m sure eve could fix in firmware. If nothing else, having a user-settable “displayID” that gets added to whatever field the OS is using to differentiate monitors would solve the problem.

Anyway, at least I know I’m not alone in having these issues, which hopefully will get the eve firmware team to take notice.

I’m not sure how one can validate that DSC is enabled in macOS. I assumed it was, since I believe it is required for 4K 144Hz over DisplayPort 1.4. I might be wrong though, as I couldn’t validate it, and maybe 4K 144Hz is achieved through some different compromise (chroma subsampling?).

I think the highest refresh rate we could achieve through DP 1.4 without lossy compression at 4K is 120Hz. However, it’s not offered to me in the macOS display settings. It jumps directly from 60Hz to 144Hz. That’s why I’m now trying to use 60Hz to see if I can reproduce the issue. It seems to be the highest refresh rate offered that doesn’t involve lossy compression.

These monitors support 120Hz, don’t they? I wonder why I can’t pick that refresh rate in macos, if I can pick 144Hz.

1 Like

Yeah not sure why 120Hz is not offered.

I’m trying to test the monitors at 60Hz to see if I have the same issues as at 144Hz. However, they keep randomly resetting to variable (48-144Hz), which makes my testing hard.

I have 5 issues:

  • Monitor blackout during usage
  • Monitor not waking from sleep
  • MacOS UI freezing
  • MacOS failing to uniquely identify monitors
  • Refresh rate keeps reverting to variable (48-144Hz)

It’s unclear if they’re independent bugs or if they’re related.

My monitors also reset to variable refresh, but it seems to only happen after some monitor “event” such as one waking up or being reconnected. You are seeing it switch to variable during normal use?

And interestingly, the past couple times my monitors have actually woken up in the morning without the UI being frozen, which is shocking since I haven’t changed anything, or even rebooted, since I was seeing the problem. Although today when the monitors woke up, one of them had about a 2" band at the top of the screen where the image would flicker in and out. It stopped doing that when I switched my display mode back to fixed 144 (of course it had come back up as variable).

Another thing I noticed that I thought was interesting: when the UI appears frozen, it isn’t actually unresponsive, it’s just not-visibly responsive. While “unresponsive” I clicked and dragged a desktop icon from my tidy column of icons to the middle of the desktop. I couldn’t see anything move on my screen other than the pointer. Then when I unplugged/replugged the displays I found the icon had actually been moved to the middle of the screen.

Hi @p_giguere1,

I do not own a macOS device, but from my understanding, DSC is not a requirement for DP 1.4 certification. It is supported but not required. Based on the feedback I have gathered, 4K 144Hz is achieved by chroma subsampling (if connected via USB-C).

When it comes to settings, macOS is quite particular when supporting a specific refresh rate on a particular resolution. Spectrum does support 120Hz but macOS refuses to give the option to enable in-between settings.

Were you guys talking about setting in OSD? This might be something worth experimenting with: Try setting the monitor to factory default, then perform a power cycle. After turning it back on, change the OSD setting as you like and see if it retains it.

No, we’re talking about the macos display settings. We are setting the monitors to be 144Hz fixed, and sometimes those settings switch back to variable refresh (which seems to get it between 48 and 144Hz depending).

I’m not sure what OSD setting you’re talking about. Adaptive-Sync? Does that setting disable the variable refresh capability? That would be one way to prevent macos from switching to it, hopefully.

Can you point me to descriptions of the other settings in the Performance menu of the OSD?

Hi @asolochek,

Yes, the OSD setting I was talking about was Adaptive-Sync (under Performance).

That is the only one I can think of that enables/disables variable refresh rate.

Update: I’ve been using my monitors at 60Hz for about a week. The random blackouts during usage stopped since. I still have the issue where they can’t wake up from sleep, as well as the UI freezes though. The workaround of setting the monitors to 60Hz is of course not an acceptable permanent solution, given how the high refresh rate of these displays is a major selling point. I’m only testing this to help diagnose the issues.

On the refresh rate issue: It’s true that the reset of the refresh rate to variable (48-144 Hz) usually happens after some event (like reconnecting the monitor), not randomly during usage. I also noticed that other macOS display settings sometimes change following the monitor being reconnected. For example, the “High Dynamic Range” checkbox has turned itself on automatically, and the radio button where you can choose between “Default for Display” and “Scaled” also changes value by itself.

Basically, macOS display settings in general fail to persist between reconnections of the same monitor. I wonder if that has to do with Serial Number / UUID issue mentioned by asolochek.

1 Like

Hi,

I’ve noticed issue #1 as mentioned by @p_giguere1 as well. I’ve had a completely frozen screen as well as one where only my mouse cursor moves.

I have a single ES07D03 connected to my Mac Studio running Mac OS 12.3.1 through USB-C. I run at Scaled 2560x1440 at a variable refresh rate. Although the refresh rate sometimes jumps back to 144Hz after a wakeup.

This morning the frozen UI problem reappeared for me, only this time unplugging and replugging the monitors did not fix the problem. What did, somewhat ironically, fix the problem was putting my mouse pointer in the hot corner I have configured to sleep the displays. When they woke up the second time everything was as it should be.

Hi @p_giguere1,

Based on the feedback I have gathered, we don’t have this issue with Windows. Its because the “AlphanumericSerialNumber” value is shown differently for each monitor. Not being able to recognise two identical monitors connected at the same time might be a MacOS issue. I will see if there is any workaround for this.

Just to clarify, EDID ID is expected to be identical between two ES07D03’s because they share the same EDID.

Hi @asolochek & @ancher1912,

Frozen UI issue has been reported as well on a single monitor setup. This might be a bug and has been documented on our side. I will report here once I receive more feedback.

Hi @asolochek & @p_giguere1,

This is really interesting.

QQ - What firmware version are you running? This used to happen to me but once I upgraded my spectrum to 105, my VRR never reverted back down to 30hz, unless I do a firmware update which resets everything in the OSD setting which can have some effect on your macOS display settings.

@NZgeek - Is this the same for you?

I’m not running into any issues with VRR. However, my MBP is an Intel one so it’s limited to 60Hz (thanks Apple!) with no VRR support. I know that I’m due to an upgrade to a M1 MBP, but it’s likely a couple of months away.

For the waking from sleep issue, I haven’t had any major issues lately. I did have one time a few weeks back where the Spectrum continued to show a black screen, but I was able to use the power button to turn the Spectrum off and back on again and everything was fine after that.

I also appear to be one of the lucky few who upgraded their USB firmware along with the v106 scaler firmware, and didn’t have any issues with USB-C connectivity.

1 Like

I’m running the latest firmware. 106 and whatever the USB firmware that came out around the same time was.

1 Like

Are you saying you don’t believe it is a bug in the firmware that the serialnumber fields are always 0x01010101 because the alphanumeric serial number fields are correct and that works on windows? Does the display port specification say that only one of those two field needs to be unique? Why not just make the serial number field the numeric portion of the entire serial number to make things work for those of us with macs who supported eve enough to order multiple monitors?

I also thought about this earlier, but never got around to posting it.

While Windows may make use of the alphanumeric serial number, it’s possible that macOS only makes use of the 32-bit numeric serial number. It would make a lot of sense to have the numeric portion of the serial number reported in this field.

It appears that the numeric portion of the serial number is 9 digits so there shouldn’t be any issues converting this to an integer.

I’m limited to 60Hz too :confused: Can’t wait to upgrade to an M1 MBP.

You and me both! Could be an Intel thing as I’ve only seen M1 MBP with the USB firmware issue.

Yeah, that’s really strange, please contact support and I’ll inform the fw team in regards to your issue.