Driver failure after Windows update

My V completely failed today. I was on Firefox working on something in Google sheets, all of a sudden keyboard stops working (in Bluetooth mode), Bluetooth mouse stops working (Logitech m510) and error messages started popping up before it bluescreened. I restarted the computer and here’s the drivers that are corrupted.


This may also explain why the battery life has been dismal, if the laptop is constantly looking for drivers on the background, it’ll drain the battery much faster. I did notice that there’s a Windows update error after I installed the drivers from Eve that aren’t properly signed.

Fingerprint sensor no longer works
V Keyboard isn’t recognised as a keyboard, and is listed as other device instead.

Windows update doesn’t resolve issues due to proprietary drivers from Eve… That I had to uninstall to get the system to run.


So basically Windows update now constantly runs, trying to download and install drivers even though the existing ones are “better” but don’t work. Endless loop…

The wear and tear for 3 months of this on the battery is apparent.


Another issue related to Windows update: Netflix app from Windows no longer loads. There is an update in queue but it says installing indefinitely.

Interestingly, those drivers all look like whats available on the support downloads.

edit: I mean these:

Sounds like an update got screwed up somewhere down the line. Normally I would consider it something wrong with the Windows driver cache or the motherboard; but considering there’s an update error, I think the update store was corrupted either out of the box or during an update previously. Once you installed your own drivers, it didn’t match the now corrupted drivers and it’s very possible Windows tried to “fix it with a broken tool”.

You could try repairing the component store and flushing the update and driver cache, and if support could send you a complete driver package, that should fix things just fine. Of course, this is the more complicated option, but you would be able to keep all of the changes and setup you’ve already done to your device.

If the above option doesn’t sound great, support should be able to send you a Windows image so that you can reinstall Windows from scratch. This is the technically easier option, but may require more work depending on how much work it will take to get your device back to the way it was.


Yup, the problem is, even when I force uninstall drivers from device manager, it self reinstalls every time I restart the computer. Windows doesn’t recognize the self reinstall, so it attempts to download the drivers through Windows update. It’ll try to install and fail, creating error msgs and popups about having issues installing an update.

I’m in the middle of a project for a client so a fresh install is out of question

Hi Richard!

Sounds like there was a Windows update that f*ed things up majorly - you were a HEB, correct? If so, then I guess it happened during the installation of the FCU - I’ve personally seen something similar to this happen on my personal Desktop.

As for potential solutions:

  • Boot the V in Safe Mode ( Shift + Restart and hangling through a few menus)
  • In Safe Mode use the CMD in Admin-Mode to do the following:
    • pnputil -e > C:/Drivers.txt
      • This will create a .txt with all listed drivers and their installer
    • Go through the list and note the Drivers to be removed (especially their numbers)
    • Remove the ‘corrupt’ drivers with pnphtil -d (drivername).inf

After that a reboot and an automated Windows Update (no manual installation of the V drivers for now) at least all drivers should install via Windows Update.
After that you should be able to install all the drivers from our homepage.

Your Error-Message says it can’t access the Windows Update which is very weird tbh. Do you have any 3rd Party Antivirus Software installed? If yes, disabling that might also fix your problem (at least for the updates - please enable it again afterwards :smiley: )


I am weary of manually deleting drivers (especially if I delete the wrong ones) for fear of bricking the V. I am waiting for support to email me back


Hi @iKirin

I finally had the time to sit down and try to figure this out. I just reset my computer, but now I am running into Windows Update errors with 1803 (says device hardware not supported) . Any tips? I have not installed anything, no antivirus or software. Bluetooth still doesn’t recognize keyboard when its wireless.


1 Like

Latest windows update isn’t supporting the Intel 600p I think.
Check out the windows update thread for more information.


@TheDestiny did pretty much give the summary.

There’s a known issue with the 600p SSD where if you install Windows there’s a chance for a bootloop - it’s a known issue and our partners at Microsoft and Intel are on it. While you can install 1803 and it can work just fine (I’m one of the lucky ones) I’d not recommend it.

As for the keyboard, can you check the following:

  • Keyboard is turned on (blinked once when pressing Ctrl+BT)
  • After that press the BT-Button for ~3 seconds until the LED at the bottom right starts blinking blue.
  • Then the V Keyboard should show up when searching.

I tried it. The V sees the laptop and “connects” but it doesn’t allow typing. Same issue before and after reformatting.

Try the new update of today. You could have a resolution just like that if you can

Still no luck. Reformatted the computer again, and still running into issues with 1803.

The same issues than before ?

OMG I found a fix. It’s the dumbest fix ever. SO after my 3rd full wipe, I unplugged my V, ran the update and took a shower. I came back and it’s fully updated now to 1803!!! I am going to install Adobe CC, and update accordingly…

Installing update with internet connection off is a possible tip for other “II cannot update to 1803” people?