DP over Type-C vs. HDMI (washed out blacks?)

Hi all,

First let me start saying that this does not seem to be a Eve Spectrum issue, I am reaching out the community to see if this has some kind of tech explanation :slight_smile:

When I use the DP over TypeC I get this level of “blacks”:
image

When I use HDMI it is much better balanced (i.e.: darker):
image

I also used a HP G2 Thunderbolt dock and its DP out and I get the same “quality” and I can compensate/improve a little if I change gamma from 2.2 to 2.6 when using DP over Type-C.

Here I overlapped the 2 photos, seems easier to see the difference
image

Is this expected?
Anything we can do to match DP over Type-C vs. HDMI?
Anyone out there that can try to reproduce this? (try the same wallpaper, it helps :smiley: )

Thanks,
ER

1 Like

Hmmm I think I have an idea about why this might be a thing. What kind of graphics card are you using and what version are your drivers on?

1 Like

Hi,

It is a LGgram laptop i7-1165G7 with Iris Xe graphics running with driver 30.0.101.1960 dated 29/04/2022

1 Like

Now I did a quick test, I removed the registry key that was allowing me to use the latest Intel driver (instead of Windows Update version i.e.: ExcludeWUDriversInQualityUpdate) and then I let Windows install the driver automatically from WU.

Now I am running 27.20.100.8853 dated 14/10/2020 and looks like there is no difference :dizzy_face:

Could this be related with output dynamic range full / limited? I need to check where I can find that option to toggle and test again :slight_smile:

1 Like

Update:

No go with the latest Graphics Command Center, seems Intel removed the option to select either Full or Limited RGB options. What is strange is that if I select 144Hz refresh, the black level is correct.

@sr20 Any tips or alternatives solutions you can think of?

Thanks,
ER

1 Like

Thats honestly very peculiar. Have you tried multiple different USBC cables?

1 Like

Yes I did… I have 3, all rated 100W, two are certified TB3 cable. Rolling back the driver to the original LG/Windows update seems to fix it.
Now I am running a 2 year old driver but by default works with the right RGB config.

1 Like

Hi @ERodrigues,

Thanks for this. I will bring this up in the firmware meeting tomorrow and get back to you.

Can you please confirm this is with HDR disabled?

1 Like

Hi @ERodrigues,

As Marvin stated, this will be brought up as a discussion later to see if we can come up with something else.

For me, this seems like a result of how different each connection standard handle video signals. Since you are using Intel graphics chipsets you should look for an option called Quantization Range in the Intel Graphics Control Panel and ensure it is set to ‘Full Range’.

2 Likes

@Cas / @MarvyMarvz

I will leave to you as decision to bring this up with firmware team; from my findings, this does not appear as a Spectrum issue but maybe I am wrong and there is some kind of hand-shake between laptop and monitor over what RGB range to support?

@Cas, regarding

Since you are using Intel graphics chipsets you should look for an option called Quantization Range in the Intel Graphics Control Panel and ensure it is set to ‘Full Range’.

Unfortunately, the Intel Graphics Control Panel was replaced with the Intel Graphics Command Center and the Quantization Range removed from the available options when using new drivers:

Quantization Range Option Is Not Visible in the Intel® Graphics…
:slightly_frowning_face:

2 Likes

Hi @ERodrigues,

I don’t think it is firmware either, but discussing with the internal team may give us more ideas on what can be done :slight_smile:

We’ll get back to you when we have more stuff that you can try to fix/alleviate the issue!

Hmm that’s interesting… On this link it seems like it is still there (even after name change to Intel Graphics Command Center). Maybe it is hidden on your device somehow?

1 Like

Cool.

I just wanted to ensure that the message from my side was clear that I am not pointing fingers at the Spectrum :pray:

On the possibility of the option being hidden, that is what I thought too but no, it appears that they simply just removed it:
image

One can read Intel statement on that: “This is expected behavior. With the most recent drivers (xx.xx.100.xxxx and newer), the Quantization Range option will only be visible if the video output on your computer is native HDMI. Using a DisplayPort (DP) video output or adapters such as DP-to-HDMI or USB Type-C to-HDMI will cause the option to disappear.

I tried both the “normal” release and the “beta” as you can see from the screenshot. Both are missing the option…

Intel says that the option will only be available in HDMI mode and I confirm:
image

… now let’s get more confusing shall we?

in HDMI both FULL and LIMITED still appears to be darker when when using DP over Type-C :dizzy_face: … but needs further testing to confirm.

I am running the default/old Xe driver which works fine but when time permits I will use again the updated driver and compare again DP over Type-C vs. HDMI Full vs HDMI Limited

Maybe there is technical explanation for this, thus why I was hoping that someone here could chip in and provide some light :slight_smile:

Thanks,
ER.

2 Likes

Update:

30.0.100.9684 Black levels = OK
30.0.100.9955 Black levels = OK
30.0.101.1069 Black levels = OK
30.0.101.1660 Black levels = OK
30.0.101.1960 Black levels = not OK - latest version

The only version that is not working properly is the LATEST version, even the immediate prior works OK.

I checked Intel’s release note and I can only see fixes for games :dizzy_face:

1 Like

Hi @ERodrigues,

I am sorry. What do you mean exactly by “OK”? Does this mean that you are not experiencing washed-out blacks (on DP/USB-C) when you are not on the latest driver?

1 Like

Yes, when “not OK” I meant that the black levels were not OK. I edited the post to help.

2 Likes

Correct, it is with HDR disabled

2 Likes

Update:

30.0.100.9684 Black levels = OK
30.0.100.9955 Black levels = OK
30.0.101.1069 Black levels = OK
30.0.101.1660 Black levels = OK
30.0.101.1960 Black levels = not OK
30.0.101.1994 Black levels = OK (build May 13, 2022 / release May 25, 2022)

Nothing in the change log that could even remotely indicate a fix towards this issue… :smiley:

1 Like

Gotta love it when that happens. Lol.

BTW, which firmware are you running on the Spectrum?

At the moment, I am using the VRR PS4 Test4 bin (although it has some limitations on my setup)

1 Like

Test 5 is posted to the PS5 VRR thread, post 110.