Device Updating Fail — Spectrum bricked?

When updating my Spectrum, the firmware update tool’s progress bar restarts a couple times and then says ‘Device Updating Fail’. My Spectrum will not boot past the Eve logo.

Is my monitor bricked?

It is no longer turning on at all — neither the indicator light nor the screen are ever lit, and the buttons are unresponsive. The USB hub no longer connects to my PC either. It reverted back to the above state after I left it for a couple of minutes then held the power button. To be clear, the monitor is still not booting past a black screen.

Hi @JacobCXDev,

Just to clarify, you left the Spectrum on update process and the progress bar restarts by itself?
You might want to check this topic since it seems like you are experiencing a similar issue. If you give the monitor ample time (more than 10 minutes) to process its update, you can try power cycling by unplugging it from power then turning it back on.

If multiple attempts yield the same result, I recommend you to reach out to our support team.

Hi there.

Unfortunately, my monitor never even said ‘processing update’, nor did the indicator light change colour. I’ve left it on overnight, and it appears to still be in the same state.

If it is indeed bricked, is there a recovery mode I can use to flash new scaler firmware (like a DFU mode on iPhones)? Also, if it’s possible to give the support team a nudge to respond to my ticket ASAP, that would be great — I can’t really go without a monitor for long :sweat_smile:.

Hi @JacobCXDev,

There are other methods that you can try. To be honest with you I have little to no experience to this so I can’t guide you through it.

As for support, please DM me your ticket/order number.

I can see mention of using the power button, but no mention of cutting power completely.

Have you tried turning off power at the wall, or at least pulling the DC jack out of the Spectrum? Make sure that the power is off/disconnected for at least 5 seconds. This ensures that there’s no old data in working memory that might conflict with the new firmware.

1 Like

As noted above by Jamie as well as in the instructions.pdf, in step 9, you need to unplug the machine from power, not use the power button. The power button will do absolutely nothing when trying to flash firmware in terms of giving the Spectrum the power cycle that it needs to perform. This is a necessary step as all components need to be powered off fully before the firmware will proceed with the update.

Also, the way the firmware is written, the Spectrum has a backup of the factory installed fw version, which it will use if the flashing process fails for any reason. I ran into something similar as you did in that I got a report of my unit flashing having failed, but after a power cycle (again, full removal of power), the monitor came on when I applied power again and turned it on, and I was back at good old v.085 of the firmware.It then allowed me to flash the fw again, which was successful.

However, one thing I would suggest also doing is to disconnected everything from the Spectrum, then remove power, leave it off for about 10 minutes, then only connect power, and see if it gets past the logo or not. This means anything connected to a video input (remove the cables from the back of the monitor), anything connected to the USB ports open the bottom at the back, and anything connected in the USB ports on the side - absolutely nothing should be connected to the Spectrum when you try this.

That all being said - if you remove it from power, at least for 10 seconds, and it still does not power on (semi) normally with a viewable OSD screen after, please contact support directly. Its not unheard of that devices may go stupid when flashing firmware, and if so, there is not a lot that can be done at this point.

1 Like

i have the same exact problem. When i try to update to 106 firmware from 104 the firmware update tool’s says ‘Device Updating Fail’.
A couple month ago I have installed the 104 firmware without any problem.

1 Like

Do you have anything plugged into the Spectrum’s USB hub (left-side ports)? If so, try unplugging everything and see if that helps.

1 Like