Can't Update Firmware

Hi, i’m here because i can’t update the firmware, i use a usb c cable that connect to monitor and put the usb a into the pc but tell me that device disconnect. Hi set all settings on the monitor that tell the pdf. Thank you

Hi @Edoardo_Pinucci,

Please make sure that you are using the USB-C port located on the bottom of the monitor.

Hi, yes I used several working cables but the result does not change, it seems strange to me that they have not done anything in assistance because there was a month for the display change, but I had also written about this other problem but they did not update it

And also I tried a usb a to usb a the result not changed

Hi @Edoardo_Pinucci,

I am sorry, but i don’t quite understand what you were trying to explain with waiting for a month for display change.

For update connection you have two options:

  1. To connect using USB-C to USB-C. Make sure that you are using the USB-C at the bottom of the monitor and set the OSD USB hub source to USB-C. Or…
  2. To connect using USB-A to USB-B. Set the OSD USB hub source to USB-B (also at the bottom of the monitor)

Using USB-A to USB-A will not work.

yes i apologize for my bad english, the monitor has been in service for some dead pixels, they told me to write what problems the monitor had, and i wrote this thing that i could not update the monitor. They haven’t solved it because I have the old firmware.
For the return I have set everything in the settings but it continues to give me the disconnected device

Hi @Edoardo_Pinucci,

Sorry I’m trying to understand the situation more clearly here.

If you have issue with dead pixels, I doubt updating the firmware can fix it.

Do you mind sharing the screenshot is showing on the screen when you attempt the update?

Didn’t work for me either, I had to use the USB Type B port

Hi @MrFluffles & @Edoardo_Pinucci,

I’ve seen a fantastic post by Jamie regarding the cable and port you are using to update the firmware. Please take a look at the below and action as necessary.

1 Like

yes, I have already sent the monitor for repair, and it also came back but the update problem did not solve it

thank you, i used all cable that i have, also a usb c to usb c of apple and not change

Hi @Edoardo_Pinucci,

I think I understand what you are trying to convey.

I don’t think the service centre will update the firmware if the monitor itself has no problem related to firmware. In this case, your firmware stayed intact since dead pixels have nothing to do with firmware.

Remember that it is not recommended to update the firmware unless it is absolutely necessary to fix an issue you are encountering. If you do want to proceed with it, please follow the instructions carefully. You may also check the topic posted above and topic about version 106 for guidance.

If you use USB-C to USB-C, you will need to set the USB hub source to USB-C and set it to “always on”.

If it still fails, then you might need to use a USB-B cable, since it is possible that the USB-C cable you are using is not supported. Remember to change the USB source to USB-B when doing so.


A lot of USB-C cables are designed for charging devices only. They don’t contain all of the wires necessary to pass through a data signal. The cables that Apple provide with their power adapters are like this - they won’t carry any USB data.

Please take a look at the link that @MarvyMarvz posted a few days ago. It’s to a post that I made, and it goes into a lot of detail about the types of cable that you can use for a firmware update. I also talk about the types of USB-C cable that probably won’t work, and how to test cables to check if they will work.