Can't turn on the monitor

I still used it today morning for gaming, but now i can’t turn on the monitor, no any response, i have try to power on and off.

Any ideas what I could try/check?

I’m having occasional issues with the non-glossy monitor. Today I had to press the power button like 7 times before it turned on.

1 Like

Your monitor still not work now?

Hey there, so nothing is happening when you try to turn back on the monitor no LED indicator light etc?

Here are something’s provided by @NZgeek that you can try

Was this just random or after updating firmware?

Still can’t turn on the monitor, no firmware updated.

Any repair solution ?

Have you tried unplugging the power cable? Unplug the cable from both the Spectrum and the wall, wait 5 minutes for any residual power to drain, then plug it in and try again.

If that doesn’t help, follow the link that @Aethel posted just above and try some of my tips for getting the screen to turn on.

Keep note of everything you try, and what the Spectrum does after trying that thing. For example:

  • Pressed power button: power LED is not lit, screen stays black, no signs of backlight being on
  • Held power button for 5 seconds: same as above
  • Unplugged power cable for 10 seconds: same as above
  • Left power unplugged overnight: power LED flashes briefly but then stays off, screen stays black, no signs of backlight being on

Knowing what you’ve done and why happens as a result will help us to identify whether this is a serious problem or not. There might also be a step you’ve missed that we can help with.

And if nothing works and you need to file a warranty request (RMA) with the support team, this list will help. They’ll usually get you to try a series of troubleshooting steps before they’ll allow the RMA. If you can show that you’ve tried everything already, you can speed up process.

1 Like

I’ve tried all the solutions you suggest, but still press the power button and no any response include led light.

Just to confirm:

  1. The power LED remained unlit, no matter what you did.
  2. You unplugged the power connection from the wall, then plugged it back in.
  3. You unplugged the power connection from the Spectrum, then plugged it back in.

The lack of power LED says that the Spectrum probably isn’t receiving power.

There is one power connection that we haven’t checked yet. Can you please:

  1. Turn off power at the wall.
  2. Find the Spectrum’s power brick.
  3. Unplug the cable that goes to the wall outlet. It uses the same type of plug as a normal PC power supply.
  4. Blow hard into the socket in the power brick, and into the 3 small holes in the end of the power cable. You want to dislodge any dust or debris that might be in there.
  5. Plug the cable back into the power brick. Push them together firmly to make sure that there’s a good connection.
  6. Turn power back on at the wall. Check if the Spectrum’s power LED lights up.

If this works, it’s likely that you had a bad connection between the wall cord and the power brick.

If this doesn’t work, either the power brick has died or something inside the Spectrum has stopped working. You’ll need to ask support for a warranty return. Make sure you give them as much information as possible when you do this - the support team are usually slow to respond, and you want to reduce how many times they come back to you asking for more information.

i tried to connect the power cable to another monitor that works, so i don’t think there’s any power or cable problem.

I recommend contacting our support team and explain to them the situation so they can further diagnosis and continue with the next steps to assist with your case.

i have contacted the support team , but no reply yet .

Can you DM me your order ID and I will have them reach out to you about this.

l still not recevied any follow up action from support team