Can't get firmware 106 update program to detect device

I’ve downloaded the firmware update 106 package and set up the installer, but every time I run it it just shows the “Device disconnect…” error. I’ve tried connecting both with a USB 3 type B cable and a USB 2 type B cable, and the OSD settings are as specified in the instructions (USB type B as hub source, and set to always on). I’ve tried power cycling the monitor a few times (by unplugging it), and no luck.

What should I do?

Hi @copascetic,

Welcome to the community!

You want to make sure that the installer is run with admin privileges.

Yes, it is run with admin privileges each time, with the same result. (It gives me a UAC prompt regardless of whether I explicitly run it as admin.) I am on Windows 11, if that matters.

If you are using another USB hub, try to connect the monitor’s USB hub directly to PC.

If that’s not the case or does not help, try to enable compability with Windows 10 (if W11 provides such an option) in the firmware-updater executable properties.

I had a similar sounding problem on one of my monitors, I just closed the updater, unplugged the USB and then plugging back in and re-ran the updater (unplugging on the spectrum side seemed most effective). Did that a few times along with fairly randomly clicking refresh and eventually it found it. Strangely it worked first time on my other monitor.

Other people also suggested having other devices connected to the Spectrum’s hub makes it less reliable but that didn’t seem to bother mine but worth a try.

Basically, it’s a bit flaky but, for me at least, works eventually.

(Oh, this is also on windows 11)

So, I’ve tried a few different cables, directly and indirectly connected to the PC, and nothing is working. When I connect and disconnect I can’t even see a new device show up in the USB device tree. At this point I also checked whether the internal USB hub works at all, as I’ve not actually used it yet (only DP 1.4 or HDMI for display), and it doesn’t… Any other theories? How can I debug this?

The USB hubs have always been reliable for me so if you have any USB device (something like a mouse), check that it works plugged directly into the PC then use the same USB port to connect to the monitor and try the same device plugged into the spectrum hub. If that works then the hub is working, if it doesn’t then either the hub or the cable is faulty (although the fact that you’ve tried multiple cables suggests that it’s not the cable).

Also I’ve also just checked and when I plug in the USB cable with nothing else connected to the spectrum hub I get a ‘usb device connected’ audio notification but nothing else.

Hi @copascetic,

When running the firmware installer, did you have any other devices connected to your PC? If so, I would suggest to disconnect any other peripherals before running the updater.

Yes, the devices I’m testing work perfectly when plugged directly into the PC or into another hub that I use. And yeah, I would expect the hub itself to show up in the USB device tree, but it doesn’t.

The only other devices are a USB keyboard and USB mouse.

So have you tried plugging the spectrum hub into the PC via a USB A to B cable then plugging a device into the spectrum hub (any of the USB ports on the left hand side of the monitor) and do those devices not show up or work?

If that doesn’t work and the same device plugged into the same USB port on the PC that you used to connect to the spectrum does appear and work then it’s looking like the spectrum USB hub may be faulty (or you’ve got very unlucky with the USB A to B cables you have tried which is possible).

Yes, that’s the scenario I’m describing. Neither the hub itself nor any devices plugged into it show up. The cable I’m using is also known to work (I normally use it with a different hub).

Would you mind double-checking that the USB hub source setting it sticking?

I know this sounds like a silly thing, but it’s worth checking that the Spectrum is actually using the hub source you think it should be using. Also, it’s easy to forget that you have to press right on the stick when selecting the hub source; clicking the stick just closes the OSD without changing anything.

If the correct hub source is sticking, it’s also worth leaving the USB cable plugged in while you disconnect the Spectrum’s power for a few seconds. Forcing a full reboot might be enough to get things moving again.

Yeah, I’ve power-cycled the spectrum (by unplugging for 10+ seconds) and gone back into the OSD and confirmed that the settings are as expected. See picture.

Afraid I’m out of ideas, not sure if anyone else can think of anything, it does sound like the Hub is broken.

The only two final final tests I can think of are -

Plug the other hub that you got that cable from into the PC, plug something in to test it works then plug the same cable into the spectrum without disconnecting it from the PC and try the same thing plugged into the spectrum hub.

Or, maybe get a new USB B cable just in case you’ve been very very unlucky and that cable is broken in some way that means it happens to work in your hub but not the spectrum but that’s really clutching at straws (although I’m sure stranger things have happened).

Failing all that it may be time for @Cas or someone else from eve to jump back in and suggest what you can do, I expect they’ll point you at support.


Yeah, I will try those extra steps soon and let you know. It does seem like I have a borked USB hub though. :frowning:
Thanks for your ideas!

Hi, I did have one more thought, it might just be the USB-B connection that is borked, if you have a USB-C data cable you could try that, again, worth checking it works first plugged into the PC with a USB-C device if you have one (there are apparently a lot of USB C cables out there that are charge only so none of the data pins are connected).

Hi @copascetic,

I agree with @OldAsh here. Before ruling out that the USB hub is defective, I suggest you to try to connect using USB-C and see if it works.

I am sorry, but I am running out of ideas other than contacting support if USB-C still doesn’t work for you.

1 Like

The USB C display input and hub function also do not work. When connecting my laptop I don’t even see the laptop try to display anything (no monitor is detected, as opposed to the laptop detecting it and the monitor just not showing anything). I also don’t see a USB hub device in my device tree, just like for the USB 3 type B port.

I’m going to ask just in case but I expect the answer is yes, have you confirmed that the cable you’re using isn’t a charge only cable?

If it is a data cable then it does look like the monitor is faulty, I genuinely don’t know if all USB C data cables can carry video but worst case it should allow you to use the USB hub. :frowning: